aboutsummaryrefslogtreecommitdiffstats
path: root/packages/git
diff options
context:
space:
mode:
authorMichael Krelin <hacker@klever.net>2007-05-08 15:48:50 +0000
committerMichael Krelin <hacker@klever.net>2007-05-08 15:48:50 +0000
commitcfc067b7935b039556c6867710889ca726d8e908 (patch)
tree4ec657250a8cf12f9fc7c1842f2f8b14b99fe114 /packages/git
parent397955bf9ffc367df8f979d1e441e3f405bed2ee (diff)
downloadopenembedded-cfc067b7935b039556c6867710889ca726d8e908.tar.gz
git: minor fixes to make git work on the device. Closes #2226 and #2240
- Adjust path to templates directory to fix `git init-db` - Make it depend on cpio and findutils as at least local `git clone` relies on them.
Diffstat (limited to 'packages/git')
-rw-r--r--packages/git/git_1.4.4.2.bb10
1 files changed, 9 insertions, 1 deletions
diff --git a/packages/git/git_1.4.4.2.bb b/packages/git/git_1.4.4.2.bb
index 37f71cfb04..5a22f040f3 100644
--- a/packages/git/git_1.4.4.2.bb
+++ b/packages/git/git_1.4.4.2.bb
@@ -1,3 +1,11 @@
require git.inc
DEPENDS = "openssl curl"
-RDEPENDS = "perl perl-module-file-path"
+RDEPENDS = "perl perl-module-file-path cpio findutils"
+
+PR="r1"
+
+do_install() {
+ oe_runmake install DESTDIR="${D}" bindir="${bindir}" \
+ template_dir="${datadir}/git-core/templates" \
+ GIT_PYTHON_DIR="${datadir}/git-core/python"
+}