aboutsummaryrefslogtreecommitdiffstats
path: root/packages/git
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2007-08-03 22:22:08 +0000
committerHenning Heinold <heinold@inf.fu-berlin.de>2007-08-03 22:22:08 +0000
commitd94e95c91846ccb048c3f6bfa06a34c5369731dc (patch)
tree162d58828ba8ae9a1fd8be0940678722f5604103 /packages/git
parentf68a0b07dbfc2335454d3025e6261f32b2cffa3a (diff)
downloadopenembedded-d94e95c91846ccb048c3f6bfa06a34c5369731dc.tar.gz
git: fix runtime issues
* fix config.mak.in to export LDFLAGS, now it compiles and runs in a sane way * remove the OEMAKE_EXTRA hack for LDFLAGS * bump PR
Diffstat (limited to 'packages/git')
-rw-r--r--packages/git/files/autotools.patch14
-rw-r--r--packages/git/git_1.5.2.3.bb4
2 files changed, 15 insertions, 3 deletions
diff --git a/packages/git/files/autotools.patch b/packages/git/files/autotools.patch
index 7625a0da63..0666118cde 100644
--- a/packages/git/files/autotools.patch
+++ b/packages/git/files/autotools.patch
@@ -1,7 +1,7 @@
Index: git-1.5.2.3/configure.ac
===================================================================
--- git-1.5.2.3.orig/configure.ac 2007-07-02 10:11:39.000000000 +0200
-+++ git-1.5.2.3/configure.ac 2007-08-03 22:14:10.000000000 +0200
++++ git-1.5.2.3/configure.ac 2007-08-04 00:02:13.000000000 +0200
@@ -235,7 +235,8 @@
else if (strcmp(buf, "12345"))
exit(2);]])],
@@ -12,3 +12,15 @@ Index: git-1.5.2.3/configure.ac
])
if test $ac_cv_c_c99_format = no; then
NO_C99_FORMAT=YesPlease
+Index: git-1.5.2.3/config.mak.in
+===================================================================
+--- git-1.5.2.3.orig/config.mak.in 2007-07-02 10:11:39.000000000 +0200
++++ git-1.5.2.3/config.mak.in 2007-08-04 00:07:04.000000000 +0200
+@@ -3,6 +3,7 @@
+
+ CC = @CC@
+ CFLAGS = @CFLAGS@
++LDFLAGS = @LDFLAGS@
+ AR = @AR@
+ TAR = @TAR@
+ #INSTALL = @INSTALL@ # needs install-sh or install.sh in sources
diff --git a/packages/git/git_1.5.2.3.bb b/packages/git/git_1.5.2.3.bb
index f70d840c4c..db43aa71fd 100644
--- a/packages/git/git_1.5.2.3.bb
+++ b/packages/git/git_1.5.2.3.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "The git revision control system used by the Linux kernel developers"
SECTION = "console/utils"
LICENSE = "GPL"
-PR="r3"
+PR="r4"
inherit autotools
@@ -14,7 +14,7 @@ S = "${WORKDIR}/git-${PV}"
DEPENDS = "openssl curl zlib expat"
RDEPENDS = "perl perl-module-file-path cpio findutils sed"
-EXTRA_OEMAKE = "NO_TCLTK=1 LDFLAGS=${LDFLAGS}"
+EXTRA_OEMAKE = "NO_TCLTK=1"
do_install() {
oe_runmake install DESTDIR="${D}" bindir="${bindir}" \