aboutsummaryrefslogtreecommitdiffstats
path: root/packages/git
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2007-08-03 20:44:20 +0000
committerHenning Heinold <heinold@inf.fu-berlin.de>2007-08-03 20:44:20 +0000
commitf68a0b07dbfc2335454d3025e6261f32b2cffa3a (patch)
treeff3fd0a092a49b2c9c9f7abc005964075ed6061d /packages/git
parent53c20a77542d9dd39cbecb6aeeb0144bc3ef49fd (diff)
downloadopenembedded-f68a0b07dbfc2335454d3025e6261f32b2cffa3a.tar.gz
git: fix building of git 1.5.2.3
* remove git.inc because 2 files are enough * let git-native require git * override RDEPENDS in git-native * switch to autotools * add files/autotools.patch so we can crosscompile * adding expat and zlib to the DEPENDS
Diffstat (limited to 'packages/git')
-rw-r--r--packages/git/files/.mtn2git_empty0
-rw-r--r--packages/git/files/autotools.patch14
-rw-r--r--packages/git/git-native_1.5.2.3.bb7
-rw-r--r--packages/git/git.inc15
-rw-r--r--packages/git/git_1.5.2.3.bb21
5 files changed, 37 insertions, 20 deletions
diff --git a/packages/git/files/.mtn2git_empty b/packages/git/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/git/files/.mtn2git_empty
diff --git a/packages/git/files/autotools.patch b/packages/git/files/autotools.patch
new file mode 100644
index 0000000000..7625a0da63
--- /dev/null
+++ b/packages/git/files/autotools.patch
@@ -0,0 +1,14 @@
+Index: git-1.5.2.3/configure.ac
+===================================================================
+--- git-1.5.2.3.orig/configure.ac 2007-07-02 10:11:39.000000000 +0200
++++ git-1.5.2.3/configure.ac 2007-08-03 22:14:10.000000000 +0200
+@@ -235,7 +235,8 @@
+ else if (strcmp(buf, "12345"))
+ exit(2);]])],
+ [ac_cv_c_c99_format=yes],
+- [ac_cv_c_c99_format=no])
++ [ac_cv_c_c99_format=no],
++ [ac_cv_c_c99_format=yes])
+ ])
+ if test $ac_cv_c_c99_format = no; then
+ NO_C99_FORMAT=YesPlease
diff --git a/packages/git/git-native_1.5.2.3.bb b/packages/git/git-native_1.5.2.3.bb
index f91fd03ab1..7ddfee0d08 100644
--- a/packages/git/git-native_1.5.2.3.bb
+++ b/packages/git/git-native_1.5.2.3.bb
@@ -1,3 +1,6 @@
-require git.inc
+
inherit native
-DEPENDS = "openssl-native curl-native"
+require git_${PV}.bb
+
+DEPENDS = "openssl-native curl-native zlib-native expat-native"
+RDEPENDS = ""
diff --git a/packages/git/git.inc b/packages/git/git.inc
deleted file mode 100644
index 384dfaaeec..0000000000
--- a/packages/git/git.inc
+++ /dev/null
@@ -1,15 +0,0 @@
-DESCRIPTION = "The git revision control system used by the Linux kernel developers"
-SECTION = "console/utils"
-LICENSE = "GPL"
-
-SRC_URI = "http://www.kernel.org/pub/software/scm/git/git-${PV}.tar.bz2"
-S = "${WORKDIR}/git-${PV}"
-
-do_install () {
- oe_runmake install prefix=${D} bindir=${D}${bindir} \
- template_dir=${D}${datadir}/git-core/templates \
- GIT_PYTHON_DIR=${D}${datadir}/git-core/python
-}
-
-FILES_${PN} += "${datadir}/git-core"
-
diff --git a/packages/git/git_1.5.2.3.bb b/packages/git/git_1.5.2.3.bb
index e6a1117316..f70d840c4c 100644
--- a/packages/git/git_1.5.2.3.bb
+++ b/packages/git/git_1.5.2.3.bb
@@ -1,11 +1,26 @@
-require git.inc
-DEPENDS = "openssl curl"
+DESCRIPTION = "The git revision control system used by the Linux kernel developers"
+SECTION = "console/utils"
+LICENSE = "GPL"
+PR="r3"
+
+inherit autotools
+
+SRC_URI = "http://www.kernel.org/pub/software/scm/git/git-${PV}.tar.bz2 \
+ file://autotools.patch;patch=1 \
+ "
+
+S = "${WORKDIR}/git-${PV}"
+
+DEPENDS = "openssl curl zlib expat"
RDEPENDS = "perl perl-module-file-path cpio findutils sed"
-PR="r2"
+EXTRA_OEMAKE = "NO_TCLTK=1 LDFLAGS=${LDFLAGS}"
do_install() {
oe_runmake install DESTDIR="${D}" bindir="${bindir}" \
template_dir="${datadir}/git-core/templates" \
GIT_PYTHON_DIR="${datadir}/git-core/python"
}
+
+FILES_${PN} += "${datadir}/git-core"
+