aboutsummaryrefslogtreecommitdiffstats
path: root/packages/git
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@rpsys.net>2007-12-01 19:04:36 +0000
committerRichard Purdie <rpurdie@rpsys.net>2007-12-01 19:04:36 +0000
commit7dce8cc1fe80f9e1ee4712339889728b8798b013 (patch)
tree8446b356f86a0d65e361e96a584cd5a93ab8f725 /packages/git
parent4bdcce051cee2d1c9c83f77c88a6f68726cedfe0 (diff)
downloadopenembedded-7dce8cc1fe80f9e1ee4712339889728b8798b013.tar.gz
Add git-native 1.5.3 (from poky)
Diffstat (limited to 'packages/git')
-rw-r--r--packages/git/git-native_1.5.3.bb4
-rw-r--r--packages/git/git.inc19
2 files changed, 23 insertions, 0 deletions
diff --git a/packages/git/git-native_1.5.3.bb b/packages/git/git-native_1.5.3.bb
new file mode 100644
index 0000000000..935c773c1c
--- /dev/null
+++ b/packages/git/git-native_1.5.3.bb
@@ -0,0 +1,4 @@
+require git.inc
+inherit native
+DEPENDS = "openssl-native curl-native zlib-native expat-native"
+PR = "r1"
diff --git a/packages/git/git.inc b/packages/git/git.inc
new file mode 100644
index 0000000000..7115d44b35
--- /dev/null
+++ b/packages/git/git.inc
@@ -0,0 +1,19 @@
+DESCRIPTION = "The git revision control system used by the Linux kernel developers"
+SECTION = "console/utils"
+LICENSE = "GPL"
+
+SRC_URI = "http://www.kernel.org/pub/software/scm/git/git-${PV}.tar.bz2 \
+ file://autotools.patch;patch=1"
+S = "${WORKDIR}/git-${PV}"
+
+EXTRA_OEMAKE = "NO_TCLTL=1"
+
+inherit autotools
+
+do_install () {
+ oe_runmake install prefix=${D} bindir=${D}${bindir} \
+ template_dir=${D}${datadir}/git-core/templates \
+ GIT_PYTHON_DIR=${D}${datadir}/git-core/python
+}
+
+FILES_${PN} += "${datadir}/git-core"