aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gizmod
diff options
context:
space:
mode:
authorJustin Patrin <papercrane@gmail.com>2007-01-21 20:34:40 +0000
committerJustin Patrin <papercrane@gmail.com>2007-01-21 20:34:40 +0000
commita01f1ba3c4046a1beb395acf21008864b1880156 (patch)
treeef440cccf186f70aef4c8a1de08a266e1b1a60d7 /packages/gizmod
parent2254c2110b3d8cded176e7d56268e77c64b4879d (diff)
downloadopenembedded-a01f1ba3c4046a1beb395acf21008864b1880156.tar.gz
gizmod: add gizmod
Diffstat (limited to 'packages/gizmod')
-rw-r--r--packages/gizmod/.mtn2git_empty0
-rw-r--r--packages/gizmod/files/.mtn2git_empty0
-rw-r--r--packages/gizmod/files/disable-bmp.patch105
-rw-r--r--packages/gizmod/files/disable-xmms.patch113
-rw-r--r--packages/gizmod/files/fix-python-configure.patch17
-rw-r--r--packages/gizmod/gizmod_2.3.bb24
6 files changed, 259 insertions, 0 deletions
diff --git a/packages/gizmod/.mtn2git_empty b/packages/gizmod/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/gizmod/.mtn2git_empty
diff --git a/packages/gizmod/files/.mtn2git_empty b/packages/gizmod/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/gizmod/files/.mtn2git_empty
diff --git a/packages/gizmod/files/disable-bmp.patch b/packages/gizmod/files/disable-bmp.patch
new file mode 100644
index 0000000000..89dfad3446
--- /dev/null
+++ b/packages/gizmod/files/disable-bmp.patch
@@ -0,0 +1,105 @@
+Index: gizmod-2.3/configure.ac
+===================================================================
+--- gizmod-2.3.orig/configure.ac
++++ gizmod-2.3/configure.ac
+@@ -319,76 +319,6 @@ fi
+
+ ###########################################################################
+ ##
+-## Check whether to build BMP plugin
+-##
+-
+-##################
+-## enabled?
+-########
+-
+-AC_MSG_CHECKING(Whether or not to build BMP plugin)
+-AC_ARG_ENABLE(bmp,
+- [ --enable-bmp build BMP plugin <default = no>],
+- [enable_bmp="$enableval"], enable_bmp=no)
+-AC_MSG_RESULT($enable_bmp)
+-
+-AM_CONDITIONAL(BUILD_EXTERNALPLUGIN_BMP, test x$enable_bmp = xyes)
+-AM_CONDITIONAL(BUILD_PLUGIN_BMPCONTROL, test x$enable_bmp = xyes)
+-
+-##################
+-## can we build it if it's enabled?
+-########
+-
+-if test "$enable_bmp" == "yes"; then
+-
+-BEEP_CFLAGS=""
+-BEEP_LIBS=""
+-
+-#check stuff
+-AM_PATH_GLIB_2_0(2.4.0, ,
+- AC_MSG_ERROR([GTK+ >= 2.4.0 not installed - required for BMP plugin]))
+-AM_PATH_GTK_2_0(2.4.0, ,
+- AC_MSG_ERROR([GTK+ >= 2.4.0 not installed - required for BMP plugin]))
+-
+-dnl check for beep
+-PKG_CHECK_MODULES(BEEP, [ bmp >= 0.9.7], ,
+- AC_MSG_ERROR("You need the BEEP development files to build the BEEP plugin!"))
+-
+-BEEP_PLUGIN_DIR="`$PKG_CONFIG --variable=output_plugin_dir bmp`"
+-BEEP_INPUT_PLUGIN_DIR="`$PKG_CONFIG --variable=input_plugin_dir bmp`"
+-BEEP_OUTPUT_PLUGIN_DIR="`$PKG_CONFIG --variable=output_plugin_dir bmp`"
+-BEEP_GENERAL_PLUGIN_DIR="`$PKG_CONFIG --variable=general_plugin_dir bmp`"
+-BEEP_VISUALIZATION_PLUGIN_DIR="`$PKG_CONFIG --variable=visualization_plugin_dir bmp`"
+-BEEP_EFFECT_PLUGIN_DIR="`$PKG_CONFIG --variable=effect_plugin_dir bmp`"
+-BEEP_DATA_DIR="`$PKG_CONFIG --variable=data_dir bmp`"
+-
+-AC_SUBST(BEEP_PLUGIN_DIR)
+-AC_SUBST(BEEP_INPUT_PLUGIN_DIR)
+-AC_SUBST(BEEP_OUTPUT_PLUGIN_DIR)
+-AC_SUBST(BEEP_GENERAL_PLUGIN_DIR)
+-AC_SUBST(BEEP_VISUALIZATION_PLUGIN_DIR)
+-AC_SUBST(BEEP_EFFECT_PLUGIN_DIR)
+-AC_SUBST(BEEP_DATA_DIR)
+-
+-dnl make BEEP_DATA_DIR a variable in config.h
+-AH_TEMPLATE(BEEP_DATA_DIR, "Path to bmp-touch.config")
+-AC_DEFINE_UNQUOTED(BEEP_DATA_DIR, "$BEEP_DATA_DIR")
+-
+-CPPFLAGS="$CPPFLAGS $BEEP_CFLAGS"
+-
+-AC_CHECK_HEADER(bmp/beepctrl.h, [
+- AC_DEFINE(HAVE_BEEPCTRL_H, 1, [Has bmp/beepctrl.h])
+- ], [
+- AC_MSG_ERROR([Cannot find beepctrl.h!])
+- ])
+-
+-AC_SUBST(BEEP_CFLAGS)
+-AC_SUBST(BEEP_LIBS)
+-
+-fi
+-
+-###########################################################################
+-##
+ ## Check whether to build Sound Visualization plugin
+ ##
+
+@@ -633,9 +563,7 @@ AC_CONFIG_FILES([
+ plugins/soundVisualization/Makefile
+ plugins/cpuUsage/Makefile
+ plugins/x11/Makefile
+- plugins/bmpControl/Makefile
+ plugins/externalPlugins/Makefile
+- plugins/externalPlugins/bmp/Makefile
+ plugins/lirc/Makefile
+ ])
+ AC_OUTPUT
+Index: gizmod-2.3/plugins/Makefile.am
+===================================================================
+--- gizmod-2.3.orig/plugins/Makefile.am
++++ gizmod-2.3/plugins/Makefile.am
+@@ -1 +1 @@
+-SUBDIRS=scriptingPlugins powermate alsaMixer xosd generic externalPlugins soundVisualization cpuUsage x11 bmpControl lirc
++SUBDIRS=scriptingPlugins powermate alsaMixer xosd generic externalPlugins soundVisualization cpuUsage x11 lirc
+Index: gizmod-2.3/plugins/externalPlugins/Makefile.am
+===================================================================
+--- gizmod-2.3.orig/plugins/externalPlugins/Makefile.am
++++ gizmod-2.3/plugins/externalPlugins/Makefile.am
+@@ -1 +1 @@
+-SUBDIRS=bmp
++SUBDIRS=
diff --git a/packages/gizmod/files/disable-xmms.patch b/packages/gizmod/files/disable-xmms.patch
new file mode 100644
index 0000000000..e8aea12b4c
--- /dev/null
+++ b/packages/gizmod/files/disable-xmms.patch
@@ -0,0 +1,113 @@
+Index: gizmod-2.3/configure.ac
+===================================================================
+--- gizmod-2.3.orig/configure.ac
++++ gizmod-2.3/configure.ac
+@@ -393,60 +393,6 @@ fi
+
+ ###########################################################################
+ ##
+-## Check whether to build XMMS plugin
+-##
+-
+-##################
+-## enabled?
+-########
+-
+-AC_MSG_CHECKING(Whether or not to build XMMS plugin)
+-AC_ARG_ENABLE(xmms,
+- [ --enable-xmms build XMMS plugin <default = yes>],
+- [enable_xmms="$enableval"], enable_xmms=yes)
+-AC_MSG_RESULT($enable_xmms)
+-
+-AM_CONDITIONAL(BUILD_EXTERNALPLUGIN_XMMS, test x$enable_xmms = xyes)
+-AM_CONDITIONAL(BUILD_PLUGIN_XMMSCONTROL, test x$enable_xmms = xyes)
+-
+-##################
+-## can we build it if it's enabled?
+-########
+-
+-if test "$enable_xmms" == "yes"; then
+-
+-XMMS_CFLAGS=""
+-XMMS_LIBS=""
+-
+-#check stuff
+-
+-AM_PATH_XMMS(1.2.4,
+- XMMS_CFLAGS=`xmms-config --cflags`
+- CPPFLAGS="$CPPFLAGS $XMMS_CFLAGS"
+- XMMS_LIBS=`xmms-config --libs`
+- ,
+- AC_MSG_ERROR([You must have the XMMS development headers installed to build the XMMS plugin!])
+-)
+-
+-AC_CHECK_HEADER(xmms/xmmsctrl.h, [
+- AC_DEFINE(HAVE_XMMSCTRL_H, 1, [Has xmms/xmmsctrl.h])
+- ], [
+- AC_MSG_ERROR([Cannot find xmmsctrl.h!])
+- ])
+-
+-AC_CHECK_HEADER(xmms/plugin.h, [
+- AC_DEFINE(HAVE_XMMSPLUGIN_H, 1, [Has xmms/xmmsplugin.h])
+- ], [
+- AC_MSG_ERROR([Cannot find xmms/plugin.h!])
+- ])
+-
+-AC_SUBST(XMMS_CFLAGS)
+-AC_SUBST(XMMS_LIBS)
+-
+-fi
+-
+-###########################################################################
+-##
+ ## Check whether to build Sound Visualization plugin
+ ##
+
+@@ -691,10 +637,8 @@ AC_CONFIG_FILES([
+ plugins/soundVisualization/Makefile
+ plugins/cpuUsage/Makefile
+ plugins/x11/Makefile
+- plugins/xmmsControl/Makefile
+ plugins/bmpControl/Makefile
+ plugins/externalPlugins/Makefile
+- plugins/externalPlugins/xmms/Makefile
+ plugins/externalPlugins/bmp/Makefile
+ plugins/lirc/Makefile
+ ])
+@@ -774,22 +718,10 @@ else
+ echo " BMP Control plugin: Disabled"
+ fi
+
+-if test "$enable_xmms" == "yes"; then
+- echo " XMMS Control plugin: Enabled"
+-else
+- echo " XMMS Control plugin: Disabled"
+-fi
+-
+ if test "$enable_bmp" == "yes"; then
+ echo " BMP Visualization plugin: Enabled"
+ else
+ echo " BMP Visualization plugin: Disabled"
+ fi
+
+-if test "$enable_xmms" == "yes"; then
+- echo " XMMS Visualization plugin: Enabled"
+-else
+- echo " XMMS Visualization plugin: Disabled"
+-fi
+-
+ echo
+Index: gizmod-2.3/plugins/Makefile.am
+===================================================================
+--- gizmod-2.3.orig/plugins/Makefile.am
++++ gizmod-2.3/plugins/Makefile.am
+@@ -1 +1 @@
+-SUBDIRS=scriptingPlugins powermate alsaMixer xosd generic externalPlugins soundVisualization cpuUsage x11 xmmsControl bmpControl lirc
++SUBDIRS=scriptingPlugins powermate alsaMixer xosd generic externalPlugins soundVisualization cpuUsage x11 bmpControl lirc
+Index: gizmod-2.3/plugins/externalPlugins/Makefile.am
+===================================================================
+--- gizmod-2.3.orig/plugins/externalPlugins/Makefile.am
++++ gizmod-2.3/plugins/externalPlugins/Makefile.am
+@@ -1 +1 @@
+-SUBDIRS=xmms bmp
++SUBDIRS=bmp
diff --git a/packages/gizmod/files/fix-python-configure.patch b/packages/gizmod/files/fix-python-configure.patch
new file mode 100644
index 0000000000..9b48c9790f
--- /dev/null
+++ b/packages/gizmod/files/fix-python-configure.patch
@@ -0,0 +1,17 @@
+Index: gizmod-2.3/configure.ac
+===================================================================
+--- gizmod-2.3.orig/configure.ac
++++ gizmod-2.3/configure.ac
+@@ -162,11 +162,7 @@ CFLAGS="$PYTHON_INC $CFLAGS"
+ # AC_MSG_ERROR([Cannot find python.h!])
+ # ])
+
+-AC_CHECK_FILE(${py_prefix}/include/python${py_ver}/Python.h, [
+- AC_DEFINE(HAVE_PYTHON_H, 1, [Has Python.h])
+- ], [
+- AC_MSG_ERROR([Cannot find Python.h!])
+- ])
++AC_DEFINE(HAVE_PYTHON_H, 1, [Has Python.h])
+
+ CFLAGS="$OLD_CFLAGS"
+
diff --git a/packages/gizmod/gizmod_2.3.bb b/packages/gizmod/gizmod_2.3.bb
new file mode 100644
index 0000000000..c00293b64c
--- /dev/null
+++ b/packages/gizmod/gizmod_2.3.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "Gizmo Daemon"
+HOMEPAGE = "http://gizmod.sourceforge.net"
+LICENSE = "GPLv2"
+MAINTAINER = "Justin Patrin <papercrane@reversefold.com>"
+SECTION = "console/multimedia"
+DEPENDS = "python virtual/libx11 xf86vidmodeproto"
+SRC_URI = "${SOURCEFORGE_MIRROR}/gizmod/gizmod-${PV}.tar.bz2 \
+ file://disable-xmms.patch;patch=1 \
+ file://fix-python-configure.patch;patch=1 \
+ file://disable-bmp.patch;patch=1"
+
+PR = "r0"
+
+inherit autotools
+
+EXTRA_OECONF = "--disable-xmms --disable-bmp --disable-xosd"
+
+#do_configure_prepend() {
+# sed -i 's/TARGET_SYS/${TARGET_SYS}/' ${S}/configure.ac
+#}
+
+FILES_${PN} += "${datadir}/gizmo/scripts ${datadir}/gizmo/plugins/*.so ${datadir}/gizmo/plugins/*.so.*"
+FILES_${PN}-dev += "${datadir}/gizmo/plugins/*.a ${datadir}/gizmo/plugins/*.la"
+FILES_${PN}-dbg += "${datadir}/gizmo/plugins/.debug" \ No newline at end of file