aboutsummaryrefslogtreecommitdiffstats
path: root/packages/glibc
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2008-02-20 20:12:18 +0000
committerMichael Lauer <mickey@vanille-media.de>2008-02-20 20:12:18 +0000
commit5a362b4bb805986fbb4a5e0aee08d23b62d84b05 (patch)
tree45fa952885fd175b9eb0c51a5cc2ea1944f434ba /packages/glibc
parent4880ad5a25883d37116c857b58424d397402c23e (diff)
downloadopenembedded-5a362b4bb805986fbb4a5e0aee08d23b62d84b05.tar.gz
glibc 2.5|2.6.1 actually apply the local-dynamic-resolvconf.patch instead of
just unpacking it into debian/patches... ~lart debian...
Diffstat (limited to 'packages/glibc')
-rw-r--r--packages/glibc/files/glibc-2.5-local-dynamic-resolvconf.patch83
-rw-r--r--packages/glibc/glibc_2.5.bb4
-rw-r--r--packages/glibc/glibc_2.6.1.bb4
3 files changed, 44 insertions, 47 deletions
diff --git a/packages/glibc/files/glibc-2.5-local-dynamic-resolvconf.patch b/packages/glibc/files/glibc-2.5-local-dynamic-resolvconf.patch
index bab3747b1a..e137287dd1 100644
--- a/packages/glibc/files/glibc-2.5-local-dynamic-resolvconf.patch
+++ b/packages/glibc/files/glibc-2.5-local-dynamic-resolvconf.patch
@@ -1,44 +1,41 @@
---- glibc-2.5.orig/debian/patches/any/local-dynamic-resolvconf.diff
-+++ glibc-2.5/debian/patches/any/local-dynamic-resolvconf.diff
-@@ -0,0 +1,41 @@
-+# All lines beginning with `# DP:' are a description of the patch.
-+# DP: Description: allow dynamic long-running processes to
-+# DP: re-read a dynamically updated resolv.conf on the fly
-+# DP: Dpatch author: Adam Conrad <adconrad@ubuntu.com>
-+# DP: Patch author: Thorsten Kukuk <kukuk@suse.de>
-+# DP: Upstream status: Ubuntu-Specific
-+# DP: Date: 2006-01-13 08:14:21 UTC
+# All lines beginning with `# DP:' are a description of the patch.
+# DP: Description: allow dynamic long-running processes to
+# DP: re-read a dynamically updated resolv.conf on the fly
+# DP: Dpatch author: Adam Conrad <adconrad@ubuntu.com>
+# DP: Patch author: Thorsten Kukuk <kukuk@suse.de>
+# DP: Upstream status: Ubuntu-Specific
+# DP: Date: 2006-01-13 08:14:21 UTC
+
+Index: resolv/res_libc.c
+===================================================================
+--- resolv/res_libc.c.orig
++++ resolv/res_libc.c
+@@ -22,7 +22,7 @@
+ #include <arpa/nameser.h>
+ #include <resolv.h>
+ #include <bits/libc-lock.h>
+-
++#include <sys/stat.h>
+
+ /* The following bit is copied from res_data.c (where it is #ifdef'ed
+ out) since res_init() should go into libc.so but the rest of that
+@@ -94,8 +94,17 @@
+ int
+ __res_maybe_init (res_state resp, int preinit)
+ {
+- if (resp->options & RES_INIT) {
+- if (__res_initstamp != resp->_u._ext.initstamp) {
++ static time_t last_mtime;
++ struct stat statbuf;
++ int ret;
+
-+Index: resolv/res_libc.c
-+===================================================================
-+--- resolv/res_libc.c.orig
-++++ resolv/res_libc.c
-+@@ -22,7 +22,7 @@
-+ #include <arpa/nameser.h>
-+ #include <resolv.h>
-+ #include <bits/libc-lock.h>
-+-
-++#include <sys/stat.h>
-+
-+ /* The following bit is copied from res_data.c (where it is #ifdef'ed
-+ out) since res_init() should go into libc.so but the rest of that
-+@@ -94,8 +94,17 @@
-+ int
-+ __res_maybe_init (res_state resp, int preinit)
-+ {
-+- if (resp->options & RES_INIT) {
-+- if (__res_initstamp != resp->_u._ext.initstamp) {
-++ static time_t last_mtime;
-++ struct stat statbuf;
-++ int ret;
-++
-++
-++ if (resp->options & RES_INIT) {
-++ ret = stat (_PATH_RESCONF, &statbuf);
-++ if (__res_initstamp != resp->_u._ext.initstamp
-++ || (ret == 0) && (last_mtime != statbuf.st_mtime))
-++ {
-++ last_mtime = statbuf.st_mtime;
-+ if (resp->nscount > 0) {
-+ __res_iclose (resp, true);
-+ return __res_vinit (resp, 1);
++
++ if (resp->options & RES_INIT) {
++ ret = stat (_PATH_RESCONF, &statbuf);
++ if (__res_initstamp != resp->_u._ext.initstamp
++ || (ret == 0) && (last_mtime != statbuf.st_mtime))
++ {
++ last_mtime = statbuf.st_mtime;
+ if (resp->nscount > 0) {
+ __res_iclose (resp, true);
+ return __res_vinit (resp, 1);
diff --git a/packages/glibc/glibc_2.5.bb b/packages/glibc/glibc_2.5.bb
index f50c85b1d0..0dc1c41070 100644
--- a/packages/glibc/glibc_2.5.bb
+++ b/packages/glibc/glibc_2.5.bb
@@ -1,5 +1,5 @@
require glibc.inc
-PR = "r9"
+PR = "r10"
ARM_INSTRUCTION_SET = "arm"
@@ -44,7 +44,7 @@ SRC_URI = "\
file://dl-cache-libcmp.patch;patch=1 \
file://ldsocache-varrun.patch;patch=1 \
file://nptl-crosscompile.patch;patch=1 \
- file://glibc-2.5-local-dynamic-resolvconf.patch;patch=1 \
+ file://glibc-2.5-local-dynamic-resolvconf.patch;patch=1;pnum=0 \
file://glibc-check_pf.patch;patch=1;pnum=0 \
file://zecke-sane-readelf.patch;patch=1 \
file://ldd-unbash.patch;patch=1 \
diff --git a/packages/glibc/glibc_2.6.1.bb b/packages/glibc/glibc_2.6.1.bb
index 705fab6715..4c59bbdc13 100644
--- a/packages/glibc/glibc_2.6.1.bb
+++ b/packages/glibc/glibc_2.6.1.bb
@@ -1,5 +1,5 @@
require glibc.inc
-PR = "r2"
+PR = "r3"
ARM_INSTRUCTION_SET = "arm"
@@ -45,7 +45,7 @@ SRC_URI = "\
file://dl-cache-libcmp.patch;patch=1 \
file://ldsocache-varrun.patch;patch=1 \
file://nptl-crosscompile.patch;patch=1 \
- file://glibc-2.5-local-dynamic-resolvconf.patch;patch=1 \
+ file://glibc-2.5-local-dynamic-resolvconf.patch;patch=1;pnum=0 \
file://glibc-check_pf.patch;patch=1;pnum=0 \
file://zecke-sane-readelf.patch;patch=1 \
file://ldd-unbash.patch;patch=1 \