aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gnash
diff options
context:
space:
mode:
authorJohn Lee <john_lee@openmoko.org>2008-02-29 11:03:16 +0000
committerOpenmoko anonymizer key <devel@lists.openmoko.org>2008-02-29 11:03:16 +0000
commit2aa3d0842e9cde0ca04d41771b2c5c49e911ffe8 (patch)
treef4a35307cd341aa972a3cb0e11abc3ca032e4513 /packages/gnash
parent5ebc5e03c1014c0626a4abe5da68fb80a1268421 (diff)
downloadopenembedded-2aa3d0842e9cde0ca04d41771b2c5c49e911ffe8.tar.gz
gnash: create gnash.inc
* add gnash 0.8.1
Diffstat (limited to 'packages/gnash')
-rw-r--r--packages/gnash/gnash.inc79
-rw-r--r--packages/gnash/gnash_0.8.0.bb80
-rw-r--r--packages/gnash/gnash_0.8.1.bb1
3 files changed, 81 insertions, 79 deletions
diff --git a/packages/gnash/gnash.inc b/packages/gnash/gnash.inc
new file mode 100644
index 0000000000..197cea06b6
--- /dev/null
+++ b/packages/gnash/gnash.inc
@@ -0,0 +1,79 @@
+DESCRIPTION = "Gnash is a GNU Flash movie player that supports many SWF v7 features"
+
+LICENSE = "GPL-2"
+HOMEPAGE = "http://www.gnu.org/software/gnash"
+
+DEPENDS = "gtk+ cairo libxml2 libmad libsdl-mixer zlib boost jpeg pango curl"
+
+SRC_URI = "ftp://ftp.gnu.org/pub/gnu/gnash/${PV}/gnash-${PV}.tar.bz2"
+
+
+EXTRA_OECONF = "--enable-gui=gtk \
+ --enable-renderer=cairo \
+ --enable-media=none \
+ --disable-klash \
+ --enable-z \
+ --enable-jpeg \
+ --disable-glext \
+ --enable-Xft \
+ --enable-expat \
+ --enable-mad \
+ --enable-cairo \
+ --disable-plugin \
+ --disable-cygnal \
+ --with-boost-incl=${STAGING_INCDIR} \
+ --with-boost-lib=${STAGING_LIBDIR} \
+ --with-libxml-incl=${STAGING_INCDIR}/libxml2 \
+ --with-libxml-lib=${STAGING_LIBDIR} \
+ --with-glib-incl=${STAGING_INCDIR}/glib-2.0 \
+# --with-glib-lib=${STAGING_LIBDIR} \
+ --with-gtk2-incl=${STAGING_INCDIR}/gtk-2.0 \
+ --with-pango-incl=${STAGING_INCDIR}/pango-1.0 \
+# --with-pango-lib=${STAGING_LIBDIR} \
+ --with-sdl-incl=${STAGING_INCDIR}/SDL \
+ --with-atk-incl=${STAGING_INCDIR}/atk-1.0 \
+ --with-Xft-incl=${STAGING_INCDIR}/X11 \
+ --with-expat-incl=${STAGING_INCDIR} \
+ --with-mad-incl=${STAGING_INCDIR} \
+ --with-cairo-incl=${STAGING_INCDIR}/cairo \
+ --with-curl-incl=${STAGING_INCDIR} \
+ --with-curl-lib=${STAGING_LIBDIR} \
+ "
+
+inherit autotools pkgconfig
+
+LDFLAGS += " -L${STAGING_LIBDIR} -lcurl -lboost_date_time -lboost_filesystem -lboost_iostreams -lboost_signals -lboost_thread-mt "
+CFLAGS += " -I${STAGING_INCDIR} -I${STAGING_LIBDIR}/gtk-2.0/include/ "
+
+do_configure_append() {
+ for i in `find . -name Makefile` ; do
+ sed -i s:I/usr/include:I${STAGING_INCDIR}:g $i
+ done
+}
+
+
+PARALLEL_MAKE = ""
+
+do_compile() {
+ oe_runmake 'CC=${CC}' 'LD=${LD}' 'CFLAGS=${CFLAGS}' \
+ 'ZLIB_INCLUDE=${STAGING_INCDIR}' \
+ 'ZLIB_LIBS=${STAGING_LIBDIR}' \
+ 'PNG_INCLUDE=${STAGING_INCDIR}' \
+ 'PNG_LIBS=${STAGING_LIBDIR}'
+}
+
+
+PACKAGES =+ " libgnashamf libgnashbackend libgnashbase libgnashgeo libgnashgui libgnashplayer libgnashserver "
+
+FILES_libgnashamf = "${libdir}/libgnashamf-${PV}.so"
+FILES_libgnashbackend = "${libdir}/libgnashbackend-${PV}.so"
+FILES_libgnashbase = "${libdir}/libgnashbase-${PV}.so"
+FILES_libgnashgeo = "${libdir}/libgnashgeo-${PV}.so"
+FILES_libgnashgui = "${libdir}/libgnashgui-${PV}.so"
+FILES_libgnashplayer = "${libdir}/libgnashplayer-${PV}.so"
+FILES_libgnashserver = "${libdir}/libgnashserver-${PV}.so"
+
+do_stage() {
+ autotools_stage_all
+}
+
diff --git a/packages/gnash/gnash_0.8.0.bb b/packages/gnash/gnash_0.8.0.bb
index 197cea06b6..da4b281e94 100644
--- a/packages/gnash/gnash_0.8.0.bb
+++ b/packages/gnash/gnash_0.8.0.bb
@@ -1,79 +1 @@
-DESCRIPTION = "Gnash is a GNU Flash movie player that supports many SWF v7 features"
-
-LICENSE = "GPL-2"
-HOMEPAGE = "http://www.gnu.org/software/gnash"
-
-DEPENDS = "gtk+ cairo libxml2 libmad libsdl-mixer zlib boost jpeg pango curl"
-
-SRC_URI = "ftp://ftp.gnu.org/pub/gnu/gnash/${PV}/gnash-${PV}.tar.bz2"
-
-
-EXTRA_OECONF = "--enable-gui=gtk \
- --enable-renderer=cairo \
- --enable-media=none \
- --disable-klash \
- --enable-z \
- --enable-jpeg \
- --disable-glext \
- --enable-Xft \
- --enable-expat \
- --enable-mad \
- --enable-cairo \
- --disable-plugin \
- --disable-cygnal \
- --with-boost-incl=${STAGING_INCDIR} \
- --with-boost-lib=${STAGING_LIBDIR} \
- --with-libxml-incl=${STAGING_INCDIR}/libxml2 \
- --with-libxml-lib=${STAGING_LIBDIR} \
- --with-glib-incl=${STAGING_INCDIR}/glib-2.0 \
-# --with-glib-lib=${STAGING_LIBDIR} \
- --with-gtk2-incl=${STAGING_INCDIR}/gtk-2.0 \
- --with-pango-incl=${STAGING_INCDIR}/pango-1.0 \
-# --with-pango-lib=${STAGING_LIBDIR} \
- --with-sdl-incl=${STAGING_INCDIR}/SDL \
- --with-atk-incl=${STAGING_INCDIR}/atk-1.0 \
- --with-Xft-incl=${STAGING_INCDIR}/X11 \
- --with-expat-incl=${STAGING_INCDIR} \
- --with-mad-incl=${STAGING_INCDIR} \
- --with-cairo-incl=${STAGING_INCDIR}/cairo \
- --with-curl-incl=${STAGING_INCDIR} \
- --with-curl-lib=${STAGING_LIBDIR} \
- "
-
-inherit autotools pkgconfig
-
-LDFLAGS += " -L${STAGING_LIBDIR} -lcurl -lboost_date_time -lboost_filesystem -lboost_iostreams -lboost_signals -lboost_thread-mt "
-CFLAGS += " -I${STAGING_INCDIR} -I${STAGING_LIBDIR}/gtk-2.0/include/ "
-
-do_configure_append() {
- for i in `find . -name Makefile` ; do
- sed -i s:I/usr/include:I${STAGING_INCDIR}:g $i
- done
-}
-
-
-PARALLEL_MAKE = ""
-
-do_compile() {
- oe_runmake 'CC=${CC}' 'LD=${LD}' 'CFLAGS=${CFLAGS}' \
- 'ZLIB_INCLUDE=${STAGING_INCDIR}' \
- 'ZLIB_LIBS=${STAGING_LIBDIR}' \
- 'PNG_INCLUDE=${STAGING_INCDIR}' \
- 'PNG_LIBS=${STAGING_LIBDIR}'
-}
-
-
-PACKAGES =+ " libgnashamf libgnashbackend libgnashbase libgnashgeo libgnashgui libgnashplayer libgnashserver "
-
-FILES_libgnashamf = "${libdir}/libgnashamf-${PV}.so"
-FILES_libgnashbackend = "${libdir}/libgnashbackend-${PV}.so"
-FILES_libgnashbase = "${libdir}/libgnashbase-${PV}.so"
-FILES_libgnashgeo = "${libdir}/libgnashgeo-${PV}.so"
-FILES_libgnashgui = "${libdir}/libgnashgui-${PV}.so"
-FILES_libgnashplayer = "${libdir}/libgnashplayer-${PV}.so"
-FILES_libgnashserver = "${libdir}/libgnashserver-${PV}.so"
-
-do_stage() {
- autotools_stage_all
-}
-
+require gnash.inc
diff --git a/packages/gnash/gnash_0.8.1.bb b/packages/gnash/gnash_0.8.1.bb
new file mode 100644
index 0000000000..da4b281e94
--- /dev/null
+++ b/packages/gnash/gnash_0.8.1.bb
@@ -0,0 +1 @@
+require gnash.inc