aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gnash
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2007-07-31 10:52:28 +0000
committerKoen Kooi <koen@openembedded.org>2007-07-31 10:52:28 +0000
commit41d1e248d5c941cc99d7436ed74d39cf891927d5 (patch)
treeeb846ec0b58fb474da8c4c3f5905854eb2121f1a /packages/gnash
parent00b20a5a4b14c59424f4c4328addd3f8c4311d39 (diff)
downloadopenembedded-41d1e248d5c941cc99d7436ed74d39cf891927d5.tar.gz
gnash: add 0.8.0
Diffstat (limited to 'packages/gnash')
-rw-r--r--packages/gnash/.mtn2git_empty0
-rw-r--r--packages/gnash/gnash_0.8.0.bb79
2 files changed, 79 insertions, 0 deletions
diff --git a/packages/gnash/.mtn2git_empty b/packages/gnash/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/gnash/.mtn2git_empty
diff --git a/packages/gnash/gnash_0.8.0.bb b/packages/gnash/gnash_0.8.0.bb
new file mode 100644
index 0000000000..197cea06b6
--- /dev/null
+++ b/packages/gnash/gnash_0.8.0.bb
@@ -0,0 +1,79 @@
+DESCRIPTION = "Gnash is a GNU Flash movie player that supports many SWF v7 features"
+
+LICENSE = "GPL-2"
+HOMEPAGE = "http://www.gnu.org/software/gnash"
+
+DEPENDS = "gtk+ cairo libxml2 libmad libsdl-mixer zlib boost jpeg pango curl"
+
+SRC_URI = "ftp://ftp.gnu.org/pub/gnu/gnash/${PV}/gnash-${PV}.tar.bz2"
+
+
+EXTRA_OECONF = "--enable-gui=gtk \
+ --enable-renderer=cairo \
+ --enable-media=none \
+ --disable-klash \
+ --enable-z \
+ --enable-jpeg \
+ --disable-glext \
+ --enable-Xft \
+ --enable-expat \
+ --enable-mad \
+ --enable-cairo \
+ --disable-plugin \
+ --disable-cygnal \
+ --with-boost-incl=${STAGING_INCDIR} \
+ --with-boost-lib=${STAGING_LIBDIR} \
+ --with-libxml-incl=${STAGING_INCDIR}/libxml2 \
+ --with-libxml-lib=${STAGING_LIBDIR} \
+ --with-glib-incl=${STAGING_INCDIR}/glib-2.0 \
+# --with-glib-lib=${STAGING_LIBDIR} \
+ --with-gtk2-incl=${STAGING_INCDIR}/gtk-2.0 \
+ --with-pango-incl=${STAGING_INCDIR}/pango-1.0 \
+# --with-pango-lib=${STAGING_LIBDIR} \
+ --with-sdl-incl=${STAGING_INCDIR}/SDL \
+ --with-atk-incl=${STAGING_INCDIR}/atk-1.0 \
+ --with-Xft-incl=${STAGING_INCDIR}/X11 \
+ --with-expat-incl=${STAGING_INCDIR} \
+ --with-mad-incl=${STAGING_INCDIR} \
+ --with-cairo-incl=${STAGING_INCDIR}/cairo \
+ --with-curl-incl=${STAGING_INCDIR} \
+ --with-curl-lib=${STAGING_LIBDIR} \
+ "
+
+inherit autotools pkgconfig
+
+LDFLAGS += " -L${STAGING_LIBDIR} -lcurl -lboost_date_time -lboost_filesystem -lboost_iostreams -lboost_signals -lboost_thread-mt "
+CFLAGS += " -I${STAGING_INCDIR} -I${STAGING_LIBDIR}/gtk-2.0/include/ "
+
+do_configure_append() {
+ for i in `find . -name Makefile` ; do
+ sed -i s:I/usr/include:I${STAGING_INCDIR}:g $i
+ done
+}
+
+
+PARALLEL_MAKE = ""
+
+do_compile() {
+ oe_runmake 'CC=${CC}' 'LD=${LD}' 'CFLAGS=${CFLAGS}' \
+ 'ZLIB_INCLUDE=${STAGING_INCDIR}' \
+ 'ZLIB_LIBS=${STAGING_LIBDIR}' \
+ 'PNG_INCLUDE=${STAGING_INCDIR}' \
+ 'PNG_LIBS=${STAGING_LIBDIR}'
+}
+
+
+PACKAGES =+ " libgnashamf libgnashbackend libgnashbase libgnashgeo libgnashgui libgnashplayer libgnashserver "
+
+FILES_libgnashamf = "${libdir}/libgnashamf-${PV}.so"
+FILES_libgnashbackend = "${libdir}/libgnashbackend-${PV}.so"
+FILES_libgnashbase = "${libdir}/libgnashbase-${PV}.so"
+FILES_libgnashgeo = "${libdir}/libgnashgeo-${PV}.so"
+FILES_libgnashgui = "${libdir}/libgnashgui-${PV}.so"
+FILES_libgnashplayer = "${libdir}/libgnashplayer-${PV}.so"
+FILES_libgnashserver = "${libdir}/libgnashserver-${PV}.so"
+
+do_stage() {
+ autotools_stage_all
+}
+