aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gnash
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-01-22 22:40:41 +0100
committerKoen Kooi <koen@openembedded.org>2009-01-22 22:40:41 +0100
commit55437a9e24c1196085d1baea507df32a9de39fe6 (patch)
treeebc260e5b06162977e14c6787ef3fb94a76382ef /packages/gnash
parent1f0202f85079b905994df9c6442ce24365908c8d (diff)
downloadopenembedded-55437a9e24c1196085d1baea507df32a9de39fe6.tar.gz
gnash: add 0.8.4, def pref -1 till it's runtime tested
Diffstat (limited to 'packages/gnash')
-rw-r--r--packages/gnash/gnash_0.8.4.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/packages/gnash/gnash_0.8.4.bb b/packages/gnash/gnash_0.8.4.bb
new file mode 100644
index 0000000000..0a9c780cc4
--- /dev/null
+++ b/packages/gnash/gnash_0.8.4.bb
@@ -0,0 +1,24 @@
+require gnash.inc
+
+DEFAULT_PREFERENCE = "-1"
+
+do_configure_prepend() {
+ sed -i -e 's:GNASH_PKG_FIND(libpng:GNASH_PKG_FIND(png:g' ${S}/configure.ac
+ for i in $(find ${S} -name "Makefile.am") ; do
+ sed -i -e s:LIBPNG:PNG:g $i
+ done
+ export CFLAGS="${CFLAGS} -lpng"
+}
+
+EXTRA_OECONF += " --without-included-ltdl \
+ --with-ltdl-include=${STAGING_INCDIR} \
+ --with-ltdl-lib=${STAGING_LIBDIR} \
+ --enable-plugins \
+ --enable-npapi \
+ --with-npapi-plugindir=${libdir}/mozilla/plugins \
+ --enable-mit-shm \
+ --enable-png \
+ --with-png-incl=${STAGING_INCDIR} \
+ --with-png-lib=${STAGING_LIBDIR} \
+ "
+