aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gnash
diff options
context:
space:
mode:
authorLeon Woestenberg <leon.woestenberg@gmail.com>2008-05-05 18:24:26 +0000
committerLeon Woestenberg <leon.woestenberg@gmail.com>2008-05-05 18:24:26 +0000
commit9a1d156623f21d1f66c4314230056c8499d556f5 (patch)
tree56736a54e69ce8019cc63b701452c718d66db7b7 /packages/gnash
parent213303a5804e0061e86fc9c3b7dfc40c3c8d9037 (diff)
downloadopenembedded-9a1d156623f21d1f66c4314230056c8499d556f5.tar.gz
gnash-minimal: Added gnash-minimal.inc, and _cvs.bb
Diffstat (limited to 'packages/gnash')
-rw-r--r--packages/gnash/gnash-minimal.inc49
-rw-r--r--packages/gnash/gnash-minimal_0.8.2.bb49
-rw-r--r--packages/gnash/gnash-minimal_cvs.bb4
-rw-r--r--packages/gnash/gnash.inc14
4 files changed, 61 insertions, 55 deletions
diff --git a/packages/gnash/gnash-minimal.inc b/packages/gnash/gnash-minimal.inc
new file mode 100644
index 0000000000..d0bc8d62a0
--- /dev/null
+++ b/packages/gnash/gnash-minimal.inc
@@ -0,0 +1,49 @@
+DESCRIPTION = "Gnash is a GNU Flash movie player that supports many SWF v7 features"
+HOMEPAGE = "http://www.gnu.org/software/gnash"
+LICENSE = "GPL-2"
+DEPENDS = "agg libxml2 libmad zlib boost jpeg pango curl freetype"
+PR = "r4"
+
+SRC_URI = "ftp://ftp.gnu.org/pub/gnu/gnash/${PV}/gnash-${PV}.tar.bz2"
+S = ${WORKDIR}/gnash-${PV}
+
+inherit autotools pkgconfig
+
+# gnash-minimal is intended for running directly on a framebuffer device
+# for memory constrained devices, but does not accept all SWF files.
+# As such, it is useful as a GUI frontend for dedicated SWF files.
+
+# JPEG support and libz cannot be disabled due to a bug in 0.8.2.
+# maintainer-mode is enabled to disable the testsuite.
+
+EXTRA_OECONF="--enable-gui=gtk \
+ --enable-renderer=agg \
+ --enable-media=none \
+ --enable-agg \
+ --enable-gui=fb \
+ --enable-z \
+ --enable-jpeg \
+ --disable-klash \
+ --disable-glext \
+ --disable-Xft \
+ --disable-expat \
+ --disable-mad \
+ --disable-gstreamer \
+ --disable-cairo \
+ --disable-plugin \
+ --disable-cygnal \
+ --disable-testsuite \
+ --enable-maintainer-mode \
+ --enable-fps-debug \
+ --enable-allstatic \
+ --with-top-level=${STAGING_DIR_HOST}/usr \
+ "
+
+PACKAGES =+ " libgnashamf libgnashbase libgnashserver libgnashmedia libltdl"
+
+FILES_libltdl = "${libdir}/gnash/libltdl*.so*"
+FILES_libgnashamf = "${libdir}/gnash/libgnashamf-${PV}.so"
+FILES_libgnashbase = "${libdir}/gnash/libgnashbase-${PV}.so"
+FILES_libgnashmedia = "${libdir}/gnash/libgnashmedia-${PV}.so"
+FILES_libgnashserver = "${libdir}/gnash/libgnashserver-${PV}.so"
+
diff --git a/packages/gnash/gnash-minimal_0.8.2.bb b/packages/gnash/gnash-minimal_0.8.2.bb
index 5cec59f140..bcfb88c42f 100644
--- a/packages/gnash/gnash-minimal_0.8.2.bb
+++ b/packages/gnash/gnash-minimal_0.8.2.bb
@@ -1,49 +1,2 @@
-DESCRIPTION = "Gnash is a GNU Flash movie player that supports many SWF v7 features"
-HOMEPAGE = "http://www.gnu.org/software/gnash"
-LICENSE = "GPL-2"
-DEPENDS = "agg libxml2 libmad zlib boost jpeg pango curl freetype"
-PR = "r3"
-
-SRC_URI = "ftp://ftp.gnu.org/pub/gnu/gnash/${PV}/gnash-${PV}.tar.bz2"
-S = ${WORKDIR}/gnash-${PV}
-
-inherit autotools pkgconfig
-
-# gnash-minimal is intended for running directly on a framebuffer device
-# for memory constrained devices, but does not accept all SWF files.
-# As such, it is useful as a GUI frontend for dedicated SWF files.
-
-# JPEG support and libz cannot be disabled due to a bug in 0.8.2.
-# maintainer-mode is enabled to disable the testsuite.
-
-EXTRA_OECONF="--enable-gui=gtk \
- --enable-renderer=agg \
- --enable-media=none \
- --enable-agg \
- --enable-gui=fb \
- --enable-z \
- --enable-jpeg \
- --disable-klash \
- --disable-glext \
- --disable-Xft \
- --disable-expat \
- --disable-mad \
- --disable-gstreamer \
- --disable-cairo \
- --disable-plugin \
- --disable-cygnal \
- --disable-testsuite \
- --enable-maintainer-mode \
- --enable-fps-debug \
- --enable-allstatic \
- --with-top-level=${STAGING_DIR_HOST}/usr \
- "
-
-PACKAGES =+ " libgnashamf libgnashbase libgnashserver libgnashmedia libltdl"
-
-FILES_libltdl = "${libdir}/gnash/libltdl*.so*"
-FILES_libgnashamf = "${libdir}/gnash/libgnashamf-${PV}.so"
-FILES_libgnashbase = "${libdir}/gnash/libgnashbase-${PV}.so"
-FILES_libgnashmedia = "${libdir}/gnash/libgnashmedia-${PV}.so"
-FILES_libgnashserver = "${libdir}/gnash/libgnashserver-${PV}.so"
+require gnash-minimal.inc
diff --git a/packages/gnash/gnash-minimal_cvs.bb b/packages/gnash/gnash-minimal_cvs.bb
new file mode 100644
index 0000000000..c079caadc6
--- /dev/null
+++ b/packages/gnash/gnash-minimal_cvs.bb
@@ -0,0 +1,4 @@
+require gnash-minimal.inc
+
+SRC_URI = "cvs://anonymous:anonymous@cvs.sv.gnu.org/sources/gnash;module=gnash"
+S = ${WORKDIR}/gnash
diff --git a/packages/gnash/gnash.inc b/packages/gnash/gnash.inc
index 113422596a..31e84b84ac 100644
--- a/packages/gnash/gnash.inc
+++ b/packages/gnash/gnash.inc
@@ -27,12 +27,12 @@ EXTRA_OECONF = "--enable-gui=gtk \
PACKAGES =+ " libgnashamf libgnashbackend libgnashbase libgnashgeo libgnashgui libgnashplayer libgnashserver "
-FILES_libgnashamf = "${libdir}/libgnashamf-${PV}.so"
-FILES_libgnashbackend = "${libdir}/libgnashbackend-${PV}.so"
-FILES_libgnashbase = "${libdir}/libgnashbase-${PV}.so"
-FILES_libgnashgeo = "${libdir}/libgnashgeo-${PV}.so"
-FILES_libgnashgui = "${libdir}/libgnashgui-${PV}.so"
-FILES_libgnashplayer = "${libdir}/libgnashplayer-${PV}.so"
-FILES_libgnashserver = "${libdir}/libgnashserver-${PV}.so"
+FILES_libgnashamf = "${libdir}/gnash/libgnashamf-${PV}.so"
+FILES_libgnashbackend = "${libdir}/gnash/libgnashbackend-${PV}.so"
+FILES_libgnashbase = "${libdir}/gnash/libgnashbase-${PV}.so"
+FILES_libgnashgeo = "${libdir}/gnash/libgnashgeo-${PV}.so"
+FILES_libgnashgui = "${libdir}/gnash/libgnashgui-${PV}.so"
+FILES_libgnashplayer = "${libdir}/gnash/libgnashplayer-${PV}.so"
+FILES_libgnashserver = "${libdir}/gnash/libgnashserver-${PV}.so"
PARALLEL_MAKE = ""