aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gnash
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2008-09-02 14:50:48 +0000
committerKoen Kooi <koen@openembedded.org>2008-09-02 14:50:48 +0000
commitc826cf9b7488b54130e7df6887851a7db2e9fed9 (patch)
treeb049f617d8bc1ab80f33c38dbaf7614896832e96 /packages/gnash
parentd1cf4ab9116fbea812d339d7f06c631927a446e4 (diff)
downloadopenembedded-c826cf9b7488b54130e7df6887851a7db2e9fed9.tar.gz
gnash-minimal cvs: fix missing trunc() definition, https://savannah.gnu.org/bugs/?24188
Diffstat (limited to 'packages/gnash')
-rw-r--r--packages/gnash/files/fix-trunc.diff13
-rw-r--r--packages/gnash/gnash-minimal_cvs.bb12
2 files changed, 24 insertions, 1 deletions
diff --git a/packages/gnash/files/fix-trunc.diff b/packages/gnash/files/fix-trunc.diff
new file mode 100644
index 0000000000..a01ca311d0
--- /dev/null
+++ b/packages/gnash/files/fix-trunc.diff
@@ -0,0 +1,13 @@
+--- /tmp/utility.h 2008-09-02 16:35:44.000000000 +0200
++++ gnash/libbase/utility.h 2008-09-02 16:36:10.000000000 +0200
+@@ -327,6 +327,10 @@
+ #endif
+ }
+
++#ifndef HAVE_TRUNC
++inline double trunc(double x) { return (x < 0 ? -(std::floor(-x)) : std::floor(x)); }
++#endif
++
+ #endif // UTILITY_H
+
+
diff --git a/packages/gnash/gnash-minimal_cvs.bb b/packages/gnash/gnash-minimal_cvs.bb
index ba9e2afb67..992998bf55 100644
--- a/packages/gnash/gnash-minimal_cvs.bb
+++ b/packages/gnash/gnash-minimal_cvs.bb
@@ -6,5 +6,15 @@ PR = "r1"
PV = "0.8.3+cvs${SRCDATE}"
SRC_URI = "cvs://anonymous:anonymous@cvs.sv.gnu.org/sources/gnash;module=gnash"
-SRC_URI += "file://libtool-2.2.patch;patch=1 file://libintl.patch;patch=1"
+SRC_URI += "file://libtool-2.2.patch;patch=1 \
+ file://libintl.patch;patch=1 \
+ file://fix-trunc.diff;patch=1"
+
S = ${WORKDIR}/gnash
+
+
+do_configure_prepend() {
+ sed -i -e 's:dnl AC_CHECK_LIB(m, trunc:AC_CHECK_LIB(m, trunc:g' ${S}/configure.ac
+}
+
+