aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gnome/gnome-games_2.6.1.bb
diff options
context:
space:
mode:
authorPhil Blundell <philb@gnu.org>2005-04-16 08:21:34 +0000
committerPhil Blundell <philb@gnu.org>2005-04-16 08:21:34 +0000
commit9ef4139d17dc7ffa6e51224196fadcdbdc6737ac (patch)
tree5901bf29463848c7d969e8f0dcae6d1f6f64e7a2 /packages/gnome/gnome-games_2.6.1.bb
parentef9024025d446763888bc4007f719a1e6b186f6c (diff)
downloadopenembedded-9ef4139d17dc7ffa6e51224196fadcdbdc6737ac.tar.gz
no need to set SECTION here since gnome.bbclass does it
BKrev: 4260cb0epSE90Xbe29uxrckA0YX8KA
Diffstat (limited to 'packages/gnome/gnome-games_2.6.1.bb')
-rw-r--r--packages/gnome/gnome-games_2.6.1.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/packages/gnome/gnome-games_2.6.1.bb b/packages/gnome/gnome-games_2.6.1.bb
index e69de29bb2..3db93ccb2b 100644
--- a/packages/gnome/gnome-games_2.6.1.bb
+++ b/packages/gnome/gnome-games_2.6.1.bb
@@ -0,0 +1,26 @@
+LICENSE = GPL
+MAINTAINER = "Phil Blundell <pb@handhelds.org>"
+DEPENDS = "guile gtk+ libgnome libgnomeui librsvg gnome-vfs gconf libglade gnome-common"
+PR = "r2"
+
+inherit gnome
+
+PACKAGES =+ "libgdkcardimage libgdkcardimage-data libgdkcardimage-dev"
+
+FILES_libgdkcardimage = "${libdir}/libgdkcardimage.so.*"
+FILES_libgdkcardimage-dev = "${libdir}/libgdkcardimage.* ${includedir}/gdkcardimage"
+FILES_libgdkcardimage-data = "${datadir}/pixmaps/cards"
+DEPENDS_libgdkcardimage = "libgdkcardimage-data"
+
+FILES_${PN}-doc += " ${datadir}/gnome/help"
+
+PACKAGES =+ "gnome-games-sol "
+FILES_gnome-games-sol = "${bindir}/sol ${datadir}/applications/sol.desktop ${datadir}/pixmaps/gnome-aisleriot.png ${sysconfdir}/gconf/schemas/aisleriot.schemas ${datadir}/sol-games"
+
+PACKAGES =+ "gnome-games-gnometris "
+FILES_gnome-games-gnometris = "${bindir}/gnometris ${datadir}/pixmaps/gnometris ${datadir}/pixmaps/gnome-gtetris.png ${datadir}/applications/gnometris.desktop ${sysconfdir}/gconf/schemas/gnometris.schemas"
+
+PACKAGES =+ "gnome-games-gnomine"
+FILES_gnome-games-gnomine = "${bindir}/gnomine ${datadir}/pixmaps/gnomine ${datadir}/pixmaps/gnome-gnomine.png ${datadir}/applications/gnomine.desktop ${sysconfdir}/gconf/schemas/gnomine.schemas"
+
+EXTRA_OECONF = "--disable-schemas-install"