aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gnome
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2008-12-08 17:14:04 -0500
committerDenys Dmytriyenko <denis@denix.org>2008-12-08 17:14:04 -0500
commit41b3c72649443c24420704864095f2ca88348f31 (patch)
tree11c5f090f8c5a5367ff16e89ab13c346fdba6253 /packages/gnome
parent30fc3452b21f1ecfe9abfef5a8b09d547c5b5bbc (diff)
downloadopenembedded-41b3c72649443c24420704864095f2ca88348f31.tar.gz
gnome-panel: fix "couldn't find scrollkeeper" error on Gnome-less host (#4802)
Diffstat (limited to 'packages/gnome')
-rw-r--r--packages/gnome/gnome-panel/scrollkeeper.patch16
-rw-r--r--packages/gnome/gnome-panel_2.24.0.bb3
2 files changed, 19 insertions, 0 deletions
diff --git a/packages/gnome/gnome-panel/scrollkeeper.patch b/packages/gnome/gnome-panel/scrollkeeper.patch
new file mode 100644
index 0000000000..29b870310f
--- /dev/null
+++ b/packages/gnome/gnome-panel/scrollkeeper.patch
@@ -0,0 +1,16 @@
+diff -u gnome-panel-2.24.0.orig/configure.in gnome-panel-2.24.0/configure.in
+--- gnome-panel-2.24.0.orig/configure.in 2008-09-22 17:21:55.000000000 -0400
++++ gnome-panel-2.24.0/configure.in 2008-11-04 15:32:39.000000000 -0500
+@@ -296,9 +296,9 @@
+ dnl scrollkeeper checks
+
+ AC_PATH_PROG(SCROLLKEEPER_CONFIG, scrollkeeper-config,no)
+-if test x$SCROLLKEEPER_CONFIG = xno; then
+- AC_MSG_ERROR(Couldn't find scrollkeeper-config. Please install the scrollkeeper package)
+-fi
++dnl if test x$SCROLLKEEPER_CONFIG = xno; then
++dnl AC_MSG_ERROR(Couldn't find scrollkeeper-config. Please install the scrollkeeper package)
++dnl fi
+
+ AM_GCONF_SOURCE_2
+
diff --git a/packages/gnome/gnome-panel_2.24.0.bb b/packages/gnome/gnome-panel_2.24.0.bb
index b96d985387..743e0fafd7 100644
--- a/packages/gnome/gnome-panel_2.24.0.bb
+++ b/packages/gnome/gnome-panel_2.24.0.bb
@@ -3,6 +3,8 @@ DEPENDS = "librsvg libgweather startup-notification libwnck orbit2 gtk+ libgnome
inherit gnome pkgconfig
+SRC_URI += "file://scrollkeeper.patch;patch=1"
+
do_configure_prepend() {
sed -i -e s:help:: ${S}/Makefile.am
}
@@ -15,6 +17,7 @@ FILES_${PN} =+ "${datadir}/gnome* \
${datadir}/icons"
EXTRA_OEMAKE = "ORBIT_IDL=${STAGING_BINDIR_NATIVE}/orbit-idl-2"
+EXTRA_OECONF = "--disable-scrollkeeper"
do_stage() {
autotools_stage_all