aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gnome
diff options
context:
space:
mode:
authorRolf Leggewie <oe-devel@rolf.leggewie.biz>2008-08-05 01:42:46 +0000
committerRolf Leggewie <oe-devel@rolf.leggewie.biz>2008-08-05 01:42:46 +0000
commit9b26d42fdc33a5a5393dd3c22079016b2bdf92c6 (patch)
tree707fec91d9ecdad556362770f1c3261763137b18 /packages/gnome
parentb7585abf9076138dafdfdb4246190bac699064ba (diff)
downloadopenembedded-9b26d42fdc33a5a5393dd3c22079016b2bdf92c6.tar.gz
gconf: fix packaging for dbg, introduce autotools_stage_all and reorder fields according to StyleGuide. Closes 3505.
Diffstat (limited to 'packages/gnome')
-rw-r--r--packages/gnome/gconf_2.6.1.bb22
1 files changed, 10 insertions, 12 deletions
diff --git a/packages/gnome/gconf_2.6.1.bb b/packages/gnome/gconf_2.6.1.bb
index 52cb799cf2..ef0b132e43 100644
--- a/packages/gnome/gconf_2.6.1.bb
+++ b/packages/gnome/gconf_2.6.1.bb
@@ -1,32 +1,30 @@
-LICENSE = "LGPL"
-SECTION = "x11/gnome"
DESCRIPTION = "GNOME configuration database system"
-SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/GConf/2.6/GConf-${PV}.tar.bz2 \
- file://backends.patch;patch=1"
+SECTION = "x11/gnome"
+LICENSE = "LGPL"
DEPENDS = "orbit2 glib-2.0 libxml2"
ORBIT_IDL_SRC = "${STAGING_BINDIR_NATIVE}/orbit-idl-2"
-FILES_${PN} += " ${libdir}/GConf/*"
-
S = "${WORKDIR}/GConf-${PV}"
+SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/GConf/2.6/GConf-${PV}.tar.bz2 \
+ file://backends.patch;patch=1"
+
EXTRA_OECONF = "--disable-gtk-doc"
+HEADERS = "gconf.h gconf-changeset.h gconf-listeners.h gconf-schema.h gconf-value.h gconf-error.h gconf-engine.h gconf-client.h gconf-enum-types.h"
inherit autotools pkgconfig gettext
-HEADERS = "gconf.h gconf-changeset.h gconf-listeners.h gconf-schema.h gconf-value.h gconf-error.h gconf-engine.h gconf-client.h gconf-enum-types.h"
-
do_compile() {
oe_runmake ORBIT_IDL="${ORBIT_IDL_SRC}"
}
do_stage() {
- oe_libinstall -so -C gconf libgconf-2 ${STAGING_LIBDIR}
- install -d ${STAGING_INCDIR}/gconf/2/gconf/
- ( cd gconf; for i in ${HEADERS}; do install -m 0644 $i ${STAGING_INCDIR}/gconf/2/gconf/$i; done )
- install -m 0644 gconf.m4 ${STAGING_DATADIR}/aclocal/gconf-2.m4
+ autotools_stage_all
}
do_install() {
oe_runmake ORBIT_IDL="${ORBIT_IDL_SRC}" DESTDIR="${D}" install
}
+
+FILES_${PN} += " ${libdir}/GConf/*"
+FILES_gconf-dbg += "${libdir}/*/*/.debug"