aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gnome
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2008-08-12 14:32:57 +0000
committerKoen Kooi <koen@openembedded.org>2008-08-12 14:32:57 +0000
commitf40c2a0be0ccc9e5655feb5051815ec6887bdc47 (patch)
treefa743d4e884406411df7f0639fdf12bb1056e279 /packages/gnome
parentb99a9f05a0a96c3e3b631f576a5a84dd2767fc62 (diff)
downloadopenembedded-f40c2a0be0ccc9e5655feb5051815ec6887bdc47.tar.gz
gnome-games: build aisleriot since we have a working guile now
Diffstat (limited to 'packages/gnome')
-rw-r--r--packages/gnome/gnome-games_2.23.6.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/packages/gnome/gnome-games_2.23.6.bb b/packages/gnome/gnome-games_2.23.6.bb
new file mode 100644
index 0000000000..61e145a549
--- /dev/null
+++ b/packages/gnome/gnome-games_2.23.6.bb
@@ -0,0 +1,38 @@
+LICENSE = "GPL"
+DEPENDS = "libggz ggz-client-libs python-pygtk gtk+ libgnome libgnomeui librsvg gnome-vfs gconf libglade gnome-common"
+
+PR = "r1"
+
+inherit gnome distutils-base gconf
+
+EXTRA_OECONF = "--with-libggz-includes=${STAGING_INCDIR} \
+ --with-libggz-libraries=${STAGING_LIBDIR} \
+ --with-ggzmod-includes=${STAGING_INCDIR} \
+ --with-ggzmod-libraries=${STAGING_LIBDIR} \
+ --enable-scalable \
+ "
+
+do_configure_prepend() {
+ for i in $(find ${S} -name "Makefile.am") ; do
+ sed -i -e s:help::g $i
+ done
+}
+
+
+FILES_${PN}-doc += " ${datadir}/gnome/help"
+FILES_${PN}-dbg += " ${bindir}/.debug ${libdir}/gnome-games/.debug"
+
+FILES_${PN} += "/var/games \
+ ${datadir}/applications \
+ ${datadir}/g* \
+ ${datadir}/ggz \
+ ${datadir}/icons \
+ ${datadir}/pixmaps \
+ ${sysconfdir}"
+
+PACKAGES =+ "gnome-games-gnometris "
+FILES_gnome-games-gnometris = "${bindir}/gnometris ${datadir}/pixmaps/gnometris ${datadir}/pixmaps/gnome-gtetris.png ${datadir}/applications/gnometris.desktop ${sysconfdir}/gconf/schemas/gnometris.schemas"
+
+PACKAGES =+ "gnome-games-gnomine"
+FILES_gnome-games-gnomine = "${bindir}/gnomine ${datadir}/pixmaps/gnomine ${datadir}/pixmaps/gnome-gnomine.png ${datadir}/applications/gnomine.desktop ${sysconfdir}/gconf/schemas/gnomine.schemas"
+