aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gnome
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2008-09-03 12:46:52 +0000
committerKoen Kooi <koen@openembedded.org>2008-09-03 12:46:52 +0000
commita3552eb349f3a83b0ded45301775fbae29973eee (patch)
treec8b0a04b57ecd976706201328f28bd7ac11fe805 /packages/gnome
parent0f6cd7812dfe83d073112dfbf7aa83b62e92b2d6 (diff)
downloadopenembedded-a3552eb349f3a83b0ded45301775fbae29973eee.tar.gz
gnome-python-extras: add 2.19.1
Diffstat (limited to 'packages/gnome')
-rw-r--r--packages/gnome/gnome-python-extras_2.19.1.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/packages/gnome/gnome-python-extras_2.19.1.bb b/packages/gnome/gnome-python-extras_2.19.1.bb
new file mode 100644
index 0000000000..9d8e786241
--- /dev/null
+++ b/packages/gnome/gnome-python-extras_2.19.1.bb
@@ -0,0 +1,21 @@
+LICENSE = "GPL/LGPL"
+DEPENDS = "python-pygtk libwnck"
+
+inherit gnome distutils-base
+
+SRC_URI += "file://acinclude.m4"
+
+do_configure_prepend() {
+ install -m 0644 ${WORKDIR}/acinclude.m4 ${S}/
+}
+
+do_configure_prepend() {
+ sed -i -e s:'`$PKG_CONFIG --variable=defsdir pygtk-2.0`':\"${STAGING_DATADIR}/pygtk/2.0/defs\":g ${S}/configure.ac
+}
+
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
+do_stage() {
+ autotools_stage_all
+}
+
+FILES_${PN}-dev += "${datadir}/pygtk"