aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gnome
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2006-04-01 17:37:53 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-04-01 17:37:53 +0000
commit062c38db824963e3edcffc9e6389e160b8093793 (patch)
treed106d0ee2844e4fa009f2963304a1fd697af5018 /packages/gnome
parentaa3cfa09dbcb66744209c3c6fda3decdc90f49a7 (diff)
downloadopenembedded-062c38db824963e3edcffc9e6389e160b8093793.tar.gz
goffice_0.2.1.bb, gnumeric_1.6.3.bb : New versions of these.
Also fixed the problem with gnumeric packaging where is depended on gnumeric-dev.
Diffstat (limited to 'packages/gnome')
-rw-r--r--packages/gnome/goffice_0.2.1.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/packages/gnome/goffice_0.2.1.bb b/packages/gnome/goffice_0.2.1.bb
new file mode 100644
index 0000000000..59372fa5ec
--- /dev/null
+++ b/packages/gnome/goffice_0.2.1.bb
@@ -0,0 +1,21 @@
+DESCRIPTION="Gnome Office Library"
+LICENSE="GPLv2"
+PR="r0"
+
+DEPENDS="glib-2.0 gtk+ pango libgnomeprint libgsf libglade libxml2 libart-lgpl"
+
+inherit gnome pkgconfig
+
+do_stage() {
+ gnome_stage_includes
+ oe_libinstall -so -C goffice libgoffice-1 ${STAGING_LIBDIR}
+}
+
+PACKAGES_DYNAMIC = "goffice-plugin-*"
+
+python populate_packages_prepend () {
+ goffice_libdir = bb.data.expand('${libdir}/goffice/${PV}/plugins', d)
+
+ do_split_packages(d, goffice_libdir, '(.*)', 'goffice-plugin-%s', 'Goffice plugin for %s', allow_dirs=True)
+}
+