aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gnome
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2006-09-04 11:24:07 +0000
committerGraeme Gregory <dp@xora.org.uk>2006-09-04 11:24:07 +0000
commitb15cd814c4d59a858beee25a329a6e29a0b3989b (patch)
tree0eba3e3dec7a722a0b92b83c7c2546f1c983fcd8 /packages/gnome
parentda241cb72a4d49335420bf122f4f8eb1ce82419f (diff)
downloadopenembedded-b15cd814c4d59a858beee25a329a6e29a0b3989b.tar.gz
libbonoboui_2.14.0.bb : new version
Diffstat (limited to 'packages/gnome')
-rw-r--r--packages/gnome/libbonoboui_2.14.0.bb58
1 files changed, 58 insertions, 0 deletions
diff --git a/packages/gnome/libbonoboui_2.14.0.bb b/packages/gnome/libbonoboui_2.14.0.bb
new file mode 100644
index 0000000000..049eb135ad
--- /dev/null
+++ b/packages/gnome/libbonoboui_2.14.0.bb
@@ -0,0 +1,58 @@
+LICENSE = "GPL"
+SECTION = "x11/gnome/libs"
+PR = "r0"
+
+inherit gnome pkgconfig
+
+FILES_${PN} += "${libdir}/libglade/2.0/*.so"
+FILES_${PN}-dev += "${libdir}/libglade/2.0/* ${datadir}/gnome-2.0/ui \
+ ${libdir}/bonobo-2.0/samples"
+FILES_${PN}-dbg += "${libdir}/libglade/2.0/.debug/*.so"
+
+DEPENDS = "libgnomecanvas libbonobo libgnome glib-2.0 gtk-doc gconf libxml2 libglade"
+
+EXTRA_OECONF = "--disable-gtk-doc"
+
+HEADERS = " \
+bonobo/bonobo-zoomable.h \
+bonobo/bonobo-ui-component.h \
+bonobo/bonobo-dock-layout.h \
+bonobo/bonobo-ui-type-builtins.h \
+bonobo/bonobo-canvas-component.h \
+bonobo/bonobo-widget.h \
+bonobo/bonobo-ui-engine.h \
+bonobo/bonobo-window.h \
+bonobo/bonobo-ui-toolbar.h \
+bonobo/bonobo-dock-band.h \
+bonobo/bonobo-ui-toolbar-item.h \
+bonobo/bonobo-control.h \
+bonobo/bonobo-dock-item.h \
+bonobo/bonobo-ui-config-widget.h \
+bonobo/bonobo-zoomable-frame.h \
+bonobo/bonobo-control-frame.h \
+bonobo/bonobo-dock.h \
+bonobo/bonobo-ui-main.h \
+bonobo/bonobo-canvas-item.h \
+bonobo/bonobo-ui-node.h \
+bonobo/bonobo-socket.h \
+bonobo/bonobo-selector.h \
+bonobo/bonobo-ui-sync.h \
+bonobo/bonobo-ui-util.h \
+bonobo/bonobo-plug.h \
+bonobo/bonobo-ui-toolbar-button-item.h \
+bonobo/bonobo-ui-toolbar-toggle-button-item.h \
+bonobo/bonobo-ui-container.h \
+bonobo/bonobo-file-selector-util.h \
+bonobo/bonobo-property-control.h \
+bonobo/bonobo-selector-widget.h \
+libbonoboui.h \
+bonobo.h \
+"
+
+do_stage() {
+ install -d ${STAGING_INCDIR}/libbonoboui-2.0/bonobo
+ for i in ${HEADERS}; do
+ install -m 0644 $i ${STAGING_INCDIR}/libbonoboui-2.0/$i
+ done
+ oe_libinstall -C bonobo -a -so libbonoboui-2 ${STAGING_LIBDIR}
+}