aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gnome
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2006-02-01 12:23:06 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-02-01 12:23:06 +0000
commitd68c92b4a63e4f46071a1c35ed1bb1009ba6f324 (patch)
tree41217baf99190192c2ff9bf76fefbda659f7b85d /packages/gnome
parent4f53bb2d58aba4a382057369405e00b165b95f42 (diff)
downloadopenembedded-d68c92b4a63e4f46071a1c35ed1bb1009ba6f324.tar.gz
goffice_0.2.0.bb, gnumeric_1.6.2.bb : new versions
Diffstat (limited to 'packages/gnome')
-rw-r--r--packages/gnome/goffice_0.2.0.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/packages/gnome/goffice_0.2.0.bb b/packages/gnome/goffice_0.2.0.bb
new file mode 100644
index 0000000000..59372fa5ec
--- /dev/null
+++ b/packages/gnome/goffice_0.2.0.bb
@@ -0,0 +1,21 @@
+DESCRIPTION="Gnome Office Library"
+LICENSE="GPLv2"
+PR="r0"
+
+DEPENDS="glib-2.0 gtk+ pango libgnomeprint libgsf libglade libxml2 libart-lgpl"
+
+inherit gnome pkgconfig
+
+do_stage() {
+ gnome_stage_includes
+ oe_libinstall -so -C goffice libgoffice-1 ${STAGING_LIBDIR}
+}
+
+PACKAGES_DYNAMIC = "goffice-plugin-*"
+
+python populate_packages_prepend () {
+ goffice_libdir = bb.data.expand('${libdir}/goffice/${PV}/plugins', d)
+
+ do_split_packages(d, goffice_libdir, '(.*)', 'goffice-plugin-%s', 'Goffice plugin for %s', allow_dirs=True)
+}
+