aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gnumeric
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2006-04-01 17:37:53 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-04-01 17:37:53 +0000
commit062c38db824963e3edcffc9e6389e160b8093793 (patch)
treed106d0ee2844e4fa009f2963304a1fd697af5018 /packages/gnumeric
parentaa3cfa09dbcb66744209c3c6fda3decdc90f49a7 (diff)
downloadopenembedded-062c38db824963e3edcffc9e6389e160b8093793.tar.gz
goffice_0.2.1.bb, gnumeric_1.6.3.bb : New versions of these.
Also fixed the problem with gnumeric packaging where is depended on gnumeric-dev.
Diffstat (limited to 'packages/gnumeric')
-rw-r--r--packages/gnumeric/gnumeric_1.6.3.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/packages/gnumeric/gnumeric_1.6.3.bb b/packages/gnumeric/gnumeric_1.6.3.bb
new file mode 100644
index 0000000000..0fc45bbd63
--- /dev/null
+++ b/packages/gnumeric/gnumeric_1.6.3.bb
@@ -0,0 +1,22 @@
+LICENSE = "GPL"
+SECTION = "x11/utils"
+S = "${WORKDIR}/gnumeric-${PV}"
+MAINTAINER = "Koen Kooi <koen@handhelds.org>"
+DEPENDS = "libgsf gtk+ libxml2 goffice libglade libart-lgpl intltool-native libgnomecanvas libgnomeprint libgnomeprintui libbonoboui"
+DESCRIPTION = "Gnumeric spreadsheet for GNOME"
+
+inherit gnome flow-lossage
+
+SRC_URI += "file://remove-docs.patch;patch=1"
+
+EXTRA_OECONF=" --without-perl "
+
+PACKAGES_DYNAMIC = "gnumeric-plugin-*"
+
+FILES_gnumeric_append = " /usr/lib/libspreadsheet-${PV}.so "
+
+python populate_packages_prepend () {
+ gnumeric_libdir = bb.data.expand('${libdir}/gnumeric/${PV}/plugins', d)
+
+ do_split_packages(d, gnumeric_libdir, '(.*)', 'gnumeric-plugin-%s', 'Gnumeric plugin for %s', allow_dirs=True)
+}