aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gnumeric
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@rpsys.net>2006-01-08 12:29:18 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-01-08 12:29:18 +0000
commitb2d178844371bb2d413eb6aed1e83a89783d7d96 (patch)
treef24681464666831f287143a7d4983ee33cdb3333 /packages/gnumeric
parent9134c9ba3bd9d6b3151fc4e3c2a3ed0f844a22b6 (diff)
downloadopenembedded-b2d178844371bb2d413eb6aed1e83a89783d7d96.tar.gz
Add PACKAGES_DYNAMIC to the appropriate .bb files.
Diffstat (limited to 'packages/gnumeric')
-rw-r--r--packages/gnumeric/gnumeric_1.3.1.bb2
-rw-r--r--packages/gnumeric/gnumeric_1.5.3.bb2
-rw-r--r--packages/gnumeric/gnumeric_1.5.5.bb2
-rw-r--r--packages/gnumeric/gnumeric_1.5.90.bb2
-rw-r--r--packages/gnumeric/gnumeric_1.6.0.bb2
-rw-r--r--packages/gnumeric/gnumeric_1.6.1.bb2
6 files changed, 12 insertions, 0 deletions
diff --git a/packages/gnumeric/gnumeric_1.3.1.bb b/packages/gnumeric/gnumeric_1.3.1.bb
index 164982aec3..299c36cbb2 100644
--- a/packages/gnumeric/gnumeric_1.3.1.bb
+++ b/packages/gnumeric/gnumeric_1.3.1.bb
@@ -11,6 +11,8 @@ SRC_URI += 'file://workbook-control-gui-priv.h.patch;patch=1'
EXTRA_OEMAKE_prepend = ' ORBIT_IDL=`which orbit-idl-2` '
+PACKAGES_DYNAMIC = "gnumeric-plugin-*"
+
python populate_packages_prepend () {
gnumeric_libdir = bb.data.expand('${libdir}/gnumeric/${PV}/plugins', d)
diff --git a/packages/gnumeric/gnumeric_1.5.3.bb b/packages/gnumeric/gnumeric_1.5.3.bb
index 07960b1277..c3a594a391 100644
--- a/packages/gnumeric/gnumeric_1.5.3.bb
+++ b/packages/gnumeric/gnumeric_1.5.3.bb
@@ -11,6 +11,8 @@ SRC_URI += "file://remove-docs.patch;patch=1"
EXTRA_OECONF=" --without-perl "
+PACKAGES_DYNAMIC = "gnumeric-plugin-*"
+
python populate_packages_prepend () {
gnumeric_libdir = bb.data.expand('${libdir}/gnumeric/${PV}/plugins', d)
diff --git a/packages/gnumeric/gnumeric_1.5.5.bb b/packages/gnumeric/gnumeric_1.5.5.bb
index 07960b1277..c3a594a391 100644
--- a/packages/gnumeric/gnumeric_1.5.5.bb
+++ b/packages/gnumeric/gnumeric_1.5.5.bb
@@ -11,6 +11,8 @@ SRC_URI += "file://remove-docs.patch;patch=1"
EXTRA_OECONF=" --without-perl "
+PACKAGES_DYNAMIC = "gnumeric-plugin-*"
+
python populate_packages_prepend () {
gnumeric_libdir = bb.data.expand('${libdir}/gnumeric/${PV}/plugins', d)
diff --git a/packages/gnumeric/gnumeric_1.5.90.bb b/packages/gnumeric/gnumeric_1.5.90.bb
index 3f19f36757..18ab5472a4 100644
--- a/packages/gnumeric/gnumeric_1.5.90.bb
+++ b/packages/gnumeric/gnumeric_1.5.90.bb
@@ -11,6 +11,8 @@ SRC_URI += "file://remove-docs.patch;patch=1"
EXTRA_OECONF=" --without-perl "
+PACKAGES_DYNAMIC = "gnumeric-plugin-*"
+
python populate_packages_prepend () {
gnumeric_libdir = bb.data.expand('${libdir}/gnumeric/${PV}/plugins', d)
diff --git a/packages/gnumeric/gnumeric_1.6.0.bb b/packages/gnumeric/gnumeric_1.6.0.bb
index 3f19f36757..18ab5472a4 100644
--- a/packages/gnumeric/gnumeric_1.6.0.bb
+++ b/packages/gnumeric/gnumeric_1.6.0.bb
@@ -11,6 +11,8 @@ SRC_URI += "file://remove-docs.patch;patch=1"
EXTRA_OECONF=" --without-perl "
+PACKAGES_DYNAMIC = "gnumeric-plugin-*"
+
python populate_packages_prepend () {
gnumeric_libdir = bb.data.expand('${libdir}/gnumeric/${PV}/plugins', d)
diff --git a/packages/gnumeric/gnumeric_1.6.1.bb b/packages/gnumeric/gnumeric_1.6.1.bb
index 3f19f36757..18ab5472a4 100644
--- a/packages/gnumeric/gnumeric_1.6.1.bb
+++ b/packages/gnumeric/gnumeric_1.6.1.bb
@@ -11,6 +11,8 @@ SRC_URI += "file://remove-docs.patch;patch=1"
EXTRA_OECONF=" --without-perl "
+PACKAGES_DYNAMIC = "gnumeric-plugin-*"
+
python populate_packages_prepend () {
gnumeric_libdir = bb.data.expand('${libdir}/gnumeric/${PV}/plugins', d)