aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gnupg
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-24 01:40:08 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-24 01:40:08 +0000
commita702a4829935cbe81edef1de716bc81664f94e0a (patch)
treeb9e32f8d19be7ba4b12a7d1a55c2e5ff74b14209 /packages/gnupg
parent58b704b108847c779bf8fef38bd523183207c1ae (diff)
downloadopenembedded-a702a4829935cbe81edef1de716bc81664f94e0a.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/02/23 19:29:51-06:00 ti.com!kergoth Rename gnupg-devel to gnupg2, since this development branch has the binaries postfixed that way, so is clearly for the upcoming 2.x stable release. Also change libexecdir from /usr/libexec to /usr/libexec/gnupg2, as it was resulting in the gnupg binaries ending up in the root of /usr/libexec, rather than by packagename. 2005/02/23 19:24:52-06:00 ti.com!kergoth Fix the ipk rootfs/image classes to use ${libdir}/ipkg, now that ipkg does so as well. 2005/02/23 19:22:38-06:00 ti.com!kergoth Add a development version of gnupg (version 1.9.15) as gnupg-devel. Note that the 'gpgsm' and 'scdaemon' binaries are not currently being built, due to the additional dependencies they introduce. If you need them, let me know. One issue that needs to be fixed is that the gnupg-devel build needs to prefix or postfix its binaries, or conflict with 'gnupg', to ensure they don't step on one another's toes. 2005/02/23 19:18:34-06:00 ti.com!kergoth Add libgpg-error 1.0 (required by gnupg 0.9.15) and make the libgpg-error .bb's inherit binconfig. 2005/02/23 19:17:35-06:00 ti.com!kergoth Add libgcrypt 1.2.1 and make the libgcrypt .bb's inherit binconfig. 2005/02/23 19:16:20-06:00 ti.com!kergoth Add libassuan 0.6.9 (required by gnupg 0.9.15) and make the libassuan .bb's inherit binconfig. BKrev: 421d3078taXhU4QcW7mi0rDTzgYsgA
Diffstat (limited to 'packages/gnupg')
-rw-r--r--packages/gnupg/gnupg.inc73
-rw-r--r--packages/gnupg/gnupg2.inc0
-rw-r--r--packages/gnupg/gnupg2_1.9.15.bb0
3 files changed, 73 insertions, 0 deletions
diff --git a/packages/gnupg/gnupg.inc b/packages/gnupg/gnupg.inc
index e69de29bb2..717d76fdaa 100644
--- a/packages/gnupg/gnupg.inc
+++ b/packages/gnupg/gnupg.inc
@@ -0,0 +1,73 @@
+SECTION = "console/utils"
+DESCRIPTION = "gnupg - GNU privacy guard"
+HOMEPAGE = "http://www.gnupg.org/"
+LICENSE = "GPLv2"
+MAINTAINER = "Pawel Osiczko <p.osiczko@tetrapyloctomy.org>"
+DEPENDS = "zlib bzip2"
+
+inherit autotools gettext
+
+MIRRORS_prepend () {
+ftp://ftp.gnupg.org/gcrypt http://mirrors.rootmode.com/ftp.gnupg.org
+}
+SRC_URI = "ftp://ftp.gnupg.org/gcrypt/gnupg/gnupg-${PV}.tar.bz2"
+S = "${WORKDIR}/gnupg-${PV}"
+
+# --with-egd-socket=NAME use NAME for the EGD socket
+# --with-photo-viewer=FIXED_VIEWER set a fixed photo ID viewer
+# --with-included-zlib use the zlib code included here
+# --with-capabilities use linux capabilities default=no
+# --with-mailprog=NAME use "NAME -t" for mail transport
+# --with-libiconv-prefix[=DIR] search for libiconv in DIR/include and DIR/lib
+# --without-libiconv-prefix don't search for libiconv in includedir and libdir
+# --with-included-gettext use the GNU gettext library included here
+# --with-libintl-prefix[=DIR] search for libintl in DIR/include and DIR/lib
+# --without-libintl-prefix don't search for libintl in includedir and libdir
+# --with-included-regex use the included GNU regex library
+# --with-zlib=DIR use libz in DIR
+# --with-bzip2=DIR look for bzip2 in DIR
+# --enable-static-rnd=egd|unix|linux|auto
+# --disable-dev-random disable the use of dev random
+# --disable-asm do not use assembler modules
+# --enable-m-guard enable memory guard facility
+# --enable-selinux-support
+# enable SELinux support
+# --disable-card-support disable OpenPGP card support
+# --disable-gnupg-iconv disable the new iconv code
+# --enable-backsigs enable the experimental backsigs code
+# --enable-minimal build the smallest gpg binary possible
+# --disable-rsa disable the RSA public key algorithm
+# --disable-idea disable the IDEA cipher
+# --disable-cast5 disable the CAST5 cipher
+# --disable-blowfish disable the BLOWFISH cipher
+# --disable-aes disable the AES, AES192, and AES256 ciphers
+# --disable-twofish disable the TWOFISH cipher
+# --disable-sha256 disable the SHA-256 digest
+# --disable-sha512 disable the SHA-384 and SHA-512 digests
+# --disable-bzip2 disable the BZIP2 compression algorithm
+# --disable-exec disable all external program execution
+# --disable-photo-viewers disable photo ID viewers
+# --disable-keyserver-helpers disable all external keyserver support
+# --disable-ldap disable LDAP keyserver interface
+# --disable-hkp disable HKP keyserver interface
+# --disable-http disable HTTP key fetching interface
+# --disable-finger disable Finger key fetching interface
+# --disable-mailto disable email keyserver interface
+# --disable-keyserver-path disable the exec-path option for keyserver helpers
+# --enable-key-cache=SIZE Set key cache to SIZE (default 4096)
+# --disable-largefile omit support for large files
+# --disable-dns-srv disable the use of DNS SRV in HKP and HTTP
+# --disable-nls do not use Native Language Support
+# --disable-regex do not handle regular expressions in trust sigs
+
+EXTRA_OECONF = "--disable-ldap \
+ --with-zlib=${STAGING_LIBDIR}/.. \
+ --with-bzip2=${STAGING_LIBDIR}/.. \
+ --disable-selinux-support"
+
+do_install () {
+ autotools_do_install
+ install -d ${D}${docdir}/${PN}
+ mv ${D}${datadir}/${PN}/* ${D}/${docdir}/${PN}/ || :
+ mv ${D}${prefix}/doc/* ${D}/${docdir}/${PN}/ || :
+}
diff --git a/packages/gnupg/gnupg2.inc b/packages/gnupg/gnupg2.inc
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/gnupg/gnupg2.inc
diff --git a/packages/gnupg/gnupg2_1.9.15.bb b/packages/gnupg/gnupg2_1.9.15.bb
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/gnupg/gnupg2_1.9.15.bb