aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gnuradio
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2007-07-27 12:19:58 +0000
committerKoen Kooi <koen@openembedded.org>2007-07-27 12:19:58 +0000
commit40d3de312d7892436cb00b8bdb77eda0746564b1 (patch)
tree7e70fb76fb781b718754412cc16de94633f30121 /packages/gnuradio
parent12e9dd26696aaa5b1ffbc48b8d8eff9afc2c6102 (diff)
downloadopenembedded-40d3de312d7892436cb00b8bdb77eda0746564b1.tar.gz
gnuradio: fixes
* update PV to 3.0.4 * patch out doc generation for gr-trellis subdir * packages all libs seperately * package python files as well
Diffstat (limited to 'packages/gnuradio')
-rw-r--r--packages/gnuradio/gnuradio/.mtn2git_empty0
-rw-r--r--packages/gnuradio/gnuradio/no-trellis-doc.patch9
-rw-r--r--packages/gnuradio/gnuradio_svn.bb20
3 files changed, 26 insertions, 3 deletions
diff --git a/packages/gnuradio/gnuradio/.mtn2git_empty b/packages/gnuradio/gnuradio/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/gnuradio/gnuradio/.mtn2git_empty
diff --git a/packages/gnuradio/gnuradio/no-trellis-doc.patch b/packages/gnuradio/gnuradio/no-trellis-doc.patch
new file mode 100644
index 0000000000..1e5148d3f9
--- /dev/null
+++ b/packages/gnuradio/gnuradio/no-trellis-doc.patch
@@ -0,0 +1,9 @@
+--- /tmp/Makefile.am 2007-07-27 13:44:31.000000000 +0200
++++ trunk/gr-trellis/Makefile.am 2007-07-27 13:50:06.795215000 +0200
+@@ -21,5 +21,5 @@
+
+ include $(top_srcdir)/Makefile.common
+
+-SUBDIRS = src doc
++SUBDIRS = src
+
diff --git a/packages/gnuradio/gnuradio_svn.bb b/packages/gnuradio/gnuradio_svn.bb
index f3d4873e5a..0eed243618 100644
--- a/packages/gnuradio/gnuradio_svn.bb
+++ b/packages/gnuradio/gnuradio_svn.bb
@@ -3,13 +3,16 @@ SECTION = "apps"
PRIORITY = "optional"
LICENSE = "GPL"
DEPENDS = "fftwf python boost cppunit sdcc-native swig swig-native"
-RDEPENDS = "libfftwf python swig"
-PV = "0.0+svn${SRCDATE}"
+RDEPENDS_${PN} = "python-core swig"
+
+PV = "3.0.4+svn${SRCDATE}"
PR = "r0"
-SRC_URI = "svn://gnuradio.org/svn/gnuradio;module=trunk;proto=http"
+SRC_URI = "svn://gnuradio.org/svn/gnuradio;module=trunk;proto=http \
+ file://no-trellis-doc.patch;patch=1 \
+ "
inherit autotools pkgconfig
@@ -22,3 +25,14 @@ export HOST_SYS := "${HOST_SYS}"
EXTRA_OECONF = "--disable-gr-atsc --disable-gr-video-sdl"
+PACKAGES =+ "libgromnithread libgnuradio-core libgnuradio-core-qa"
+FILES_libgnuradio-core = "${libdir}/libgnuradio-core.so.*"
+FILES_libgnuradio-core-qa = "${libdir}/libgnuradio-core-qa.so.*"
+FILES_libgromnithread = "${libdir}/libgromnithread.so*"
+
+FILES_${PN} += "${libdir}/python*/site-packages/gnuradio/*"
+FILES_${PN}-dbg += "${libdir}/python*/site-packages/gnuradio/.debug \
+ ${libdir}/python*/site-packages/gnuradio/*/.debug \
+ "
+
+