aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gnutls
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2006-05-23 16:31:13 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-05-23 16:31:13 +0000
commit665b18531d8ae69b3f1af008a3153c6298d3061a (patch)
tree10d2144e1ca11316252d8af46009c9d63af5fa3f /packages/gnutls
parentcb93e08f81bbce50ad035e4dc933ac84ef053c17 (diff)
downloadopenembedded-665b18531d8ae69b3f1af008a3153c6298d3061a.tar.gz
gnutls: added 1.4.0 (current stable)
- we probably should drop 1.0.xx (old old stable) and 1.3.5 (development) versions
Diffstat (limited to 'packages/gnutls')
-rw-r--r--packages/gnutls/gnutls-1.4.0/.mtn2git_empty0
-rw-r--r--packages/gnutls/gnutls-1.4.0/gnutls-openssl.patch120
-rw-r--r--packages/gnutls/gnutls-1.4.0/gnutls-texinfo-euro.patch16
-rw-r--r--packages/gnutls/gnutls_1.4.0.bb34
4 files changed, 170 insertions, 0 deletions
diff --git a/packages/gnutls/gnutls-1.4.0/.mtn2git_empty b/packages/gnutls/gnutls-1.4.0/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/gnutls/gnutls-1.4.0/.mtn2git_empty
diff --git a/packages/gnutls/gnutls-1.4.0/gnutls-openssl.patch b/packages/gnutls/gnutls-1.4.0/gnutls-openssl.patch
new file mode 100644
index 0000000000..6eca97efd7
--- /dev/null
+++ b/packages/gnutls/gnutls-1.4.0/gnutls-openssl.patch
@@ -0,0 +1,120 @@
+--- gnutls-1.3.5/libextra/gnutls_openssl.c.orig 2006-04-28 20:01:40.000000000 +0100
++++ gnutls-1.3.5/libextra/gnutls_openssl.c 2006-04-28 20:10:33.000000000 +0100
+@@ -252,12 +252,17 @@
+ ssl->rfd = (gnutls_transport_ptr_t) - 1;
+ ssl->wfd = (gnutls_transport_ptr_t) - 1;
+
++ ssl->ssl_peek_buffer = NULL;
++ ssl->ssl_peek_buffer_size = ssl->ssl_peek_avail = 0;
++
+ return ssl;
+ }
+
+ void
+ SSL_free (SSL * ssl)
+ {
++ if (ssl->ssl_peek_buffer)
++ free(ssl->ssl_peek_buffer);
+ gnutls_certificate_free_credentials (ssl->gnutls_cred);
+ gnutls_deinit (ssl->gnutls_state);
+ free (ssl);
+@@ -281,6 +286,7 @@
+ SSL_set_fd (SSL * ssl, int fd)
+ {
+ gnutls_transport_set_ptr (ssl->gnutls_state, (gnutls_transport_ptr_t) fd);
++ ssl->rfd = ssl->wfd = fd;
+ return 1;
+ }
+
+@@ -306,6 +312,17 @@
+ return 1;
+ }
+
++int SSL_get_rfd(SSL *ssl)
++{
++ return ssl->rfd;
++}
++
++int SSL_get_wfd(SSL *ssl)
++{
++ return ssl->wfd;
++}
++
++
+ void
+ SSL_set_bio (SSL * ssl, BIO * rbio, BIO * wbio)
+ {
+@@ -321,6 +338,8 @@
+ int
+ SSL_pending (SSL * ssl)
+ {
++ if (ssl->ssl_peek_avail)
++ return ssl->ssl_peek_avail;
+ return gnutls_record_check_pending (ssl->gnutls_state);
+ }
+
+@@ -476,11 +495,50 @@
+ return 1;
+ }
+
++int SSL_peek(SSL *ssl, void *buf, int len)
++{
++ if (len > ssl->ssl_peek_buffer_size) {
++ ssl->ssl_peek_buffer = realloc (ssl->ssl_peek_buffer, len);
++ ssl->ssl_peek_buffer_size = len;
++ }
++
++ if (ssl->ssl_peek_avail == 0) {
++
++ int ret;
++
++ ret = gnutls_record_recv(ssl->gnutls_state, ssl->ssl_peek_buffer, len);
++ ssl->last_error = ret;
++
++ if (ret > 0)
++ ssl->ssl_peek_avail += ret;
++ }
++
++ if (len > ssl->ssl_peek_avail)
++ len = ssl->ssl_peek_avail;
++
++ memcpy (buf, ssl->ssl_peek_buffer, len);
++
++ return len;
++}
++
+ int
+ SSL_read (SSL * ssl, void *buf, int len)
+ {
+ int ret;
+
++ if (ssl->ssl_peek_avail) {
++ int n = (ssl->ssl_peek_avail > len) ? len : ssl->ssl_peek_avail;
++
++ memcpy (buf, ssl->ssl_peek_buffer, n);
++
++ if (ssl->ssl_peek_avail > n)
++ memmove (ssl->ssl_peek_buffer, ssl->ssl_peek_buffer + n, ssl->ssl_peek_avail - n);
++
++ ssl->ssl_peek_avail -= n;
++
++ return n;
++ }
++
+ ret = gnutls_record_recv (ssl->gnutls_state, buf, len);
+ ssl->last_error = ret;
+
+--- gnutls-1.3.5/includes/gnutls/openssl.h.orig 2006-04-28 20:10:55.000000000 +0100
++++ gnutls-1.3.5/includes/gnutls/openssl.h 2006-04-28 20:11:52.000000000 +0100
+@@ -164,6 +164,11 @@
+
+ gnutls_transport_ptr_t rfd;
+ gnutls_transport_ptr_t wfd;
++
++ char *ssl_peek_buffer;
++ size_t ssl_peek_buffer_size;
++ size_t ssl_peek_avail;
++
+ };
+
+ #define rbio gnutls_state
diff --git a/packages/gnutls/gnutls-1.4.0/gnutls-texinfo-euro.patch b/packages/gnutls/gnutls-1.4.0/gnutls-texinfo-euro.patch
new file mode 100644
index 0000000000..e2a2762424
--- /dev/null
+++ b/packages/gnutls/gnutls-1.4.0/gnutls-texinfo-euro.patch
@@ -0,0 +1,16 @@
+The version of texinfo in Debian Sarge does not understand the @euro{} command.
+This patch replaces the @euro{} command with the word "euro".
+
+--- gnutls-1.3.5/doc/signatures.texi.orig 2006-04-26 08:06:40.918268000 +0930
++++ gnutls-1.3.5/doc/signatures.texi 2006-04-26 08:06:52.446515440 +0930
+@@ -11,8 +11,8 @@
+ long as it is difficult enough to generate two different messages with
+ the same hash algorithm output. In that case the same signature could
+ be used as a proof for both messages. Nobody wants to sign an innocent
+-message of donating 1 @euro{} to Greenpeace and find out that he
+-donated 1.000.000 @euro{} to Bad Inc.
++message of donating 1 euro to Greenpeace and find out that he
++donated 1.000.000 euro to Bad Inc.
+
+ For a hash algorithm to be called cryptographic the following three
+ requirements must hold
diff --git a/packages/gnutls/gnutls_1.4.0.bb b/packages/gnutls/gnutls_1.4.0.bb
new file mode 100644
index 0000000000..3c48bc95ff
--- /dev/null
+++ b/packages/gnutls/gnutls_1.4.0.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "GNU Transport Layer Security Library"
+DEPENDS = "zlib libgcrypt lzo"
+MAINTAINER = "Eric Shattow <lucent@gmail.com>"
+HOMEPAGE = "http://www.gnu.org/software/gnutls/"
+LICENSE = "LGPL"
+
+SRC_URI = "ftp://ftp.gnutls.org/pub/gnutls/gnutls-${PV}.tar.bz2 \
+ file://gnutls-openssl.patch;patch=1 \
+ file://gnutls-texinfo-euro.patch;patch=1"
+
+inherit autotools binconfig
+
+PACKAGES =+ "${PN}-openssl ${PN}-extra ${PN}-bin"
+FILES_${PN}-openssl = "${libdir}/libgnutls-openssl.so.*"
+FILES_${PN}-extra = "${libdir}/libgnutls-extra.so.*"
+FILES_${PN} = "${libdir}/libgnutls.so.*"
+FILES_${PN}-bin = "${bindir}/gnutls-serv \
+ ${bindir}/gnutls-cli \
+ ${bindir}/srptool \
+ ${bindir}/certtool \
+ ${bindir}/gnutls-srpcrypt \
+ ${bindir}/psktool"
+
+FILES_${PN}-dev += "${bindir}/*-config ${bindir}/gnutls-cli-debug"
+
+EXTRA_OECONF="--with-included-opencdk --with-included-libtasn1"
+
+do_stage() {
+ oe_libinstall -C lib/.libs -so -a libgnutls ${STAGING_LIBDIR}
+ oe_libinstall -C libextra/.libs -so -a libgnutls-extra ${STAGING_LIBDIR}
+ oe_libinstall -C libextra/.libs -so -a libgnutls-openssl ${STAGING_LIBDIR}
+ autotools_stage_includes
+}
+