aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gnutls
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2005-09-07 13:43:38 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-09-07 13:43:38 +0000
commit70069063f805bda312521f28a7370fc6d1e8be10 (patch)
tree36e23d83a07d13ba7c9cc281467486d9a0ac5649 /packages/gnutls
parentbf64048a34c55beb9c9b854871cc772f0b1c2d0e (diff)
downloadopenembedded-70069063f805bda312521f28a7370fc6d1e8be10.tar.gz
added gnutls 1.0.25
Diffstat (limited to 'packages/gnutls')
-rw-r--r--packages/gnutls/gnutls-1.0.25/.mtn2git_empty0
-rw-r--r--packages/gnutls/gnutls-1.0.25/export-symbols.patch11
-rw-r--r--packages/gnutls/gnutls-1.0.25/gnutls-openssl.patch126
-rw-r--r--packages/gnutls/gnutls_1.0.25.bb29
4 files changed, 166 insertions, 0 deletions
diff --git a/packages/gnutls/gnutls-1.0.25/.mtn2git_empty b/packages/gnutls/gnutls-1.0.25/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/gnutls/gnutls-1.0.25/.mtn2git_empty
diff --git a/packages/gnutls/gnutls-1.0.25/export-symbols.patch b/packages/gnutls/gnutls-1.0.25/export-symbols.patch
new file mode 100644
index 0000000000..22a1373944
--- /dev/null
+++ b/packages/gnutls/gnutls-1.0.25/export-symbols.patch
@@ -0,0 +1,11 @@
+--- gnutls-1.0.23/lib/Makefile.am.orig 2005-06-04 13:46:26.000000000 +0200
++++ gnutls-1.0.23/lib/Makefile.am 2005-06-04 13:48:38.000000000 +0200
+@@ -9,7 +9,7 @@
+ pkgconfig_DATA = gnutls.pc
+ DISTCLEANFILES = $(pkgconfig_DATA)
+
+-LIBGNUTLS_EXPORTS = -export-symbols-regex '^(_gnutls|gnutls|_E_).*'
++LIBGNUTLS_EXPORTS = -export-symbols-regex '^(asn1_|_gnutls|gnutls|_E_).*'
+
+ DIST_SUBDIRS = minitasn1 x509
+ if ENABLE_MINITASN1
diff --git a/packages/gnutls/gnutls-1.0.25/gnutls-openssl.patch b/packages/gnutls/gnutls-1.0.25/gnutls-openssl.patch
new file mode 100644
index 0000000000..3ddd8b3a18
--- /dev/null
+++ b/packages/gnutls/gnutls-1.0.25/gnutls-openssl.patch
@@ -0,0 +1,126 @@
+--- clean/gnutls-1.0.23/libextra/gnutls_openssl.c 2004-08-04 22:36:03.000000000 +0100
++++ gnutls-1.0.23/libextra/gnutls_openssl.c 2005-01-02 19:50:49.000000000 +0000
+@@ -31,7 +31,6 @@
+
+ static int last_error = 0;
+
+-
+ /* Library initialisation functions */
+
+ int SSL_library_init(void)
+@@ -219,12 +218,17 @@
+
+ ssl->rfd = (gnutls_transport_ptr)-1;
+ ssl->wfd = (gnutls_transport_ptr)-1;
++
++ ssl->ssl_peek_buffer = NULL;
++ ssl->ssl_peek_buffer_size = ssl->ssl_peek_avail = 0;
+
+ return ssl;
+ }
+
+ void SSL_free(SSL *ssl)
+ {
++ if (ssl->ssl_peek_buffer)
++ free(ssl->ssl_peek_buffer);
+ gnutls_certificate_free_credentials(ssl->gnutls_cred);
+ gnutls_deinit(ssl->gnutls_state);
+ free(ssl);
+@@ -245,6 +249,7 @@
+ int SSL_set_fd(SSL *ssl, int fd)
+ {
+ gnutls_transport_set_ptr (ssl->gnutls_state, (gnutls_transport_ptr)fd);
++ ssl->rfd = ssl->wfd = fd;
+ return 1;
+ }
+
+@@ -268,6 +273,16 @@
+ return 1;
+ }
+
++int SSL_get_rfd(SSL *ssl)
++{
++ return ssl->rfd;
++}
++
++int SSL_get_wfd(SSL *ssl)
++{
++ return ssl->wfd;
++}
++
+ void SSL_set_bio(SSL *ssl, BIO *rbio, BIO *wbio)
+ {
+ gnutls_transport_set_ptr2 (ssl->gnutls_state, rbio->fd, wbio->fd);
+@@ -280,6 +295,9 @@
+
+ int SSL_pending(SSL *ssl)
+ {
++ if (ssl->ssl_peek_avail)
++ return ssl->ssl_peek_avail;
++
+ return gnutls_record_check_pending(ssl->gnutls_state);
+ }
+
+@@ -430,10 +448,49 @@
+ return 1;
+ }
+
++int SSL_peek(SSL *ssl, void *buf, int len)
++{
++ if (len > ssl->ssl_peek_buffer_size) {
++ ssl->ssl_peek_buffer = realloc (ssl->ssl_peek_buffer, len);
++ ssl->ssl_peek_buffer_size = len;
++ }
++
++ if (ssl->ssl_peek_avail == 0) {
++
++ int ret;
++
++ ret = gnutls_record_recv(ssl->gnutls_state, ssl->ssl_peek_buffer, len);
++ ssl->last_error = ret;
++
++ if (ret > 0)
++ ssl->ssl_peek_avail += ret;
++ }
++
++ if (len > ssl->ssl_peek_avail)
++ len = ssl->ssl_peek_avail;
++
++ memcpy (buf, ssl->ssl_peek_buffer, len);
++
++ return len;
++}
++
+ int SSL_read(SSL *ssl, void *buf, int len)
+ {
+ int ret;
+
++ if (ssl->ssl_peek_avail) {
++ int n = (ssl->ssl_peek_avail > len) ? len : ssl->ssl_peek_avail;
++
++ memcpy (buf, ssl->ssl_peek_buffer, n);
++
++ if (ssl->ssl_peek_avail > n)
++ memmove (ssl->ssl_peek_buffer, ssl->ssl_peek_buffer + n, ssl->ssl_peek_avail - n);
++
++ ssl->ssl_peek_avail -= n;
++
++ return n;
++ }
++
+ ret = gnutls_record_recv(ssl->gnutls_state, buf, len);
+ ssl->last_error = ret;
+
+--- clean/gnutls-1.0.23/includes/gnutls/openssl.h 2004-08-04 22:36:02.000000000 +0100
++++ gnutls-1.0.23/includes/gnutls/openssl.h 2005-01-02 19:48:35.000000000 +0000
+@@ -139,6 +139,10 @@
+
+ gnutls_transport_ptr rfd;
+ gnutls_transport_ptr wfd;
++
++ char *ssl_peek_buffer;
++ size_t ssl_peek_buffer_size;
++ size_t ssl_peek_avail;
+ } SSL;
+
+ typedef struct
diff --git a/packages/gnutls/gnutls_1.0.25.bb b/packages/gnutls/gnutls_1.0.25.bb
new file mode 100644
index 0000000000..3b169317de
--- /dev/null
+++ b/packages/gnutls/gnutls_1.0.25.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "GNU Transport Layer Security Library"
+DEPENDS = "zlib libgcrypt"
+
+LICENSE = "LGPL"
+
+SRC_URI = "ftp://ftp.gnutls.org/pub/gnutls/gnutls-${PV}.tar.gz \
+ file://gnutls-openssl.patch;patch=1 \
+ file://export-symbols.patch;patch=1"
+
+inherit autotools
+inherit binconfig
+
+PACKAGES =+ "${PN}-openssl ${PN}-extra ${PN}-bin"
+FILES_${PN}-openssl = "${libdir}/libgnutls-openssl.so.*"
+FILES_${PN}-extra = "${libdir}/libgnutls-extra.so.*"
+FILES_${PN} = "${libdir}/libgnutls.so.*"
+FILES_${PN}-bin = "${bindir}/gnutls-serv ${bindir}/gnutls-cli \
+ ${bindir}/srptool ${bindir}/certtool ${bindir}/gnutls-srpcrypt"
+FILES_${PN}-dev += "${bindir}/*-config ${bindir}/gnutls-cli-debug"
+
+EXTRA_OECONF="--with-included-opencdk --with-included-libtasn1"
+
+do_stage() {
+ oe_libinstall -C lib/.libs -so -a libgnutls ${STAGING_LIBDIR}
+ oe_libinstall -C libextra/.libs -so -a libgnutls-extra ${STAGING_LIBDIR}
+ oe_libinstall -C libextra/.libs -so -a libgnutls-openssl ${STAGING_LIBDIR}
+ autotools_stage_includes
+}
+