aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gpe-announce
diff options
context:
space:
mode:
authorSergey Lapin <slapinid@gmail.com>2007-06-14 22:56:44 +0000
committerPaul Sokolovsky <pmiscml@gmail.com>2007-06-14 22:56:44 +0000
commit91ff6376f04a7278aa6710c8d60865b5b4254279 (patch)
tree1f01b9310e4b2fb29705bb109e951f1f76d795ac /packages/gpe-announce
parenta67730afd1dd499e2486f345f1b8a7a665b8ea7f (diff)
downloadopenembedded-91ff6376f04a7278aa6710c8d60865b5b4254279.tar.gz
gpe-announce 0.13: Fix for libsoundgen 0.5.
Diffstat (limited to 'packages/gpe-announce')
-rw-r--r--packages/gpe-announce/files/.mtn2git_empty0
-rw-r--r--packages/gpe-announce/files/fix-esound.diff24
-rw-r--r--packages/gpe-announce/gpe-announce_0.13.bb2
3 files changed, 26 insertions, 0 deletions
diff --git a/packages/gpe-announce/files/.mtn2git_empty b/packages/gpe-announce/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/gpe-announce/files/.mtn2git_empty
diff --git a/packages/gpe-announce/files/fix-esound.diff b/packages/gpe-announce/files/fix-esound.diff
new file mode 100644
index 0000000000..71ff7e8f2c
--- /dev/null
+++ b/packages/gpe-announce/files/fix-esound.diff
@@ -0,0 +1,24 @@
+diff -ruN gpe-announce-0.13/callbacks.c gpe-announce-0.13-new/callbacks.c
+--- gpe-announce-0.13/callbacks.c 2007-06-14 20:56:15.000000000 +0400
++++ gpe-announce-0.13-new/callbacks.c 2005-08-24 23:04:31.000000000 +0400
+@@ -28,7 +28,7 @@
+ #include <linux/soundcard.h>
+ #include <pthread.h>
+
+-#include <gpe/soundgen.h>
++#include <soundgen.h>
+ #include <gpe/schedule.h>
+
+ #include <linux/types.h>
+diff -ruN gpe-announce-0.13/Makefile gpe-announce-0.13-new/Makefile
+--- gpe-announce-0.13/Makefile 2007-06-14 20:30:00.000000000 +0400
++++ gpe-announce-0.13-new/Makefile 2007-06-14 20:28:30.000000000 +0400
+@@ -43,7 +43,7 @@
+ all: $(PACKAGE)
+
+ $(PACKAGE): $(OBJS)
+- $(CC) -o $@ $^ $(LDFLAGS) $(PACKAGE_LDFLAGS) -lsoundgen -lschedule
++ $(CC) -o $@ $^ $(LDFLAGS) $(PACKAGE_LDFLAGS) -lsoundgen -lschedule -lesd
+
+ install-program: all
+ install -d $(DESTDIR)$(PREFIX)/bin
diff --git a/packages/gpe-announce/gpe-announce_0.13.bb b/packages/gpe-announce/gpe-announce_0.13.bb
index 6124b4c4a8..6ffe317a12 100644
--- a/packages/gpe-announce/gpe-announce_0.13.bb
+++ b/packages/gpe-announce/gpe-announce_0.13.bb
@@ -2,4 +2,6 @@ inherit gpe
DEPENDS = "libsoundgen libschedule gtk+ libgpewidget"
LICENSE = "GPL"
+PR = "r1"
+SRC_URI += "file://fix-esound.diff;patch=1"