aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gpe-bluetooth
diff options
context:
space:
mode:
authorPhilipp Zabel <philipp.zabel@gmail.com>2006-08-24 18:02:25 +0000
committerPhilipp Zabel <philipp.zabel@gmail.com>2006-08-24 18:02:25 +0000
commitddae175d473eadf224d0514f40e5ae3a2d9f21d6 (patch)
tree991e369d9f0634eef6e82021287f2c880cd33d1f /packages/gpe-bluetooth
parente18fa6d0854c3c5eb5744ffcd731a631795dda8e (diff)
downloadopenembedded-ddae175d473eadf224d0514f40e5ae3a2d9f21d6.tar.gz
gpe-bluetooth-0.54: add BTS support to hciattach script
Diffstat (limited to 'packages/gpe-bluetooth')
-rw-r--r--packages/gpe-bluetooth/files/hciattach-bts.patch16
-rw-r--r--packages/gpe-bluetooth/gpe-bluetooth_0.54.bb4
2 files changed, 19 insertions, 1 deletions
diff --git a/packages/gpe-bluetooth/files/hciattach-bts.patch b/packages/gpe-bluetooth/files/hciattach-bts.patch
new file mode 100644
index 0000000000..aeff8b02b1
--- /dev/null
+++ b/packages/gpe-bluetooth/files/hciattach-bts.patch
@@ -0,0 +1,16 @@
+--- gpe-bluetooth-0.54/hciattach.sh.orig 2006-08-20 15:04:05.341384325 +0200
++++ gpe-bluetooth-0.54/hciattach.sh 2006-08-20 15:05:04.629179674 +0200
+@@ -2,8 +2,12 @@
+
+ if [ -f /etc/sysconfig/bluetooth ]; then
+ . /etc/sysconfig/bluetooth
++ if [ -f "$BLUETOOTH_SCRIPT" ]; then
++ BTS="-S $BLUETOOTH_SCRIPT"
++ fi
++
++ exec /sbin/hciattach -n $BLUETOOTH_PORT $BLUETOOTH_PROTOCOL $BLUETOOTH_SPEED $BTS
+
+- exec /sbin/hciattach -n $BLUETOOTH_PORT $BLUETOOTH_PROTOCOL $BLUETOOTH_SPEED
+ else
+ echo "Bluetooth not configured"
+ exit 1
diff --git a/packages/gpe-bluetooth/gpe-bluetooth_0.54.bb b/packages/gpe-bluetooth/gpe-bluetooth_0.54.bb
index 1506bd4c8b..b02be325e6 100644
--- a/packages/gpe-bluetooth/gpe-bluetooth_0.54.bb
+++ b/packages/gpe-bluetooth/gpe-bluetooth_0.54.bb
@@ -3,7 +3,7 @@ DESCRIPTION = "GPE bluetooth support user interface tool."
SECTION = "gpe"
PRIORITY = "optional"
MAINTAINER = "Florian Boor <florian.boor@kernelconcepts.de>"
-PR = "r0"
+PR = "r1"
DEPENDS = "gtk+ libcontactsdb libdisplaymigration libgpewidget openobex libgpevtype bluez-libs sqlite dbus-glib libglade blueprobe bluez-utils-dbus"
RDEPENDS = "bluez-utils-dbus blueprobe"
@@ -11,4 +11,6 @@ RDEPENDS = "bluez-utils-dbus blueprobe"
GPE_TARBALL_SUFFIX= "bz2"
inherit gpe autotools
+SRC_URI += "file://hciattach-bts.patch;patch=1"
+
FILES_${PN} += '${datadir}/bluez-pin'