aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gpe-bootsplash
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-22 12:53:55 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-22 12:53:55 +0000
commit4f857db335de6935077d4866c51dd9d6851fed1d (patch)
tree1c923be071d1a56bd79f467fd75ac77959a493a3 /packages/gpe-bootsplash
parentb32403d57d7e0473dd336e76f95c7b26f113cf26 (diff)
downloadopenembedded-4f857db335de6935077d4866c51dd9d6851fed1d.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/02/21 17:35:27-06:00 ti.com!kergoth Kill the ipkg paths patch, since its busted. 2005/02/21 17:33:13-06:00 ti.com!kergoth Fix sbindir in native.bbclass and cross.bbclass. Thanks to Jordan Crouse for reporting. 2005/02/21 17:13:19-06:00 ti.com!kergoth Add the paths patch to ipkg which fixes it to no longer hardcode the '/usr/lib/ipkg' path, which I forgot to check in from the previous commit. 2005/02/21 17:09:46-06:00 ti.com!kergoth Merge oe-devel@oe-devel.bkbits.net:openembedded into odin.sc.ti.com:/home/kergoth/code/user/oe/openembedded 2005/02/21 17:09:03-06:00 ti.com!kergoth Run a sed script against our packages to fix some hardcoded target path references. As always when I do things like this, if packages you maintain were touched by this, please do a sanity check to ensure the sed script didn't run wild. 2005/02/21 15:49:47-06:00 ti.com!kergoth Use a HOTPLUG variable to manage which hotplug you prefer, to ensure that hotplug is still included in task-bootstrap even if you dont set DISTRO. BKrev: 421b2b63X5eoMcSrC7pVcptXK-iFKg
Diffstat (limited to 'packages/gpe-bootsplash')
-rw-r--r--packages/gpe-bootsplash/gpe-bootsplash_1.13.bb19
-rw-r--r--packages/gpe-bootsplash/gpe-bootsplash_1.14.bb2
2 files changed, 20 insertions, 1 deletions
diff --git a/packages/gpe-bootsplash/gpe-bootsplash_1.13.bb b/packages/gpe-bootsplash/gpe-bootsplash_1.13.bb
index e69de29bb2..bcf50ae7d2 100644
--- a/packages/gpe-bootsplash/gpe-bootsplash_1.13.bb
+++ b/packages/gpe-bootsplash/gpe-bootsplash_1.13.bb
@@ -0,0 +1,19 @@
+inherit gpe
+
+DEPENDS = "gtk+ librsvg"
+MAINTAINER = "Phil Blundell <pb@handhelds.org>"
+SECTION = "gpe"
+PRIORITY = "optional"
+LICENSE = "GPL"
+PR = "r2"
+
+SRC_URI += "file://splash-p.svg file://splash-l.svg"
+
+FILES_${PN} += "${datadir}/gpe"
+
+do_install_append() {
+ install -m 0644 ${WORKDIR}/splash-p.svg ${D}${datadir}/gpe/splash-p.svg
+ install -m 0644 ${WORKDIR}/splash-l.svg ${D}${datadir}/gpe/splash-l.svg
+ mv ${D}/${sysconfdir}/rcS.d/S00bootsplash ${D}/${sysconfdir}/rcS.d/S02bootsplash
+}
+
diff --git a/packages/gpe-bootsplash/gpe-bootsplash_1.14.bb b/packages/gpe-bootsplash/gpe-bootsplash_1.14.bb
index ab096f4426..a2bda8b6e0 100644
--- a/packages/gpe-bootsplash/gpe-bootsplash_1.14.bb
+++ b/packages/gpe-bootsplash/gpe-bootsplash_1.14.bb
@@ -14,6 +14,6 @@ FILES_${PN} += "${datadir}/gpe"
do_install_append() {
install -m 0644 ${WORKDIR}/splash-p.svg ${D}${datadir}/gpe/splash-p.svg
install -m 0644 ${WORKDIR}/splash-l.svg ${D}${datadir}/gpe/splash-l.svg
- mv ${D}/etc/rcS.d/S00bootsplash ${D}/etc/rcS.d/S02bootsplash
+ mv ${D}/${sysconfdir}/rcS.d/S00bootsplash ${D}/${sysconfdir}/rcS.d/S02bootsplash
}