aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gpe-bootsplash
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2006-03-21 00:15:30 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-03-21 00:15:30 +0000
commitfcb25687f94b18745daac744cd0e41cad324edf0 (patch)
treeace01313817c815d4d1b87760b6c7aeae3bb678f /packages/gpe-bootsplash
parent5b2fcb332f4ab742ae5f8248d988ae8460ca12d0 (diff)
downloadopenembedded-fcb25687f94b18745daac744cd0e41cad324edf0.tar.gz
gpe-bootsplash-themes: add FIXMEs and fix SRC_URI for theme-e (file+wildcards is problematic)
Diffstat (limited to 'packages/gpe-bootsplash')
-rw-r--r--packages/gpe-bootsplash/gpe-bootsplash-theme-e.bb15
-rw-r--r--packages/gpe-bootsplash/gpe-bootsplash-theme-opie.bb15
2 files changed, 16 insertions, 14 deletions
diff --git a/packages/gpe-bootsplash/gpe-bootsplash-theme-e.bb b/packages/gpe-bootsplash/gpe-bootsplash-theme-e.bb
index e95c09b3e8..5eeee0fffa 100644
--- a/packages/gpe-bootsplash/gpe-bootsplash-theme-e.bb
+++ b/packages/gpe-bootsplash/gpe-bootsplash-theme-e.bb
@@ -3,20 +3,19 @@ SECTION = "base"
PRIORITY = "optional"
MAINTAINER = "Matthias 'CoreDump' Hentges <oe@hentges.net>"
LICENSE = "GPL"
-
DEPENDS = "gpe-bootsplash"
RDEPENDS = "gpe-bootsplash"
-
-PR = "r0"
+PR = "r1"
export THEME = "e"
-SRC_URI = "file://*.svg"
-
-FILES_${PN} = "/usr/share/gpe/splash-${THEME}-*"
+SRC_URI = "file://splash-e-portrait.svg \
+ file://splash-e-landscape.svg"
+#FIXME: Please use $datadir instead of /usr/share
+#FIXME: please use an gpe-bootsplash-theme.inc to reduce duplication
-do_install(){
+do_install() {
install -d "${D}/usr/share/gpe"
install -m 0644 ${WORKDIR}/splash-${THEME}* ${D}/usr/share/gpe
}
@@ -30,3 +29,5 @@ pkg_postrm() {
update-alternatives --remove bootsplash-l /usr/share/gpe/splash-${THEME}-landscape.svg
update-alternatives --remove bootsplash-p /usr/share/gpe/splash-${THEME}-portrait.svg
}
+
+FILES_${PN} = "/usr/share/gpe/splash-${THEME}-*"
diff --git a/packages/gpe-bootsplash/gpe-bootsplash-theme-opie.bb b/packages/gpe-bootsplash/gpe-bootsplash-theme-opie.bb
index dff92e75c3..9aa2e9bc00 100644
--- a/packages/gpe-bootsplash/gpe-bootsplash-theme-opie.bb
+++ b/packages/gpe-bootsplash/gpe-bootsplash-theme-opie.bb
@@ -3,20 +3,17 @@ SECTION = "base"
PRIORITY = "optional"
MAINTAINER = "Matthias 'CoreDump' Hentges <oe@hentges.net>"
LICENSE = "GPL"
-
DEPENDS = "gpe-bootsplash"
RDEPENDS = "gpe-bootsplash"
-
-PR = "r0"
+PR = "r1"
export THEME = "opie"
SRC_URI = "file://*.svg \
- file://*${THEME}*logo*"
-
-FILES_${PN} = "/usr/share/gpe/splash-${THEME}-*\
- /usr/share/gpe/${THEME}-logo.png"
+ file://*${THEME}*logo*"
+#FIXME: please use $datadir instead of /usr/share
+#FIXME: please use an gpe-bootsplash-theme.inc to reduce duplication
do_install(){
install -d "${D}/usr/share/gpe"
@@ -33,3 +30,7 @@ pkg_postrm() {
update-alternatives --remove bootsplash-l /usr/share/gpe/splash-${THEME}-landscape.svg
update-alternatives --remove bootsplash-p /usr/share/gpe/splash-${THEME}-portrait.svg
}
+
+FILES_${PN} = "/usr/share/gpe/splash-${THEME}-* \
+ /usr/share/gpe/${THEME}-logo.png"
+