aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gpe-conf
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2006-09-07 13:04:32 +0000
committerKoen Kooi <koen@openembedded.org>2006-09-07 13:04:32 +0000
commitd7c5504299f2215ad653fb4352e196405a2dd3dd (patch)
treef0cac2ec8acb391cc93bdbfb7fc1237f81156d43 /packages/gpe-conf
parentd38cd863bfa830afbde586ad7478bfd8ae6b2987 (diff)
downloadopenembedded-d7c5504299f2215ad653fb4352e196405a2dd3dd.tar.gz
gpe-conf: reformat according to styleguide and drop obsolete versions
Diffstat (limited to 'packages/gpe-conf')
-rw-r--r--packages/gpe-conf/files/.mtn2git_empty0
-rw-r--r--packages/gpe-conf/files/Makefile.dpkg_ipkg114
-rw-r--r--packages/gpe-conf/files/Makefile.translation107
-rw-r--r--packages/gpe-conf/files/desktop-categories.patch10
-rw-r--r--packages/gpe-conf/files/fixsegfault.patch44
-rw-r--r--packages/gpe-conf/files/ipaq-sleep-configName.patch20
-rw-r--r--packages/gpe-conf/gpe-conf_0.1.30.bb28
-rw-r--r--packages/gpe-conf/gpe-conf_0.2.1.bb24
-rw-r--r--packages/gpe-conf/gpe-conf_0.2.2.bb10
-rw-r--r--packages/gpe-conf/gpe-conf_cvs.bb28
10 files changed, 20 insertions, 365 deletions
diff --git a/packages/gpe-conf/files/.mtn2git_empty b/packages/gpe-conf/files/.mtn2git_empty
deleted file mode 100644
index e69de29bb2..0000000000
--- a/packages/gpe-conf/files/.mtn2git_empty
+++ /dev/null
diff --git a/packages/gpe-conf/files/Makefile.dpkg_ipkg b/packages/gpe-conf/files/Makefile.dpkg_ipkg
deleted file mode 100644
index 978b08d91a..0000000000
--- a/packages/gpe-conf/files/Makefile.dpkg_ipkg
+++ /dev/null
@@ -1,114 +0,0 @@
-## Please read the README in this directory to see how to use this
-## Makefile snippet
-
-# Let's use whatever clean target the specific app provides
-
-CONTROL = `if test -e familiar/control1; then echo control1; else echo control; fi`
-
-# URL to source tarball
-SOURCE = ftp://gpe.handhelds.org/projects/gpe/source/$(PACKAGE)-$(VERSION).tar.gz
-
-# can change this to e.g. /var/tmp/deb
-DEB_PATH = ../deb
-
-ifeq ($(CVSBUILD),yes)
-LIBGPEWIDGET_PC = libgpewidget-uninstalled
-PC_EXTRA=PKG_CONFIG_PATH=../../base/libgpewidget
-else
-LIBGPEWIDGET_PC = libgpewidget
-endif
-
-ifeq ($(IN_LIBGPEWIDGET),)
-GPECFLAGS = $(shell $(PC_EXTRA) pkg-config --cflags $(LIBGPEWIDGET_PC))
-GPELIBS = $(shell $(PC_EXTRA) pkg-config --libs $(LIBGPEWIDGET_PC))
-endif
-
-GTKCFLAGS = $(shell pkg-config --cflags gtk+-2.0)
-GTKLIBS = $(shell pkg-config --libs gtk+-2.0)
-
-STANDARD_CPPFLAGS = -D_GNU_SOURCE -DPACKAGE=\"$(PACKAGE)\" -DPREFIX=\"$(PREFIX)\" -DPACKAGE_LOCALE_DIR=\"$(PREFIX)/share/locale\"
-STANDARD_CFLAGS = -MD -Wall
-
-ifeq ($(DEBUG),yes)
-CFLAGS += -O2 -g
-LDFLAGS = -g
-else
-CFLAGS += -Os -fomit-frame-pointer
-endif
-
-dist: check-source clean dist-prep
- rm -rf ../$(PACKAGE)-$(VERSION)
- mkdir ../$(PACKAGE)-$(VERSION)
- ( tar cf - --exclude "*/CVS" --exclude CVS --exclude "*~" --exclude "#*#" --exclude "debian" --exclude ".*" --exclude "*.ipk" --exclude "*.ipk.*" --exclude "*.mo" --exclude "*.batch" --exclude "translation-ipkgs.txt" * ) | (cd ../$(PACKAGE)-$(VERSION); tar xf -)
- ( if [ -f linguas ]; then LINGUAS=`cat linguas`; PATCH_LINGUAS="s:^LINGUAS =.*:LINGUAS = $${LINGUAS}:"; fi; cd ../$(PACKAGE)-$(VERSION) && mkdir build && cp $(BUILD)/Makefile.dpkg_ipkg $(BUILD)/Makefile.translation build/ && sed "s:^CVSBUILD =.*:CVSBUILD = no:;s:^DEBUG =.*:DEBUG = no:;s:Makefile.translation-auto-linguas:Makefile.translation:;$${PATCH_LINGUAS}" < Makefile > Makefile.new && mv Makefile.new Makefile )
- ( cd .. ; tar cf - $(PACKAGE)-$(VERSION) | gzip -9 >$(PACKAGE)-$(VERSION).tar.gz )
- rm -rf ../$(PACKAGE)-$(VERSION)
- $(MAKE) printinfo
-
-dist-upload: dist
- scp ../$(PACKAGE)-$(VERSION).tar.gz $(USER)@handhelds.org:/home/ftp/projects/gpe/source/
-
-dist-prep:
-ipkg-prep:
-install-mo:
-# empty, can be filled in Makefile.translation
-
-install: install-program install-mo
-
-clean-dist:
- rm -rf familiar/dist familiar/dist.list
-
-clean: clean-dist
-
-check-source:
- @if [ -f familiar/$(CONTROL) ] && ! grep -q '^Source:' familiar/$(CONTROL); then echo -e "\nNo Source: field in control file. Aborting.\n"; exit 1; fi
-
-ipkg: check-source ipkg-prep clean
- rm -rf familiar/dist
- mkdir -p familiar/dist/CONTROL
- sed 's:VERSION:$(VERSION):;s$$SOURCE$$$(SOURCE)$$' < familiar/$(CONTROL) > familiar/dist/CONTROL/control
- if test -e familiar/conffiles; then install -m 644 familiar/conffiles familiar/dist/CONTROL; fi
- if test -e familiar/preinst; then install familiar/preinst familiar/dist/CONTROL; fi
- if test -e familiar/postinst; then install familiar/postinst familiar/dist/CONTROL; fi
- if test -e familiar/prerm; then install familiar/prerm familiar/dist/CONTROL; fi
- if test -e familiar/postrm; then install familiar/postrm familiar/dist/CONTROL; fi
- $(MAKE) DESTDIR=`pwd`/familiar/dist PREFIX=/usr prefix=/usr DEBUG=no install-program
- rm -rf familiar/dist.list
- ipkg-build -o 0 -g 0 familiar/dist | sed 's/^Packaged .*into //; t 1; d; : 1; s:.*/::' >> familiar/dist.list
- if [ "x$(LINGUAS)" != "x" ]; then make translation-ipkg; tr ' ' '\n' < translation-ipkgs.txt >> familiar/dist.list; fi
- md5sum `cat familiar/dist.list` > $(PACKAGE)_$(VERSION).batch
- rm -rf familiar/dist familiar/dist.list
- $(MAKE) printinfo
-
-dpkg: dist
- mkdir -p $(DEB_PATH)
- ( olddir=`pwd`; cd $(DEB_PATH); rm -rf $(PACKAGE)-$(VERSION); ln -s $$olddir/../$(PACKAGE)-$(VERSION).tar.gz $(PACKAGE)_$(VERSION).orig.tar.gz ; tar xzf $(PACKAGE)_$(VERSION).orig.tar.gz )
- mkdir -p $(DEB_PATH)/$(PACKAGE)-$(VERSION)/debian
- for i in debian/*; do if test -f $$i; then cp $$i $(DEB_PATH)/$(PACKAGE)-$(VERSION)/debian/; fi; done
-
-CVSTAG := $(shell echo $(PACKAGE)-$(VERSION) | tr [a-z.] [A-Z_])
-printinfo:
- @printf '-------------------------------------------------------------------------------\n'
- @printf "If this becomes a package release, please add a CVS tag.\n"
- @printf "You can use 'make tag' for that, it will execute\n"
- @printf " cvs tag %s\n" $(CVSTAG)
- @printf "Please upload a tarball (created with 'make dist') to\n"
- @printf " ftp://ftp.handhelds.org/pub/projects/gpe/\n"
- @printf " (handhelds.org:~ftp/pub/projects/gpe/source)\n"
- @printf "You can use 'make dist-upload' to do that.\n"
- @printf "You are currently known as USER %s.\n" $(USER)
- @printf '-------------------------------------------------------------------------------\n'
-
-tag: check-source
- cvs tag $(CVSTAG)
-
-retag: check-source
- cvs tag -F $(CVSTAG)
-
-source: tag dist-upload
-
-%.pc: %.pc.in
- sed 's:PREFIX:$(PREFIX):;s:BUILDDIR:$(shell pwd):;s:VERSION:$(VERSION):' < $< > $@
-
-.c.o:;
- $(CC) $(CFLAGS) $(CPPFLAGS) $(PACKAGE_CFLAGS) $(PACKAGE_CPPFLAGS) -c $< -o $@
diff --git a/packages/gpe-conf/files/Makefile.translation b/packages/gpe-conf/files/Makefile.translation
deleted file mode 100644
index 1ca7d648fd..0000000000
--- a/packages/gpe-conf/files/Makefile.translation
+++ /dev/null
@@ -1,107 +0,0 @@
-.SUFFIXES: .mo .po .pot .po8
-
-CONTROL = `if test -e familiar/control1; then echo control1; else echo control; fi`
-
-# use ipkg-build or ipkg-deb-build
-IPKG_BUILD := ipkg-build
-
-TRANSLATION_SITE := http://www.iro.umontreal.ca/~gnutra/maint
-
-ifeq ($(DIR_PO),)
-DIR_PO := po
-endif
-
-ifeq ($(BINPACKAGE),)
-BINPACKAGE := $(PACKAGE)
-endif
-
-mo-files = $(patsubst %,$(DIR_PO)/%.mo,$(LINGUAS))
-po-files = $(patsubst %,$(DIR_PO)/%.po,$(LINGUAS))
-
-ifeq ($(shell if [ -f $(PACKAGE).desktop.in ]; then echo present; fi;),present)
-desktop-files += $(PACKAGE).desktop
-endif
-
-ifneq ($(EXTRA_DESKTOPS),)
-desktop-files += $(patsubst %.desktop.in,%.desktop,$(EXTRA_DESKTOPS))
-endif
-
-all-mo: $(mo-files)
-
-all-desktop: $(desktop-files)
-
-install-mo: all-mo
- if [ "$(ENABLE_NLS)" != "no" ]; then \
- if [ "x$(LINGUAS)" != "x" ]; then \
- for i in $(LINGUAS); do mkdir -p $(DESTDIR)$(PREFIX)/share/locale/$$i/LC_MESSAGES; install -m 644 $(DIR_PO)/$$i.mo $(DESTDIR)$(PREFIX)/share/locale/$$i/LC_MESSAGES/$(PACKAGE).mo; done \
- fi; \
- fi;
-
-.po8.mo:;
- if [ "$(ENABLE_NLS)" != "no" ]; then \
- msgfmt -o $@ $<; \
- fi;
-
-.po.po8:;
- CTYPE=`grep "^\"Content-Type:" $< | sed 's/^.*charset=//;s/\\\\.*//'`; sed "s/\(Content-Type: .*=\)$$CTYPE/\1UTF-8/" < $< | iconv -f $${CTYPE} -t UTF-8 >$@
-
-update-po: $(po-files) extract-po
-
-dist-prep: update-po freshen-po
-# empty
-
-ifeq ($(CVSBUILD),yes)
-ipkg-prep: freshen-po
-# empty
-endif
-
-extract-po:
- mkdir -p $(DIR_PO)
- ( SOURCES="$(SOURCES)"; for DESK in $(PACKAGE).desktop.in $(EXTRA_DESKTOPS); do if [ -f $$DESK ]; then intltool-extract --type=gettext/ini $$DESK; SOURCES="$$SOURCES $${DESK}.h"; fi; done; if [ "x$$SOURCES" != "x" ]; then xgettext --add-comments=TRANSLATORS: -k_ -kN_ -o $(DIR_PO)/$(PACKAGE).pot.new $$SOURCES; fi )
- if [ -f $(DIR_PO)/$(PACKAGE).pot.new ]; then if cmp -s $(DIR_PO)/$(PACKAGE).pot.new $(PACKAGE).pot; then rm $(DIR_PO)/$(PACKAGE).pot.new; else mv $(DIR_PO)/$(PACKAGE).pot.new $(DIR_PO)/$(PACKAGE).pot; fi; fi
-
-clean: clean-po clean-dist-translation
-
-clean-po:
- rm -rf $(DIR_PO)/*.mo
- for i in $(desktop-files); do if [ -f $$i.in ]; then rm -f $$i; rm -f $$i.in.h; fi; done
-
-%.desktop: %.desktop.in $(patsubst %,$(DIR_PO)/%.po,$(LINGUAS))
- intltool-merge -u -d $(DIR_PO) $< $@
-
-freshen-po:
- rm -rf tmp-po
- mkdir tmp-po
- cd tmp-po; for LANG in $(LINGUAS); do wget $(TRANSLATION_SITE)/$(PACKAGE)/$$LANG.po; done
- for LANG in $(LINGUAS); do if [ ! -f $(DIR_PO)/$$LANG.po ] || ! cmp -s $(DIR_PO)/$$LANG.po tmp-po/$$LANG.po ; then mv tmp-po/$$LANG.po $(DIR_PO)/$$LANG.po; echo "Updated $$LANG translation"; fi; done
- rm -rf tmp-po
-
-# ------------------------------------------------------------------------
-
-MAINTAINER = $(shell grep 'Maintainer: ' familiar/$(CONTROL) | cut -d ' ' -f 2-)
-
-ifndef BUILD
-BUILD = ../build
-endif
-
-transdist := familiar/dist-translation
-templates := $(BUILD)/familiar
-ipkglist := translation-ipkgs.txt
-
-clean-dist-translation:
- rm -rf $(transdist) $(ipkglist)
-
-real-translation-package: all-mo
- rm -rf $(transdist) $(ipkglist)
- for LINGUA in $(LINGUAS); do \
- i=$$(echo $$LINGUA | tr '[A-Z_]' '[a-z+]'); \
- mkdir -p $(transdist)/$$i/CONTROL; \
- mkdir -p $(transdist)/$$i$(PREFIX)/share/locale/$$LINGUA/LC_MESSAGES; \
- install -m 644 po/$$LINGUA.mo $(transdist)/$$i$(PREFIX)/share/locale/$$LINGUA/LC_MESSAGES/$(PACKAGE).mo; \
- sed -e "s/<maintainer>/$(MAINTAINER)/;s/<package>/$(BINPACKAGE)/;s/<version>/$(VERSION)/;s/<language>/$$i/;s!<source>!$(SOURCE)!" $(templates)/control.translation > $(transdist)/$$i/CONTROL/control; \
- install $(templates)/postinst.translation $(transdist)/$$i/CONTROL/postinst; \
- $(IPKG_BUILD) -g 0 -o 0 $(transdist)/$$i | sed 's/^Packaged .*into //; t 1; d; : 1; s:.*/::' >> $(ipkglist); \
- done
-
-translation-ipkg:
- make PREFIX=/usr real-translation-package
diff --git a/packages/gpe-conf/files/desktop-categories.patch b/packages/gpe-conf/files/desktop-categories.patch
deleted file mode 100644
index 57215aae6b..0000000000
--- a/packages/gpe-conf/files/desktop-categories.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- gpe-conf-0.1.22/gpe-conf.desktop.in.old 2004-11-29 19:54:23.000000000 +0000
-+++ gpe-conf-0.1.22/gpe-conf.desktop.in 2004-11-29 19:54:35.000000000 +0000
-@@ -5,6 +5,6 @@
- Terminal=0
- Type=Application
- Icon=gpe-config.png
--Categories=Application;SystemSettings;GPE
-+Categories=Application;GPE;
- StartupNotify=True
- SingleInstance=True
diff --git a/packages/gpe-conf/files/fixsegfault.patch b/packages/gpe-conf/files/fixsegfault.patch
deleted file mode 100644
index 7f1ccbe432..0000000000
--- a/packages/gpe-conf/files/fixsegfault.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-Index: network.c
-===================================================================
-RCS file: /cvs/gpe/base/gpe-conf/network.c,v
-retrieving revision 1.55.2.2
-retrieving revision 1.55.2.3
-diff -u -r1.55.2.2 -r1.55.2.3
---- network.c 16 Feb 2006 22:32:30 -0000 1.55.2.2
-+++ network.c 20 Feb 2006 01:34:44 -0000 1.55.2.3
-@@ -289,19 +289,23 @@
- i = iflen-1;
-
- fd = fopen(_PATH_PROCNET_WIRELESS, "r");
-- fgets(buffer, 256, fd); // chuck first two lines;
-- fgets(buffer, 256, fd);
-- while (!feof(fd)) {
-- if (fgets(buffer, 256, fd) == NULL)
-- break;
-- name = buffer;
-- sep = strrchr(buffer, ':');
-- if (sep) *sep = 0;
-- while(*name == ' ') name++;
-- if (!strcmp(name, ifname))
-- iflist[iflen - 1].iswireless = TRUE;
-- }
-+ if (fd != NULL)
-+ {
-+ fgets(buffer, 256, fd); // chuck first two lines;
-+ fgets(buffer, 256, fd);
-+ while (!feof(fd))
-+ {
-+ if (fgets(buffer, 256, fd) == NULL)
-+ break;
-+ name = buffer;
-+ sep = strrchr(buffer, ':');
-+ if (sep) *sep = 0;
-+ while(*name == ' ') name++;
-+ if (!strcmp(name, ifname))
-+ iflist[iflen - 1].iswireless = TRUE;
-+ }
- fclose(fd);
-+ }
- }
- else
- i = existing;
diff --git a/packages/gpe-conf/files/ipaq-sleep-configName.patch b/packages/gpe-conf/files/ipaq-sleep-configName.patch
deleted file mode 100644
index 34f22094ad..0000000000
--- a/packages/gpe-conf/files/ipaq-sleep-configName.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- gpe-conf-0.1.30/sleep/main.c.orig 2006-06-05 12:23:34.458994776 +0200
-+++ gpe-conf-0.1.30/sleep/main.c 2006-06-05 12:23:40.216119560 +0200
-@@ -23,7 +23,7 @@
- g_spawn_command_line_sync (cmd, NULL, NULL, NULL, NULL);
- if(save_ISconf(ISconf, ISconf->confName)) {
- char homeConf[MAXPATHLEN];
-- sprintf(homeConf, "%s/ipaq-sleep.conf", getenv("HOME"));
-+ sprintf(homeConf, "%s/.sleep.conf", getenv("HOME"));
- if(!save_ISconf(ISconf, homeConf))
- strcpy(ISconf->confName, homeConf);
- }
-@@ -42,7 +42,7 @@
- char cname[MAXPATHLEN];
- GtkWidget *GPE_Config_Sleep;
-
-- sprintf(cname,"%s/ipaq-sleep.conf",g_get_home_dir());
-+ sprintf(cname,"%s/.sleep.conf",g_get_home_dir());
- ISconf = load_ISconf(cname);
- if(ISconf == NULL) {
- strcpy(cname, "/etc/ipaq-sleep.conf");
diff --git a/packages/gpe-conf/gpe-conf_0.1.30.bb b/packages/gpe-conf/gpe-conf_0.1.30.bb
deleted file mode 100644
index 5588420e45..0000000000
--- a/packages/gpe-conf/gpe-conf_0.1.30.bb
+++ /dev/null
@@ -1,28 +0,0 @@
-PACKAGES = "gpe-conf gpe-conf-panel"
-LICENSE = "GPL"
-SECTION = "gpe"
-PRIORITY = "optional"
-MAINTAINER = "Florian Boor <florian.boor@kernelconcepts.de>"
-PR="r2"
-
-inherit gpe
-
-SRC_URI += " file://fixsegfault.patch;patch=1;pnum=0 \
- file://ipaq-sleep-configName.patch;patch=1"
-
-DEPENDS = "gtk+ libgpewidget libxsettings libxsettings-client pcmcia-cs xst xset ipaq-sleep ntp gpe-login gpe-icons"
-RDEPENDS_${PN} = "xst xset ipaq-sleep ntpdate gpe-login gpe-icons"
-RDEPENDS_gpe-conf-panel = "gpe-conf"
-FILES_${PN} = "${sysconfdir} ${bindir} ${datadir}/pixmaps \
- ${datadir}/applications/gpe-conf-* ${datadir}/gpe/pixmaps \
- ${datadir}/gpe-conf"
-FILES_gpe-conf-panel = "${datadir}/applications/gpe-conf.desktop"
-
-do_compile () {
- oe_runmake PREFIX=${prefix}
- oe_runmake all-desktop PREFIX=${prefix}
-}
-
-do_install () {
- oe_runmake MACHINE=${MACHINE} PREFIX=${prefix} DESTDIR=${D} install-program
-}
diff --git a/packages/gpe-conf/gpe-conf_0.2.1.bb b/packages/gpe-conf/gpe-conf_0.2.1.bb
deleted file mode 100644
index 9cb5b6b059..0000000000
--- a/packages/gpe-conf/gpe-conf_0.2.1.bb
+++ /dev/null
@@ -1,24 +0,0 @@
-LICENSE = "GPL"
-SECTION = "gpe"
-PRIORITY = "optional"
-
-DEPENDS = "gtk+ esound audiofile libgpewidget libxsettings libxsettings-client"
-RDEPENDS_${PN} = "xst xset ipaq-sleep ntpdate gpe-login gpe-icons timezones"
-RDEPENDS_gpe-conf-panel = "gpe-conf"
-
-MAINTAINER = "Florian Boor <florian.boor@kernelconcepts.de>"
-PR="r0"
-
-GPE_TARBALL_SUFFIX = "bz2"
-
-inherit gpe autotools pkgconfig
-
-PACKAGES += "gpe-conf-panel"
-
-FILES_${PN} = "${sysconfdir} ${bindir} ${datadir}/pixmaps \
- ${datadir}/applications/gpe-conf-* ${datadir}/gpe/pixmaps \
- ${datadir}/gpe-conf"
-
-FILES_gpe-conf-panel = "${datadir}/applications/gpe-conf.desktop"
-
-
diff --git a/packages/gpe-conf/gpe-conf_0.2.2.bb b/packages/gpe-conf/gpe-conf_0.2.2.bb
index 9cb5b6b059..995a42f621 100644
--- a/packages/gpe-conf/gpe-conf_0.2.2.bb
+++ b/packages/gpe-conf/gpe-conf_0.2.2.bb
@@ -1,13 +1,14 @@
-LICENSE = "GPL"
-SECTION = "gpe"
+DESCRIPTION = "Configuration applets for GPE"
+SECTION = "gpe"
PRIORITY = "optional"
+MAINTAINER = "Florian Boor <florian.boor@kernelconcepts.de>"
+LICENSE = "GPL"
DEPENDS = "gtk+ esound audiofile libgpewidget libxsettings libxsettings-client"
RDEPENDS_${PN} = "xst xset ipaq-sleep ntpdate gpe-login gpe-icons timezones"
RDEPENDS_gpe-conf-panel = "gpe-conf"
-MAINTAINER = "Florian Boor <florian.boor@kernelconcepts.de>"
-PR="r0"
+PR = "r0"
GPE_TARBALL_SUFFIX = "bz2"
@@ -18,7 +19,6 @@ PACKAGES += "gpe-conf-panel"
FILES_${PN} = "${sysconfdir} ${bindir} ${datadir}/pixmaps \
${datadir}/applications/gpe-conf-* ${datadir}/gpe/pixmaps \
${datadir}/gpe-conf"
-
FILES_gpe-conf-panel = "${datadir}/applications/gpe-conf.desktop"
diff --git a/packages/gpe-conf/gpe-conf_cvs.bb b/packages/gpe-conf/gpe-conf_cvs.bb
index a0bec2b70f..e8da8a2646 100644
--- a/packages/gpe-conf/gpe-conf_cvs.bb
+++ b/packages/gpe-conf/gpe-conf_cvs.bb
@@ -1,25 +1,27 @@
DEFAULT_PREFERENCE = "-1"
-S = "${WORKDIR}/${PN}"
-PV = "0.1.29+cvs${SRCDATE}"
-PR = "r2"
-
-inherit autotools gpe
-
-SRC_URI = "${HANDHELDS_CVS};module=gpe/base/${PN}"
-
-PACKAGES = "gpe-conf gpe-conf-panel"
-LICENSE = "GPL"
+DESCRIPTION = "Configuration applets for GPE"
SECTION = "gpe"
PRIORITY = "optional"
MAINTAINER = "Florian Boor <florian.boor@kernelconcepts.de>"
-
+LICENSE = "GPL"
DEPENDS = "gtk+ libgpewidget libxsettings libxsettings-client pcmcia-cs xst xset ipaq-sleep ntp gpe-login gpe-icons"
RDEPENDS_${PN} = "xst xset ipaq-sleep ntpdate gpe-login gpe-icons"
RDEPENDS_gpe-conf-panel = "gpe-conf"
+
+PV = "0.2.2+cvs${SRCDATE}"
+PR = "r0"
+
+SRC_URI = "${HANDHELDS_CVS};module=gpe/base/${PN}"
+S = "${WORKDIR}/${PN}"
+
+inherit autotools gpe
+
+PACKAGES = "gpe-conf gpe-conf-panel"
+
FILES_${PN} = "${sysconfdir} ${bindir} ${datadir}/pixmaps \
- ${datadir}/applications/gpe-conf-* ${datadir}/gpe/pixmaps \
- ${datadir}/gpe-conf"
+ ${datadir}/applications/gpe-conf-* ${datadir}/gpe/pixmaps \
+ ${datadir}/gpe-conf"
FILES_gpe-conf-panel = "${datadir}/applications/gpe-conf.desktop"