aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gpe-ownerinfo
diff options
context:
space:
mode:
authorFlorian Boor <florian.boor@kernelconcepts.de>2007-03-08 22:11:42 +0000
committerFlorian Boor <florian.boor@kernelconcepts.de>2007-03-08 22:11:42 +0000
commit46a50544839a1c4243e258b499992da286b976bd (patch)
treec343e76c06f6d7d221399d1f688ab91c7852de9b /packages/gpe-ownerinfo
parent7db8984b275181a30ec7fcc47e2b78dbfe1ca698 (diff)
downloadopenembedded-46a50544839a1c4243e258b499992da286b976bd.tar.gz
gpe-ownerinfo: Add patch to fix compile issue contributed by Cyril Romain
Diffstat (limited to 'packages/gpe-ownerinfo')
-rw-r--r--packages/gpe-ownerinfo/gpe-ownerinfo/compile.patch13
-rw-r--r--packages/gpe-ownerinfo/gpe-ownerinfo_0.28.bb4
2 files changed, 16 insertions, 1 deletions
diff --git a/packages/gpe-ownerinfo/gpe-ownerinfo/compile.patch b/packages/gpe-ownerinfo/gpe-ownerinfo/compile.patch
new file mode 100644
index 0000000000..3406481d66
--- /dev/null
+++ b/packages/gpe-ownerinfo/gpe-ownerinfo/compile.patch
@@ -0,0 +1,13 @@
+Index: gpe-ownerinfo-0.28/Makefile
+===================================================================
+--- gpe-ownerinfo-0.28.orig/Makefile
++++ gpe-ownerinfo-0.28/Makefile
+@@ -40,7 +40,7 @@ all: $(PACKAGE) all-mo
+
+ $(LIB_TARGET): $(LIB_OBJS)
+ rm -f $@
+- ar cq $@ $^
++ $(AR) cq $@ $^
+
+ $(PACKAGE): $(OBJS) $(LIB_TARGET)
+ $(CC) -o $@ $^ $(LDFLAGS) $(PACKAGE_LDFLAGS) -L. -lgpe-ownerinfo
diff --git a/packages/gpe-ownerinfo/gpe-ownerinfo_0.28.bb b/packages/gpe-ownerinfo/gpe-ownerinfo_0.28.bb
index f04b9c19be..e17c6a6798 100644
--- a/packages/gpe-ownerinfo/gpe-ownerinfo_0.28.bb
+++ b/packages/gpe-ownerinfo/gpe-ownerinfo_0.28.bb
@@ -5,7 +5,9 @@ SECTION = "gpe"
PRIORITY = "optional"
DEPENDS = "gtk+ libgpewidget"
LICENSE = "GPL"
-PR = "r0"
+PR = "r1"
+
+SRC_URI += "file://compile.patch;patch=1"
do_stage () {
oe_libinstall -a libgpe-ownerinfo ${STAGING_LIBDIR}