aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gpe-session-scripts
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-09-02 20:58:40 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-09-02 20:58:40 +0000
commit7029d7e6852d5528d7b90b538ec6709d6ba968c6 (patch)
tree3d1821f28d968204a6e4d2c95b110f8750f7a4ec /packages/gpe-session-scripts
parent85804786bcde3d7cd77db5d4c1918659a2a7d636 (diff)
downloadopenembedded-7029d7e6852d5528d7b90b538ec6709d6ba968c6.tar.gz
Add gpe-sessionscripts 0.66
Diffstat (limited to 'packages/gpe-session-scripts')
-rw-r--r--packages/gpe-session-scripts/gpe-session-scripts_0.66.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/packages/gpe-session-scripts/gpe-session-scripts_0.66.bb b/packages/gpe-session-scripts/gpe-session-scripts_0.66.bb
new file mode 100644
index 0000000000..d7a3054149
--- /dev/null
+++ b/packages/gpe-session-scripts/gpe-session-scripts_0.66.bb
@@ -0,0 +1,30 @@
+LICENSE = "GPL"
+PR = "r0"
+
+inherit gpe
+
+DESCRIPTION = "GPE session startup scripts"
+SECTION = "gpe"
+PRIORITY = "optional"
+MAINTAINER = "Philip Blundell <pb@handhelds.org>"
+RDEPENDS_${PN} = "matchbox gpe-session-starter gpe-bluetooth xstroke xtscal gpe-question gpe-clock matchbox-applet-inputmanager xrandr xmodmap xdpyinfo xserver-common"
+# more rdepends: keylaunch ipaq-sleep apmd blueprobe
+DEPENDS = "matchbox-wm matchbox-panel gpe-bluetooth xstroke xtscal gpe-question matchbox-applet-inputmanager gpe-clock xrandr xmodmap xdpyinfo xserver-common"
+
+SRC_URI += "file://matchbox-session \
+ file://disable-composite.xsettings"
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/gpe/xsettings-default.d
+ if [ "${GUI_MACHINE_CLASS}" != "bigscreen" ]; then
+ echo "Gtk/ToolbarStyle:S:icons" > ${D}${sysconfdir}/gpe/xsettings-default.d/toolbar
+ fi
+ install -d ${D}${sysconfdir}/matchbox
+ install ${WORKDIR}/matchbox-session ${D}${sysconfdir}/matchbox/session
+
+ install -d ${D}${sysconfdir}/gpe/xsettings-default.d
+ install -m 0644 ${WORKDIR}/disable-composite.xsettings ${D}${sysconfdir}/gpe/xsettings-default.d/disable-composite
+}
+
+# This makes use of GUI_MACHINE_CLASS, so set PACKAGE_ARCH appropriately
+PACKAGE_ARCH = "${MACHINE_ARCH}"