aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gpe-session-scripts
diff options
context:
space:
mode:
authorMatthias Hentges <oe@hentges.net>2006-07-05 09:04:46 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-07-05 09:04:46 +0000
commitf9b065b24861e44a30b815186f4d1ebe5193a073 (patch)
tree422517b570df60ab1fc0893a402283f5030ca4f3 /packages/gpe-session-scripts
parent22e54f274d63175ecf42217b9601f20e6d2292a1 (diff)
downloadopenembedded-f9b065b24861e44a30b815186f4d1ebe5193a073.tar.gz
gpe-session-scripts: Use update-alternatives for gpe-logout to allow for different windowmanagers
Diffstat (limited to 'packages/gpe-session-scripts')
-rw-r--r--packages/gpe-session-scripts/gpe-session-scripts_0.67.bb12
1 files changed, 12 insertions, 0 deletions
diff --git a/packages/gpe-session-scripts/gpe-session-scripts_0.67.bb b/packages/gpe-session-scripts/gpe-session-scripts_0.67.bb
index 6a373cbd4b..8879833c6e 100644
--- a/packages/gpe-session-scripts/gpe-session-scripts_0.67.bb
+++ b/packages/gpe-session-scripts/gpe-session-scripts_0.67.bb
@@ -12,6 +12,8 @@ DEPENDS = "matchbox-wm matchbox-panel gpe-bluetooth xstroke xtscal gpe-question
SRC_URI += "file://matchbox-session \
file://disable-composite.xsettings"
+PR = "r1"
+
#apply a patch to set the fontsize for bigdpi (200+) devices to 5
SRC_URI_append_ipaq-pxa270 = " file://highdpifontfix.patch;patch=1"
SRC_URI_append_spitz = " file://highdpifontfix.patch;patch=1"
@@ -29,6 +31,16 @@ do_install_append() {
install -d ${D}${sysconfdir}/gpe/xsettings-default.d
install -m 0644 ${WORKDIR}/disable-composite.xsettings ${D}${sysconfdir}/gpe/xsettings-default.d/disable-composite
+
+ mv ${D}/usr/bin/gpe-logout ${D}/usr/bin/gpe-logout.matchbox
+}
+
+pkg_postinst_${PN}() {
+ update-alternatives --install /usr/bin/gpe-logout gpe-logout /usr/bin/gpe-logout.matchbox 10
+}
+
+pkg_postrm_${PN}() {
+ update-alternatives --remove gpe-logout /usr/bin/gpe-logout.matchbox
}
# This makes use of GUI_MACHINE_CLASS, so set PACKAGE_ARCH appropriately