aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gpe-what
diff options
context:
space:
mode:
authorFlorian Boor <florian.boor@kernelconcepts.de>2006-12-05 15:47:48 +0000
committerFlorian Boor <florian.boor@kernelconcepts.de>2006-12-05 15:47:48 +0000
commit2aedfc4e34a370cbdec09d7a258d60cc4ad63ac3 (patch)
tree532bd8e1f05ee859df982f1c7ed6f7fcb236e443 /packages/gpe-what
parent15d5d2edff06b9ae8ad6e95495b13123de0c80c2 (diff)
downloadopenembedded-2aedfc4e34a370cbdec09d7a258d60cc4ad63ac3.tar.gz
gpe-what: Add patch to set window type hint. Necessary for compatibility with matchbox > 0.9.5.
Diffstat (limited to 'packages/gpe-what')
-rw-r--r--packages/gpe-what/gpe-what-0.43/.mtn2git_empty0
-rw-r--r--packages/gpe-what/gpe-what-0.43/set-wm-hint.patch12
-rw-r--r--packages/gpe-what/gpe-what_0.43.bb3
3 files changed, 14 insertions, 1 deletions
diff --git a/packages/gpe-what/gpe-what-0.43/.mtn2git_empty b/packages/gpe-what/gpe-what-0.43/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/gpe-what/gpe-what-0.43/.mtn2git_empty
diff --git a/packages/gpe-what/gpe-what-0.43/set-wm-hint.patch b/packages/gpe-what/gpe-what-0.43/set-wm-hint.patch
new file mode 100644
index 0000000000..1300635197
--- /dev/null
+++ b/packages/gpe-what/gpe-what-0.43/set-wm-hint.patch
@@ -0,0 +1,12 @@
+Index: gpe-what.c
+===================================================================
+--- gpe-what.c (Revision 8874)
++++ gpe-what.c (Arbeitskopie)
+@@ -233,6 +233,7 @@
+
+ gtk_window_set_default_size (GTK_WINDOW (popup), width, height);
+ gtk_window_set_decorated (GTK_WINDOW (popup), FALSE);
++ gtk_window_set_type_hint (GTK_WINDOW (popup), GDK_WINDOW_TYPE_HINT_MENU);
+ gtk_label_set_line_wrap (GTK_LABEL (label), TRUE);
+ gtk_container_set_border_width (GTK_CONTAINER (box), spacing);
+
diff --git a/packages/gpe-what/gpe-what_0.43.bb b/packages/gpe-what/gpe-what_0.43.bb
index 2cc0dc9c2f..b82da4ff7f 100644
--- a/packages/gpe-what/gpe-what_0.43.bb
+++ b/packages/gpe-what/gpe-what_0.43.bb
@@ -1,8 +1,9 @@
LICENSE = "GPL"
DESCRIPTION = "GPE modal help"
DEPENDS = "virtual/libx11 gtk+"
-
+PR = "r1"
GPE_TARBALL_SUFFIX= "bz2"
inherit autotools gpe
+SRC_URI += " file://set-wm-hint.patch;patch=1;pnum=0"