aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gpm
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2007-01-10 13:02:48 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2007-01-10 13:02:48 +0000
commite4d953b836d587233d546c5156a258d8c86682cc (patch)
tree0912f63057f43409e8fa68645ee0f94643d380c0 /packages/gpm
parent25591e058ffbedf613b51c8c95efeac29d5ce99e (diff)
downloadopenembedded-e4d953b836d587233d546c5156a258d8c86682cc.tar.gz
gpm: provide libgpm.so.1 link, use update-rc.d class - close #543
Diffstat (limited to 'packages/gpm')
-rw-r--r--packages/gpm/gpm_1.20.1.bb31
1 files changed, 11 insertions, 20 deletions
diff --git a/packages/gpm/gpm_1.20.1.bb b/packages/gpm/gpm_1.20.1.bb
index 5623ebbf16..c017cafc9a 100644
--- a/packages/gpm/gpm_1.20.1.bb
+++ b/packages/gpm/gpm_1.20.1.bb
@@ -1,21 +1,25 @@
-SECTION = "console/utils"
-LICENSE = "GPL"
-DEPENDS = "ncurses"
DESCRIPTION = "GPM (General Purpose Mouse) is a mouse server \
for the console and xterm, with sample clients included \
(emacs, etc)."
+SECTION = "console/utils"
+LICENSE = "GPL"
+DEPENDS = "ncurses"
-PR="r1"
-PARALLEL_MAKE=""
+PR = "r2"
+PARALLEL_MAKE = ""
SRC_URI = "ftp://arcana.linux.it/pub/gpm/gpm-${PV}.tar.bz2 \
file://configure.patch;patch=1 \
file://no-docs.patch;patch=1 \
file://init"
-inherit autotools
+inherit autotools update-rc.d
+
+INITSCRIPT_NAME = "gpm"
+INITSCRIPT_PARAMS = "defaults"
export LIBS = "-lm"
+
do_configure_prepend () {
cp aclocal.m4 acinclude.m4
}
@@ -29,18 +33,5 @@ do_install () {
oe_runmake 'ROOT=${D}' install
install -d ${D}/${sysconfdir}/init.d
install -m 0755 ${WORKDIR}/init ${D}/${sysconfdir}/init.d/gpm
-}
-
-pkg_postinst () {
- if test -n "${D}"; then
- D="-r $D"
- fi
- update-rc.d $D gpm defaults
-}
-
-pkg_prerm () {
- if test -n "${D}"; then
- D="-r $D"
- fi
- update-rc.d $D gpm remove
+ cd ${D}${libdir} && ln -sf libgpm.so.1.19.0 libgpm.so.1
}