aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gpsd
diff options
context:
space:
mode:
authorJustin Patrin <papercrane@gmail.com>2007-04-02 23:15:05 +0000
committerJustin Patrin <papercrane@gmail.com>2007-04-02 23:15:05 +0000
commitb88d329c6442e6a68edae9f3c094ae9ca5b51c52 (patch)
treeea09d3606953cb437cec1782291f7b7d8f483b53 /packages/gpsd
parent583e67fbf167c75d9ebefb4c40a8f8298f3508e4 (diff)
downloadopenembedded-b88d329c6442e6a68edae9f3c094ae9ca5b51c52.tar.gz
gpsd: export BUILD_SYS and HOST_SYS as setup.py expects them to be set, add python to DEPENDS
Diffstat (limited to 'packages/gpsd')
-rw-r--r--packages/gpsd/gpsd.inc7
1 files changed, 6 insertions, 1 deletions
diff --git a/packages/gpsd/gpsd.inc b/packages/gpsd/gpsd.inc
index b4601fedd5..f7c1de2362 100644
--- a/packages/gpsd/gpsd.inc
+++ b/packages/gpsd/gpsd.inc
@@ -2,7 +2,7 @@ DESCRIPTION = "A TCP/IP Daemon simplifying the communication with GPS devices"
SECTION = "console/network"
PRIORITY = "optional"
LICENSE = "GPL"
-DEPENDS = "dbus-glib ncurses"
+DEPENDS = "dbus-glib ncurses python"
EXTRA_OECONF = "--x-includes=${STAGING_INCDIR}/X11 \
--x-libraries=${STAGING_LIBDIR} \
@@ -24,6 +24,11 @@ do_compile_prepend() {
export HOST_SYS="${HOST_SYS}"
}
+do_install_prepend() {
+ export BUILD_SYS="${BUILD_SYS}"
+ export HOST_SYS="${HOST_SYS}"
+}
+
do_stage() {
oe_libinstall -so -C ${S}/.libs libgps ${STAGING_LIBDIR}
install -m 0655 ${S}/libgps.la ${STAGING_LIBDIR}