aboutsummaryrefslogtreecommitdiffstats
path: root/packages/grub
diff options
context:
space:
mode:
authorMarco Cavallini <m.cavallini@koansoftware.com>2009-01-30 14:35:27 +0100
committerMarcin Juszkiewicz <hrw@openembedded.org>2009-02-02 12:34:55 +0100
commitc46eb730d7c8b0000d8756e1f8f79fa56ba32907 (patch)
tree40b8e37d6ea247235d04e0f24b43cc857fd79f4a /packages/grub
parent2e7e36a45d2ed5e86fc864ee2e73abee7a639ca8 (diff)
downloadopenembedded-c46eb730d7c8b0000d8756e1f8f79fa56ba32907.tar.gz
packages/grub/grub_0.97.bb * Correct GRUB installation in destination directory * added packages/grub/grub-0.97/menu.lst file
Diffstat (limited to 'packages/grub')
-rw-r--r--packages/grub/grub-0.97/menu.lst6
-rw-r--r--packages/grub/grub_0.97.bb16
2 files changed, 16 insertions, 6 deletions
diff --git a/packages/grub/grub-0.97/menu.lst b/packages/grub/grub-0.97/menu.lst
new file mode 100644
index 0000000000..510e8f82b6
--- /dev/null
+++ b/packages/grub/grub-0.97/menu.lst
@@ -0,0 +1,6 @@
+# menu.lst
+default 0
+timeout 5
+title OpenEmbedded Linux (hda1)
+root (hd0,0)
+kernel /boot/bzImage root=/dev/hda1 ro
diff --git a/packages/grub/grub_0.97.bb b/packages/grub/grub_0.97.bb
index 67fca242d4..ef37af19e0 100644
--- a/packages/grub/grub_0.97.bb
+++ b/packages/grub/grub_0.97.bb
@@ -1,12 +1,13 @@
-DESCRIPTION = "GRUB is the GRand Unified Bootloader"
+DESCRIPTION = "GRand Unified Bootloader"
HOMEPAGE = "http://www.gnu.org/software/grub"
SECTION = "bootloaders"
PRIORITY = "optional"
RDEPENDS = "diffutils"
-PR = "r3"
+PR = "r4"
SRC_URI = "ftp://alpha.gnu.org/gnu/grub/grub-${PV}.tar.gz \
- file://automake-1.10.patch;patch=1"
+ file://automake-1.10.patch;patch=1 \
+ file://menu.lst"
inherit autotools
@@ -17,9 +18,12 @@ python __anonymous () {
raise bb.parse.SkipPackage("incompatible with host %s" % host)
}
-do_install_append_vmware() {
- mkdir -p ${D}/boot/
- ln -sf ../usr/lib/grub/{$TARGET_ARCH}{$TARGET_VENDOR}/ ${D}/boot/grub
+do_install_append() {
+ install -d ${D}/boot/
+ ln -sf ../usr/lib/grub/i386${TARGET_VENDOR}/ ${D}/boot/grub
+
+ # TODO: better use grub-set-default script here?
+ install -m 0644 ${WORKDIR}/menu.lst ${D}/boot/grub
}
FILES_${PN}-doc = "${datadir}"