aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gsm
diff options
context:
space:
mode:
authorPhilipp Zabel <philipp.zabel@gmail.com>2007-04-17 10:20:44 +0000
committerPhilipp Zabel <philipp.zabel@gmail.com>2007-04-17 10:20:44 +0000
commit226d248d826b389cf4bb064e391158f21c56d022 (patch)
treef7ba4a4d906844ce3434e4c97fdbbef6fc75c2ff /packages/gsm
parent29d6dd95f7b21d1c4e87656a82b67b49d1ec9cd5 (diff)
downloadopenembedded-226d248d826b389cf4bb064e391158f21c56d022.tar.gz
libgsmd: numeric.patch was applied upstream
- patch to understand qualcomm '@' extended replies is still needed for universal
Diffstat (limited to 'packages/gsm')
-rw-r--r--packages/gsm/files/numeric.patch56
-rw-r--r--packages/gsm/files/qualcomm-extreply.patch13
-rw-r--r--packages/gsm/libgsmd_svn.bb7
3 files changed, 16 insertions, 60 deletions
diff --git a/packages/gsm/files/numeric.patch b/packages/gsm/files/numeric.patch
deleted file mode 100644
index cd1990cbe5..0000000000
--- a/packages/gsm/files/numeric.patch
+++ /dev/null
@@ -1,56 +0,0 @@
-Index: gsm/src/gsmd/atcmd.c
-===================================================================
---- gsm.orig/src/gsmd/atcmd.c 2007-04-02 09:59:16.000000000 +0200
-+++ gsm/src/gsmd/atcmd.c 2007-04-02 10:10:54.000000000 +0200
-@@ -207,7 +207,7 @@
- * TBD
- */
-
-- if (buf[0] == '+' || buf[0] == '%') {
-+ if (buf[0] == '+' || buf[0] == '%' || buf[0] == '@') {
- /* an extended response */
- const char *colon = strchr(buf, ':');
- if (!colon) {
-@@ -269,14 +269,13 @@
- memcpy(cmd->buf, buf, len);
- }
- } else {
-- if (!strcmp(buf, "RING")) {
-+ if (!strcmp(buf, "RING") || buf[0] == '2') {
- /* this is the only non-extended unsolicited return
- * code, part of Case 'B' */
- return unsolicited_parse(g, buf, len, NULL);
- }
-
-- if (!strcmp(buf, "ERROR") ||
-- ((g->flags & GSMD_FLAG_V0) && buf[0] == '4')) {
-+ if (!strcmp(buf, "ERROR") || buf[0] == '4') {
- /* Part of Case 'C' */
- DEBUGP("unspecified error\n");
- if (cmd)
-@@ -285,8 +284,7 @@
- goto final_cb;
- }
-
-- if (!strncmp(buf, "OK", 2)
-- || ((g->flags & GSMD_FLAG_V0) && buf[0] == '0')) {
-+ if (!strncmp(buf, "OK", 2) || buf[0] == '0') {
- /* Part of Case 'C' */
- if (cmd)
- cmd->ret = 0;
-@@ -296,13 +294,13 @@
-
- /* FIXME: handling of those special commands in response to
- * ATD / ATA */
-- if (!strncmp(buf, "NO CARRIER", 11)) {
-+ if (!strncmp(buf, "NO CARRIER", 11) || buf[0] == '3') {
- /* Part of Case 'D' */
- final = 1;
- goto final_cb;
- }
-
-- if (!strncmp(buf, "BUSY", 4)) {
-+ if (!strncmp(buf, "BUSY", 4) || buf[0] == '7') {
- /* Part of Case 'D' */
- final = 1;
- goto final_cb;
diff --git a/packages/gsm/files/qualcomm-extreply.patch b/packages/gsm/files/qualcomm-extreply.patch
new file mode 100644
index 0000000000..010a8c9f31
--- /dev/null
+++ b/packages/gsm/files/qualcomm-extreply.patch
@@ -0,0 +1,13 @@
+Index: gsm/src/gsmd/atcmd.c
+===================================================================
+--- gsm.orig/src/gsmd/atcmd.c 2007-04-02 09:59:16.000000000 +0200
++++ gsm/src/gsmd/atcmd.c 2007-04-02 10:10:54.000000000 +0200
+@@ -207,7 +207,7 @@
+ * TBD
+ */
+
+- if (buf[0] == '+' || buf[0] == '%') {
++ if (buf[0] == '+' || buf[0] == '%' || buf[0] == '@') {
+ /* an extended response */
+ const char *colon = strchr(buf, ':');
+ if (!colon) {
diff --git a/packages/gsm/libgsmd_svn.bb b/packages/gsm/libgsmd_svn.bb
index ad207083ac..0215bb92b9 100644
--- a/packages/gsm/libgsmd_svn.bb
+++ b/packages/gsm/libgsmd_svn.bb
@@ -11,10 +11,9 @@ SRC_URI = "svn://svn.openmoko.org/trunk/src/target;module=gsm;proto=http \
file://default"
S = "${WORKDIR}/gsm"
-SRC_URI_append_magician = " file://numeric.patch;patch=1 \
- file://plugin.patch;patch=1"
-SRC_URI_append_htcuniversal = " file://numeric.patch;patch=1 \
- file://plugin.patch;patch=1"
+SRC_URI_append_magician = " file://plugin.patch;patch=1"
+SRC_URI_append_htcuniversal = " file://plugin.patch;patch=1 \
+ file://qualcomm-extreply.patch;patch=1"
inherit autotools pkgconfig update-rc.d