aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gstreamer
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2008-02-13 11:40:41 +0000
committerMichael Lauer <mickey@vanille-media.de>2008-02-13 11:40:41 +0000
commitbe3c2cc81c9a84026a62cc3566848f1871bf22f6 (patch)
tree97952635d834adc563d5fc0cecf6a7f7bdf33d1b /packages/gstreamer
parentebd8ca1a732bb964f503b170acb87c0a043651c3 (diff)
downloadopenembedded-be3c2cc81c9a84026a62cc3566848f1871bf22f6.tar.gz
gst-plugin-pulse 0.9.7 add patch reducing 20% of the load due to some busylooping
NOTE: need to play more with that to find out whether we can get even more
Diffstat (limited to 'packages/gstreamer')
-rw-r--r--packages/gstreamer/gst-plugin-pulse/.mtn2git_empty0
-rw-r--r--packages/gstreamer/gst-plugin-pulse/dont-overload-pulseaudio.patch13
-rw-r--r--packages/gstreamer/gst-plugin-pulse_0.9.7.bb5
3 files changed, 16 insertions, 2 deletions
diff --git a/packages/gstreamer/gst-plugin-pulse/.mtn2git_empty b/packages/gstreamer/gst-plugin-pulse/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/gstreamer/gst-plugin-pulse/.mtn2git_empty
diff --git a/packages/gstreamer/gst-plugin-pulse/dont-overload-pulseaudio.patch b/packages/gstreamer/gst-plugin-pulse/dont-overload-pulseaudio.patch
new file mode 100644
index 0000000000..377a4f9589
--- /dev/null
+++ b/packages/gstreamer/gst-plugin-pulse/dont-overload-pulseaudio.patch
@@ -0,0 +1,13 @@
+Index: gst-pulse-0.9.7/src/pulsesink.c
+===================================================================
+--- gst-pulse-0.9.7.orig/src/pulsesink.c
++++ gst-pulse-0.9.7/src/pulsesink.c
+@@ -477,6 +477,8 @@ static guint gst_pulsesink_write(GstAudi
+ length -= l;
+
+ sum += l;
++
++ usleep( 500 );
+ }
+
+ pa_threaded_mainloop_unlock(pulsesink->mainloop);
diff --git a/packages/gstreamer/gst-plugin-pulse_0.9.7.bb b/packages/gstreamer/gst-plugin-pulse_0.9.7.bb
index a1e321c73e..5a83f3915b 100644
--- a/packages/gstreamer/gst-plugin-pulse_0.9.7.bb
+++ b/packages/gstreamer/gst-plugin-pulse_0.9.7.bb
@@ -2,11 +2,12 @@ DESCRIPTION = "GStreamer plugin for using pulse audio as sink and source"
HOMEPAGE = "http://0pointer.de/lennart/projects/gst-pulse/"
LICENSE = "GPL"
DEPENDS = "gstreamer pulseaudio"
-PR = "r0"
+PR = "r1"
DEFAULT_PREFERENCE = "-1"
-SRC_URI = "http://0pointer.de/lennart/projects/gst-pulse/gst-pulse-${PV}.tar.gz"
+SRC_URI = "http://0pointer.de/lennart/projects/gst-pulse/gst-pulse-${PV}.tar.gz \
+ file://dont-overload-pulseaudio.patch;patch=1"
S = "${WORKDIR}/gst-pulse-${PV}"
inherit autotools