aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gstreamer
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2008-02-05 15:05:05 +0000
committerMichael Lauer <mickey@vanille-media.de>2008-02-05 15:05:05 +0000
commit55fe052dcad7c194336adf5110aace80213f752e (patch)
tree40acc10648bdbe360fa0d8901da48f21903780c0 /packages/gstreamer
parent4f349bdd5dd605248c9825c396c168f2bf5c38b6 (diff)
downloadopenembedded-55fe052dcad7c194336adf5110aace80213f752e.tar.gz
add gst-plugin-pulse 0.9.7 (to go w/ PA 0.9.8 and later), DP = -1
Diffstat (limited to 'packages/gstreamer')
-rw-r--r--packages/gstreamer/gst-plugin-pulse_0.9.7.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/packages/gstreamer/gst-plugin-pulse_0.9.7.bb b/packages/gstreamer/gst-plugin-pulse_0.9.7.bb
new file mode 100644
index 0000000000..a1e321c73e
--- /dev/null
+++ b/packages/gstreamer/gst-plugin-pulse_0.9.7.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "GStreamer plugin for using pulse audio as sink and source"
+HOMEPAGE = "http://0pointer.de/lennart/projects/gst-pulse/"
+LICENSE = "GPL"
+DEPENDS = "gstreamer pulseaudio"
+PR = "r0"
+
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI = "http://0pointer.de/lennart/projects/gst-pulse/gst-pulse-${PV}.tar.gz"
+S = "${WORKDIR}/gst-pulse-${PV}"
+
+inherit autotools
+
+EXTRA_OECONF = "--disable-lynx"
+GST_LIBV = 0.10
+
+do_install() {
+ install -d ${D}${libdir}/gstreamer-${GST_LIBV}/
+ install -m 0755 src/.libs/libgstpulse.so ${D}${libdir}/gstreamer-${GST_LIBV}
+}
+
+export GST_MODDIR=${libdir}/gstreamer-0.10
+
+FILES_${PN} = "${libdir}/gstreamer-0.10/libgstpulse.so"
+FILES_${PN}-dev = "\
+ ${libdir}/gstreamer-0.10/libgstpulse.a \
+ ${libdir}/gstreamer-0.10/libgstpulse.la \
+ ${libdir}/gstreamer-0.10/libgstpulse.so*"
+FILES_${PN}-dbg += "${libdir}/gstreamer-0.10/.debug"
+