aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gstreamer
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2008-07-03 17:56:19 +0000
committerKoen Kooi <koen@openembedded.org>2008-07-03 17:56:19 +0000
commit5b84c61ca405f8002bf053a60c22ff8cd66bfd1d (patch)
tree36f3fcb44045bfa1fb4e87821ac6f86f7652caec /packages/gstreamer
parente7b01db35cb3e2a99513e6ee0006f1c2321c19d7 (diff)
downloadopenembedded-5b84c61ca405f8002bf053a60c22ff8cd66bfd1d.tar.gz
gst-ffmpeg: add 0.10.4, disabled by default
Diffstat (limited to 'packages/gstreamer')
-rw-r--r--packages/gstreamer/gst-ffmpeg-0.10.4/.mtn2git_empty0
-rw-r--r--packages/gstreamer/gst-ffmpeg-0.10.4/configure-hack.diff10
-rw-r--r--packages/gstreamer/gst-ffmpeg_0.10.4.bb34
3 files changed, 44 insertions, 0 deletions
diff --git a/packages/gstreamer/gst-ffmpeg-0.10.4/.mtn2git_empty b/packages/gstreamer/gst-ffmpeg-0.10.4/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/gstreamer/gst-ffmpeg-0.10.4/.mtn2git_empty
diff --git a/packages/gstreamer/gst-ffmpeg-0.10.4/configure-hack.diff b/packages/gstreamer/gst-ffmpeg-0.10.4/configure-hack.diff
new file mode 100644
index 0000000000..0c3b5b162f
--- /dev/null
+++ b/packages/gstreamer/gst-ffmpeg-0.10.4/configure-hack.diff
@@ -0,0 +1,10 @@
+--- /tmp/configure.ac 2008-07-03 19:47:44.000000000 +0200
++++ gst-ffmpeg-0.10.4/configure.ac 2008-07-03 19:47:57.000000000 +0200
+@@ -294,7 +294,6 @@
+ AC_SUBST(FFMPEG_CO_DIR)
+ AC_SUBST(FFMPEG_SVN)
+ AC_SUBST(FFMPEG_REVISION)
+- AC_CONFIG_SUBDIRS(gst-libs/ext/ffmpeg)
+ AC_MSG_NOTICE([Using included FFMpeg code])
+ fi
+
diff --git a/packages/gstreamer/gst-ffmpeg_0.10.4.bb b/packages/gstreamer/gst-ffmpeg_0.10.4.bb
new file mode 100644
index 0000000000..fdc986a0a7
--- /dev/null
+++ b/packages/gstreamer/gst-ffmpeg_0.10.4.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "FFmpeg-based GStreamer plug-in"
+SECTION = "multimedia"
+PRIORITY = "optional"
+LICENSE = "LGPL"
+HOMEPAGE = "http://www.gstreamer.net/"
+DEPENDS = "ffmpeg gstreamer zlib"
+PR = "r0"
+
+# This uses the systems ffmpeg, which is unsupported, but we can't build the internal one with the current autotools (ab)usage
+DEFAULT_PREFERENCE = "-1"
+
+inherit autotools pkgconfig
+
+SRC_URI = "http://gstreamer.freedesktop.org/src/${PN}/${PN}-${PV}.tar.bz2 \
+ file://configure-hack.diff;patch =1 \
+"
+
+FILES_${PN} += "${libdir}/gstreamer-0.10/*.so"
+FILES_${PN}-dbg += "${libdir}/gstreamer-0.10/.debug"
+FILES_${PN}-dev += "${libdir}/gstreamer-0.10/*.la ${libdir}/gstreamer-0.10/*.a"
+
+EXTRA_OECONF = "--disable-sdltest --disable-ffplay --disable-freetypetest \
+ --disable-vorbis --disable-vorbistest --disable-encoders \
+ --disable-v4l --disable-audio-oss --disable-dv1394 \
+ --disable-vhook --with-system-ffmpeg --disable-ffserver \
+ --enable-pp --disable-decoder-vorbis"
+
+# We do this because the install program is called with -s which causes it to
+# call "strip" and it then mangles cross compiled stuff..
+PATH_prepend="${CROSS_DIR}/${TARGET_SYS}/bin:"
+
+# Hack to get STAGING_LIBDIR into the linker path when building ffmpeg
+CC = "${CCACHE} ${HOST_PREFIX}gcc ${TARGET_CC_ARCH} -L${STAGING_LIBDIR}"
+