aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gstreamer
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-01-15 16:26:26 +0100
committerKoen Kooi <koen@openembedded.org>2009-01-15 16:26:26 +0100
commited4b44c68fec892b261461444e9306dfb98447af (patch)
tree0b165b06362a1278e4986f5e470bb2683dc901cd /packages/gstreamer
parent1813b844deed16544f80399cd880ba5a91562c33 (diff)
downloadopenembedded-ed4b44c68fec892b261461444e9306dfb98447af.tar.gz
gst-plugins: hook into packaging code to generate ${PN}-meta for gst-plugins that RDEPENDS on all plugins
* if you want all plugins from gst-plugins-good: 'opkg install gst-plugins-good-meta'
Diffstat (limited to 'packages/gstreamer')
-rw-r--r--packages/gstreamer/gst-plugins-bad_0.10.6.bb1
-rw-r--r--packages/gstreamer/gst-plugins-base_0.10.17.bb2
-rw-r--r--packages/gstreamer/gst-plugins-good_0.10.7.bb2
-rw-r--r--packages/gstreamer/gst-plugins-ugly-sid_0.10.7.bb2
-rw-r--r--packages/gstreamer/gst-plugins-ugly_0.10.7.bb2
-rw-r--r--packages/gstreamer/gst-plugins.inc17
6 files changed, 22 insertions, 4 deletions
diff --git a/packages/gstreamer/gst-plugins-bad_0.10.6.bb b/packages/gstreamer/gst-plugins-bad_0.10.6.bb
index 5d06a3c079..a8d87833ac 100644
--- a/packages/gstreamer/gst-plugins-bad_0.10.6.bb
+++ b/packages/gstreamer/gst-plugins-bad_0.10.6.bb
@@ -1,4 +1,5 @@
require gst-plugins.inc
+PR = "r1"
SRC_URI += "file://vorbisenc.h file://vorbisdec.h \
file://gst-plugins-directfb-fix.patch;patch=1;pnum=2 \
diff --git a/packages/gstreamer/gst-plugins-base_0.10.17.bb b/packages/gstreamer/gst-plugins-base_0.10.17.bb
index d2fd547a26..0a1f17fcd8 100644
--- a/packages/gstreamer/gst-plugins-base_0.10.17.bb
+++ b/packages/gstreamer/gst-plugins-base_0.10.17.bb
@@ -8,5 +8,5 @@ PROVIDES += "gst-plugins"
# a missing alsa plugin
DEPENDS += "alsa-lib libsm virtual/libx11 freetype gnome-vfs libxv"
-PR = "r4"
+PR = "r5"
diff --git a/packages/gstreamer/gst-plugins-good_0.10.7.bb b/packages/gstreamer/gst-plugins-good_0.10.7.bb
index ac3a5e73c5..06cec41456 100644
--- a/packages/gstreamer/gst-plugins-good_0.10.7.bb
+++ b/packages/gstreamer/gst-plugins-good_0.10.7.bb
@@ -1,5 +1,5 @@
require gst-plugins.inc
-PR = "r2"
+PR = "r3"
inherit gconf
diff --git a/packages/gstreamer/gst-plugins-ugly-sid_0.10.7.bb b/packages/gstreamer/gst-plugins-ugly-sid_0.10.7.bb
index bf059fbb8b..77c4184c29 100644
--- a/packages/gstreamer/gst-plugins-ugly-sid_0.10.7.bb
+++ b/packages/gstreamer/gst-plugins-ugly-sid_0.10.7.bb
@@ -1,7 +1,7 @@
require gst-plugins.inc
DEPENDS += "gst-plugins-base libsidplay"
PROVIDES += "gst-plugin-sid"
-PR = "r4"
+PR = "r5"
SRC_URI = "\
http://gstreamer.freedesktop.org/src/gst-plugins-ugly/gst-plugins-ugly-${PV}.tar.bz2 \
diff --git a/packages/gstreamer/gst-plugins-ugly_0.10.7.bb b/packages/gstreamer/gst-plugins-ugly_0.10.7.bb
index 054f0df5aa..380a520234 100644
--- a/packages/gstreamer/gst-plugins-ugly_0.10.7.bb
+++ b/packages/gstreamer/gst-plugins-ugly_0.10.7.bb
@@ -1,5 +1,5 @@
require gst-plugins.inc
-PR = "r1"
+PR = "r2"
DEPENDS += "gst-plugins-base mpeg2dec libsidplay"
diff --git a/packages/gstreamer/gst-plugins.inc b/packages/gstreamer/gst-plugins.inc
index 68a0502182..843ee69cd8 100644
--- a/packages/gstreamer/gst-plugins.inc
+++ b/packages/gstreamer/gst-plugins.inc
@@ -17,11 +17,28 @@ OE_LT_RPATH_ALLOW[export]="1"
LIBV = "0.10"
python populate_packages_prepend () {
+ import string
gst_libdir = bb.data.expand('${libdir}/gstreamer-${LIBV}', d)
postinst = bb.data.getVar('plugin_postinst', d, 1)
do_split_packages(d, gst_libdir, '^libgst(.*)\.so$', 'gst-plugin-%s', 'GStreamer plugin for %s', postinst=postinst, extra_depends='')
do_split_packages(d, gst_libdir, '^libgst(.*)\.l?a$', 'gst-plugin-%s-dev', 'GStreamer plugin for %s (development files)', extra_depends='')
+
+ pn = bb.data.getVar('PN', d, 1)
+ metapkg = pn + '-meta'
+ bb.data.setVar('ALLOW_EMPTY_' + metapkg, "1", d)
+ bb.data.setVar('FILES_' + metapkg, "", d)
+ blacklist = [ pn + '-locale', pn + '-dev', pn + '-dbg', pn + '-doc' ]
+ metapkg_rdepends = []
+ packages = bb.data.getVar('PACKAGES', d, 1).split()
+ for pkg in packages[1:]:
+ if not pkg in blacklist and not pkg in metapkg_rdepends and not string.count(pkg, 'dev') and not string.count(pkg,'locale'):
+ metapkg_rdepends.append(pkg)
+ bb.data.setVar('RDEPENDS_' + metapkg, ' '.join(metapkg_rdepends), d)
+ bb.data.setVar('DESCRIPTION_' + metapkg, pn + ' meta package', d)
+ packages.append(metapkg)
+ bb.data.setVar('PACKAGES', ' '.join(packages), d)
+
}
ALLOW_EMPTY = "1"