aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gtk+
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2007-05-23 08:09:06 +0000
committerKoen Kooi <koen@openembedded.org>2007-05-23 08:09:06 +0000
commita0972c9bb21ee1251be28f178ab1ef19004eaf12 (patch)
treeccc4916b9cfd6760f59e24055352f097925c43ff /packages/gtk+
parent9409e03b5941c35ce3dc7ab410fbfa06ef79c9ba (diff)
downloadopenembedded-a0972c9bb21ee1251be28f178ab1ef19004eaf12.tar.gz
composite-pixbug: add test app for pixbug performance
Diffstat (limited to 'packages/gtk+')
-rw-r--r--packages/gtk+/composite-pixbuf_0.0.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/packages/gtk+/composite-pixbuf_0.0.bb b/packages/gtk+/composite-pixbuf_0.0.bb
new file mode 100644
index 0000000000..729343fb44
--- /dev/null
+++ b/packages/gtk+/composite-pixbuf_0.0.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Pixbuf performance test"
+LICENSE = "Public domain"
+DEPENDS = "gtk+"
+
+SRC_URI = "http://amelang.net/composite_pixbuf.c"
+
+S = "${WORKDIR}"
+
+do_compile() {
+ ${CC} ${CFLAGS} composite_pixbuf.c -o composite_pixbuf \
+ `pkg-config --cflags gdk-2.0` `pkg-config --libs gdk-2.0` `pkg-config --libs x11` `pkg-config --libs pango` \
+ -lxcb -lXext -lXinerama -lXrandr -lXcursor -lXfixes -lpangoft2-1.0 -lz -lexpat -lxcb-xlib -lXau -lXdmcp
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 755 composite_pixbuf ${D}${bindir}
+}