aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gtk-engines/gtk-industrial-engine_0.2.36.5.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/gtk-engines/gtk-industrial-engine_0.2.36.5.bb
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
downloadopenembedded-c8e5702127e507e82e6f68a4b8c546803accea9d.tar.gz
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/gtk-engines/gtk-industrial-engine_0.2.36.5.bb')
-rw-r--r--packages/gtk-engines/gtk-industrial-engine_0.2.36.5.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/packages/gtk-engines/gtk-industrial-engine_0.2.36.5.bb b/packages/gtk-engines/gtk-industrial-engine_0.2.36.5.bb
index e69de29bb2..78700b91a2 100644
--- a/packages/gtk-engines/gtk-industrial-engine_0.2.36.5.bb
+++ b/packages/gtk-engines/gtk-industrial-engine_0.2.36.5.bb
@@ -0,0 +1,22 @@
+SECTION = "x11/base"
+DESCRIPTION = "Industrial theme engine for GTK"
+MAINTAINER = "Phil Blundell <pb@handhelds.org>"
+LICENSE = "GPL2"
+DEPENDS = "gtk+"
+
+SRC_URI = "${DEBIAN_MIRROR}/main/g/gtk-industrial-engine/gtk-industrial-engine_${PV}.tar.gz \
+ file://no-gtk1.patch;patch=1"
+
+PACKAGES += "gtk-theme-industrial"
+FILES_${PN} = "${libdir}/gtk-2.0/*/engines/*.so"
+FILES_${PN}-dev = "${libdir}/gtk-2.0/*/engines/*"
+FILES_gtk-theme-industrial = "${datadir}/icons ${datadir}/themes"
+
+inherit autotools
+
+do_configure_prepend() {
+ for i in `ls gtk-common`; do
+ ln -sf ../gtk-common/$i gtk2-engine/$i
+ done
+}
+