aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gtk-engines
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2005-07-27 18:47:06 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-07-27 18:47:06 +0000
commit8910aba99b20f9b6e9bf1f090dc0445d06a4fadb (patch)
tree684c2c3bd579fd3a3b78234e872671b059ca7543 /packages/gtk-engines
parent901ffa524e8e012d2352f4c62a1c8dbac418432a (diff)
downloadopenembedded-8910aba99b20f9b6e9bf1f090dc0445d06a4fadb.tar.gz
added gtk-industrial-engine 0.2.46.0
Diffstat (limited to 'packages/gtk-engines')
-rw-r--r--packages/gtk-engines/gtk-industrial-engine_0.2.46.0.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/packages/gtk-engines/gtk-industrial-engine_0.2.46.0.bb b/packages/gtk-engines/gtk-industrial-engine_0.2.46.0.bb
new file mode 100644
index 0000000000..78700b91a2
--- /dev/null
+++ b/packages/gtk-engines/gtk-industrial-engine_0.2.46.0.bb
@@ -0,0 +1,22 @@
+SECTION = "x11/base"
+DESCRIPTION = "Industrial theme engine for GTK"
+MAINTAINER = "Phil Blundell <pb@handhelds.org>"
+LICENSE = "GPL2"
+DEPENDS = "gtk+"
+
+SRC_URI = "${DEBIAN_MIRROR}/main/g/gtk-industrial-engine/gtk-industrial-engine_${PV}.tar.gz \
+ file://no-gtk1.patch;patch=1"
+
+PACKAGES += "gtk-theme-industrial"
+FILES_${PN} = "${libdir}/gtk-2.0/*/engines/*.so"
+FILES_${PN}-dev = "${libdir}/gtk-2.0/*/engines/*"
+FILES_gtk-theme-industrial = "${datadir}/icons ${datadir}/themes"
+
+inherit autotools
+
+do_configure_prepend() {
+ for i in `ls gtk-common`; do
+ ln -sf ../gtk-common/$i gtk2-engine/$i
+ done
+}
+