aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gtk-webcore
diff options
context:
space:
mode:
authorPhilippe De Swert <philippedeswert@scarlet.be>2006-05-27 14:08:02 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-05-27 14:08:02 +0000
commitb20068f0ebacd20966caf0cde0120ff9a1d9219a (patch)
treece20fe4394f13d576ffc3a3e510b2806268b865f /packages/gtk-webcore
parent0ac0f2907d567cb7513958de0285c4fc0818e855 (diff)
downloadopenembedded-b20068f0ebacd20966caf0cde0120ff9a1d9219a.tar.gz
osb-nrcit : adding patch that fixes error reporting
* packages/gtk-webcore/files/fix-loading-error-report.patch : patch that fixes the error reporting * packages/gtk-webcore/osb-nrcit_20050430.bb : added patch usage + bumped up PR
Diffstat (limited to 'packages/gtk-webcore')
-rw-r--r--packages/gtk-webcore/files/fix-loading-error-report.patch44
-rw-r--r--packages/gtk-webcore/osb-nrcit_20050430.bb6
2 files changed, 48 insertions, 2 deletions
diff --git a/packages/gtk-webcore/files/fix-loading-error-report.patch b/packages/gtk-webcore/files/fix-loading-error-report.patch
new file mode 100644
index 0000000000..09e6f4f03a
--- /dev/null
+++ b/packages/gtk-webcore/files/fix-loading-error-report.patch
@@ -0,0 +1,44 @@
+--- NRCit.orig/src/gtk/webi.cc.orig 2006-04-04 01:53:14.000000000 +0300
++++ NRCit/src/gtk/webi.cc 2006-04-04 01:44:20.000000000 +0300
+@@ -839,12 +839,15 @@
+ status->status = WEBI_LOADING_COMPLETE;
+ status->statusCode = statusCode;
+
++ g_signal_emit_by_name(webi, "status", status);
+ // assert(status->ready == status->files);
+ }
+
+ void MyRoot::internalStatusStartItem(const OSB::ResourceStatus * _status)
+ {
+ if (!internal) return;
++
++ status->status = WEBI_LOADING_START;
+ status->files++;
+ g_signal_emit_by_name(webi, "status", status);
+ }
+@@ -852,6 +855,8 @@
+ void MyRoot::internalStatusHeadersItem(const OSB::ResourceStatus * _status)
+ {
+ if (!internal) return;
++
++ status->status = WEBI_LOADING_START;
+ if (_status->size()) {
+ status->size += _status->size();
+ status->totalSize += _status->size();
+@@ -863,6 +868,8 @@
+ void MyRoot::internalStatusProgressItem(const OSB::ResourceStatus * _status)
+ {
+ if (!internal) return;
++
++ status->status = WEBI_LOADING_START;
+ status->totalReceived += _status->lastReceived();
+ // in case Content-Length -header is not present
+ if (!_status->size()) {
+@@ -880,6 +887,7 @@
+ status->ready++;
+ if (_status->error()) {
+ // FIXME: handle errors as well.u
++ status->status = WEBI_LOADING_ERROR;
+ }
+
+ g_signal_emit_by_name(webi, "status", status);
diff --git a/packages/gtk-webcore/osb-nrcit_20050430.bb b/packages/gtk-webcore/osb-nrcit_20050430.bb
index 4097464a53..da3b7a8fd9 100644
--- a/packages/gtk-webcore/osb-nrcit_20050430.bb
+++ b/packages/gtk-webcore/osb-nrcit_20050430.bb
@@ -7,13 +7,15 @@ SECTION = "gpe"
FIXEDSRCDATE = "${@bb.data.getVar('FILE', d, 1).split('_')[-1].split('.')[0]}"
PV = "0.5.0+cvs${FIXEDSRCDATE}"
-PR = "r2"
+PR = "r3"
DEPENDS = "curl librsvg osb-nrcore"
SRC_URI = "cvs://anonymous@gtk-webcore.cvs.sourceforge.net/cvsroot/gtk-webcore;module=NRCit;date=${FIXEDSRCDATE} \
file://stop-load.image-loading.patch;patch=1 \
- file://gdk-colorspace.diff;patch=1"
+ file://gdk-colorspace.diff;patch=1 \
+ file://fix-loading-error-report.patch;patch=1"
+
S = "${WORKDIR}/NRCit"
inherit autotools pkgconfig