aboutsummaryrefslogtreecommitdiffstats
path: root/packages/guile
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2006-07-02 13:50:18 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-07-02 13:50:18 +0000
commitc4ad3b40f4e5eb92adf68db603c9eebc50bc367b (patch)
tree707875839f256cfd322604cb9dc6850d8f748d92 /packages/guile
parent0f9202fb5e73731751b6aef3411f966c2756f1d0 (diff)
downloadopenembedded-c4ad3b40f4e5eb92adf68db603c9eebc50bc367b.tar.gz
guile 1.6.4 add patch for building with gcc4. reorder and enhance metadata
Diffstat (limited to 'packages/guile')
-rw-r--r--packages/guile/files/.mtn2git_empty0
-rw-r--r--packages/guile/files/configure-lossage.patch (renamed from packages/guile/configure-lossage.patch)0
-rw-r--r--packages/guile/files/gcc4.patch16
-rw-r--r--packages/guile/guile_1.6.4.bb14
4 files changed, 26 insertions, 4 deletions
diff --git a/packages/guile/files/.mtn2git_empty b/packages/guile/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/guile/files/.mtn2git_empty
diff --git a/packages/guile/configure-lossage.patch b/packages/guile/files/configure-lossage.patch
index da1d0de6e7..da1d0de6e7 100644
--- a/packages/guile/configure-lossage.patch
+++ b/packages/guile/files/configure-lossage.patch
diff --git a/packages/guile/files/gcc4.patch b/packages/guile/files/gcc4.patch
new file mode 100644
index 0000000000..2168683ad5
--- /dev/null
+++ b/packages/guile/files/gcc4.patch
@@ -0,0 +1,16 @@
+
+#
+# Signed off by Michael 'Mickey' Lauer <mickey@Vanille.de>
+#
+
+--- guile-1.6.4/libguile/guile.c~gcc4
++++ guile-1.6.4/libguile/guile.c
+@@ -88,7 +88,7 @@
+ {
+ #ifdef DYNAMIC_LINKING
+ /* libtool automagically inserts this variable into your executable... */
+- extern const scm_lt_dlsymlist lt_preloaded_symbols[];
++ extern const scm_lt_dlsymlist *lt_preloaded_symbols;
+ scm_lt_dlpreload_default (lt_preloaded_symbols);
+ #endif
+ scm_boot_guile (argc, argv, inner_main, 0);
diff --git a/packages/guile/guile_1.6.4.bb b/packages/guile/guile_1.6.4.bb
index dc55c266a0..389aec9489 100644
--- a/packages/guile/guile_1.6.4.bb
+++ b/packages/guile/guile_1.6.4.bb
@@ -1,9 +1,15 @@
-SECTION = "unknown"
-LICENSE = "GPL"
+DESCRIPTION = "Guile is an interpreter for the Scheme programming language, \
+packaged as a library which can be incorporated into your programs."
+HOMEPAGE = "http://www.gnu.org/software/guile/guile.html"
+SECTION = "devel/scheme"
+DEPENDS = "guile-native"
MAINTAINER = "Phil Blundell <pb@handhelds.org>"
+LICENSE = "GPL"
+PR = "r1"
+
SRC_URI = "http://ftp.gnu.org/pub/gnu/guile/guile-${PV}.tar.gz \
- file://configure-lossage.patch;patch=1"
-DEPENDS = "guile-native"
+ file://configure-lossage.patch;patch=1 \
+ file://gcc4.patch;patch=1"
inherit autotools