aboutsummaryrefslogtreecommitdiffstats
path: root/packages/guile
diff options
context:
space:
mode:
authorSteve Sakoman <sakoman@tera.(none)>2008-12-31 21:00:59 -0800
committerKoen Kooi <koen@openembedded.org>2009-01-02 17:35:54 +0100
commitdc966c00268b52703205176e85aa0da115064fd2 (patch)
tree1280eb92487f577056bb010b0a756806f5c08b4b /packages/guile
parent17c642af342f768a9cdb15d6a751e10f09918ee9 (diff)
downloadopenembedded-dc966c00268b52703205176e85aa0da115064fd2.tar.gz
guile-native: don't allow configure to specify "-Werr", otherwise
guile-native: don't allow configure to specify "-Werr", otherwise package will not build
Diffstat (limited to 'packages/guile')
-rw-r--r--packages/guile/guile-native_1.8.5.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/packages/guile/guile-native_1.8.5.bb b/packages/guile/guile-native_1.8.5.bb
index b29a7ebd71..e73616e6eb 100644
--- a/packages/guile/guile-native_1.8.5.bb
+++ b/packages/guile/guile-native_1.8.5.bb
@@ -5,6 +5,8 @@ SRC_URI = "http://ftp.gnu.org/pub/gnu/guile/guile-${PV}.tar.gz \
file://configure-fix.patch;patch=1 \
"
+PR = "r1"
+
inherit autotools native
S="${WORKDIR}/guile-${PV}"
@@ -128,3 +130,8 @@ do_stage() {
oe_libinstall -C guile-readline -so -a libguilereadline-v-17 ${STAGING_LIBDIR}
oe_libinstall -C libguile -so -a libguile ${STAGING_LIBDIR}
}
+
+do_configure_append() {
+ find ${S} -name Makefile | xargs sed -i s:'-Werror':'':g
+}
+