aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gzip
diff options
context:
space:
mode:
authorDavid Karlstrom <daka@thg.se>2005-07-30 20:34:12 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-07-30 20:34:12 +0000
commit52b0b44449952398e59147730e3fae6c8d2f0508 (patch)
tree1e2522bcbc05f2cdd518793ece30da1970db0d78 /packages/gzip
parent82eca06c34e4483962439a7e363e1c299cc1c59e (diff)
downloadopenembedded-52b0b44449952398e59147730e3fae6c8d2f0508.tar.gz
Update to follow the FHS and use update-alternatives for gzip, gunzip and zcat
Diffstat (limited to 'packages/gzip')
-rw-r--r--packages/gzip/gzip_1.3.5.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/packages/gzip/gzip_1.3.5.bb b/packages/gzip/gzip_1.3.5.bb
index e99c76dcb4..a138221367 100644
--- a/packages/gzip/gzip_1.3.5.bb
+++ b/packages/gzip/gzip_1.3.5.bb
@@ -5,6 +5,7 @@ MAINTAINER = "Greg Gilbert <greg@treke.net>"
DESCRIPTION = "gzip (GNU zip) is a compression utility designed \
to be a replacement for 'compress'. The GNU Project uses it as \
the standard compression program for its system."
+PR = "r1"
SRC_URI = "${DEBIAN_MIRROR}/main/g/gzip/gzip_${PV}.orig.tar.gz \
file://configure.patch;patch=1"
@@ -12,3 +13,25 @@ SRC_URI = "${DEBIAN_MIRROR}/main/g/gzip/gzip_${PV}.orig.tar.gz \
S = "${WORKDIR}/gzip-${PV}"
inherit autotools
+
+do_install () {
+ autotools_do_install
+ # Rename and move files into /bin (FHS)
+ install -d ${D}${base_bindir}
+ mv ${D}${bindir}/gunzip ${D}${base_bindir}/gunzip.${PN}
+ mv ${D}${bindir}/gzip ${D}${base_bindir}/gzip.${PN}
+ mv ${D}${bindir}/zcat ${D}${base_bindir}/zcat.${PN}
+}
+
+pkg_postinst_${PN} () {
+ update-alternatives --install ${base_bindir}/gunzip gunzip gunzip.${PN} 100
+ update-alternatives --install ${base_bindir}/gzip gzip gzip.${PN} 100
+ update-alternatives --install ${base_bindir}/zcat zcat zcat.${PN} 100
+}
+
+pkg_prerm_${PN} () {
+ update-alternatives --remove gunzip gunzip.${PN}
+ update-alternatives --remove gzip gzip.${PN}
+ update-alternatives --remove zcat zcat.${PN}
+}
+