aboutsummaryrefslogtreecommitdiffstats
path: root/packages/hal
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@openmoko.org>2008-08-28 19:16:59 +0200
committerHolger Hans Peter Freyther <zecke@selfish.org>2008-10-15 21:03:54 +0200
commit20e32f99b62af471dc08ceab0510c336429e83bc (patch)
tree1701dbdaeb2f29ac9d78d45419ab50d25d681e35 /packages/hal
parentbabeb73693b3c8071f52ae3713b7b64463a427ba (diff)
downloadopenembedded-20e32f99b62af471dc08ceab0510c336429e83bc.tar.gz
[hal] Move almost everything into the hal.inc file
hal_0.5.9.bb is the only user of hal.inc and we can safely move everything into the common include file.
Diffstat (limited to 'packages/hal')
-rw-r--r--packages/hal/hal.inc84
-rw-r--r--packages/hal/hal_0.5.9.bb84
2 files changed, 84 insertions, 84 deletions
diff --git a/packages/hal/hal.inc b/packages/hal/hal.inc
index 11a6531951..73046dfb8c 100644
--- a/packages/hal/hal.inc
+++ b/packages/hal/hal.inc
@@ -8,3 +8,87 @@ SRC_URI = "http://freedesktop.org/~david/dist/hal-${PV}.tar.gz"
S = "${WORKDIR}/hal-${PV}"
inherit autotools pkgconfig
+
+DEPENDS = "virtual/kernel dbus-glib udev intltool intltool-native expat libusb"
+RDEPENDS += "udev hal-info"
+RRECOMMENDS = "udev-utils"
+
+SRC_URI += "file://99_hal \
+ file://20hal \
+ "
+
+LEAD_SONAME = "libhal.so"
+
+# machines with pci and acpi get a machine dependant hal
+EXTRA_OECONF = "--with-hwdata=${datadir}/hwdata \
+ --with-expat=${STAGING_LIBDIR}/.. \
+ --with-dbus-sys=${sysconfdir}/dbus-1/system.d \
+ --with-hotplug=${sysconfdir}/hotplug.d \
+ --disable-docbook-docs \
+ --disable-policy-kit \
+ --disable-pmu \
+ --disable-pnp-ids \
+ ${@base_contains('COMBINED_FEATURES', 'pci', '--enable-pci --enable-pci-ids', '--disable-pci --disable-pci-ids',d)} \
+ ${@base_contains('MACHINE_FEATURES', 'acpi', '--enable-acpi', '--disable-acpi',d)} \
+ "
+
+MY_ARCH := "${PACKAGE_ARCH}"
+PACKAGE_ARCH = "${@base_contains('MACHINE_FEATURES', 'acpi', '${MACHINE_ARCH}', '${MY_ARCH}',d)}"
+PACKAGE_ARCH = "${@base_contains('MACHINE_FEATURES', 'pci', '${MACHINE_ARCH}', '${MY_ARCH}',d)}"
+
+do_install_append() {
+ install -d ${D}/etc/default/volatiles
+ install -m 0644 ${WORKDIR}/99_hal ${D}/etc/default/volatiles
+ install -d ${D}/etc/dbus-1/event.d
+ install -m 0755 ${WORKDIR}/20hal ${D}/etc/dbus-1/event.d
+}
+
+do_stage() {
+ oe_libinstall -C libhal -a -so libhal ${STAGING_LIBDIR}
+ oe_libinstall -C libhal-storage -a -so libhal-storage ${STAGING_LIBDIR}
+
+ install -d ${STAGING_INCDIR}/hal
+ install -m 0644 libhal/libhal.h ${STAGING_INCDIR}/hal
+ install -m 0644 libhal-storage/libhal-storage.h ${STAGING_INCDIR}/hal
+}
+
+# At the time the postinst runs, dbus might not be setup so only restart if running
+pkg_postinst_hal () {
+ # can't do this offline
+ if [ "x$D" != "x" ]; then
+ exit 1
+ fi
+
+ grep haldaemon /etc/group || addgroup haldaemon
+ grep haldaemon /etc/passwd || adduser --disabled-password --system --home /var/run/hald --no-create-home haldaemon --ingroup haldaemon -g HAL
+
+ /etc/init.d/populate-volatile.sh update
+
+ DBUSPID=`pidof dbus-daemon`
+
+ if [ "x$DBUSPID" != "x" ]; then
+ /etc/init.d/dbus-1 force-reload
+ fi
+}
+
+pkg_postrm_hal () {
+ deluser haldaemon || true
+ delgroup haldaemon || true
+}
+
+FILES_${PN} = "${sysconfdir} \
+ ${bindir}/lshal \
+ ${bindir}/hal-find-by-capability \
+ ${bindir}/hal-find-by-property \
+ ${bindir}/hal-device \
+ ${bindir}/hal-get-property \
+ ${bindir}/hal-set-property \
+ ${bindir}/hal-lock \
+ ${bindir}/hal-is-caller-locked-out \
+ ${sbindir} \
+ ${libdir}/libhal.so.* \
+ ${libdir}/libhal-storage.so.* \
+ ${libdir}/hal \
+ ${libexecdir} \
+ ${datadir}/hal/fdi \
+ ${datadir}/hal/scripts"
diff --git a/packages/hal/hal_0.5.9.bb b/packages/hal/hal_0.5.9.bb
index daf21f251f..68ee572f25 100644
--- a/packages/hal/hal_0.5.9.bb
+++ b/packages/hal/hal_0.5.9.bb
@@ -1,87 +1,3 @@
require hal.inc
-
-DEPENDS = "virtual/kernel dbus-glib udev intltool intltool-native expat libusb-compat"
-RDEPENDS += "udev hal-info"
-RRECOMMENDS = "udev-utils"
-
PR = "r8"
-SRC_URI += "file://99_hal \
- file://20hal \
- "
-
-LEAD_SONAME = "libhal.so"
-
-# machines with pci and acpi get a machine dependant hal
-EXTRA_OECONF = "--with-hwdata=${datadir}/hwdata \
- --with-expat=${STAGING_LIBDIR}/.. \
- --with-dbus-sys=${sysconfdir}/dbus-1/system.d \
- --with-hotplug=${sysconfdir}/hotplug.d \
- --disable-docbook-docs \
- --disable-policy-kit \
- --disable-pmu \
- --disable-pnp-ids \
- ${@base_contains('COMBINED_FEATURES', 'pci', '--enable-pci --enable-pci-ids', '--disable-pci --disable-pci-ids',d)} \
- ${@base_contains('MACHINE_FEATURES', 'acpi', '--enable-acpi', '--disable-acpi',d)} \
- "
-
-MY_ARCH := "${PACKAGE_ARCH}"
-PACKAGE_ARCH = "${@base_contains('MACHINE_FEATURES', 'acpi', '${MACHINE_ARCH}', '${MY_ARCH}',d)}"
-PACKAGE_ARCH = "${@base_contains('MACHINE_FEATURES', 'pci', '${MACHINE_ARCH}', '${MY_ARCH}',d)}"
-
-do_install_append() {
- install -d ${D}/etc/default/volatiles
- install -m 0644 ${WORKDIR}/99_hal ${D}/etc/default/volatiles
- install -d ${D}/etc/dbus-1/event.d
- install -m 0755 ${WORKDIR}/20hal ${D}/etc/dbus-1/event.d
-}
-
-do_stage() {
- oe_libinstall -C libhal -a -so libhal ${STAGING_LIBDIR}
- oe_libinstall -C libhal-storage -a -so libhal-storage ${STAGING_LIBDIR}
-
- install -d ${STAGING_INCDIR}/hal
- install -m 0644 libhal/libhal.h ${STAGING_INCDIR}/hal
- install -m 0644 libhal-storage/libhal-storage.h ${STAGING_INCDIR}/hal
-}
-
-# At the time the postinst runs, dbus might not be setup so only restart if running
-pkg_postinst_hal () {
- # can't do this offline
- if [ "x$D" != "x" ]; then
- exit 1
- fi
-
- grep haldaemon /etc/group || addgroup haldaemon
- grep haldaemon /etc/passwd || adduser --disabled-password --system --home /var/run/hald --no-create-home haldaemon --ingroup haldaemon -g HAL
-
- /etc/init.d/populate-volatile.sh update
-
- DBUSPID=`pidof dbus-daemon`
-
- if [ "x$DBUSPID" != "x" ]; then
- /etc/init.d/dbus-1 force-reload
- fi
-}
-
-pkg_postrm_hal () {
- deluser haldaemon || true
- delgroup haldaemon || true
-}
-
-FILES_${PN} = "${sysconfdir} \
- ${bindir}/lshal \
- ${bindir}/hal-find-by-capability \
- ${bindir}/hal-find-by-property \
- ${bindir}/hal-device \
- ${bindir}/hal-get-property \
- ${bindir}/hal-set-property \
- ${bindir}/hal-lock \
- ${bindir}/hal-is-caller-locked-out \
- ${sbindir} \
- ${libdir}/libhal.so.* \
- ${libdir}/libhal-storage.so.* \
- ${libdir}/hal \
- ${libexecdir} \
- ${datadir}/hal/fdi \
- ${datadir}/hal/scripts"